Announcement

Collapse
No announcement yet.

Can I upgrade from vBulletin 4.2.2 Patch Level 4 to vBulletin v5 Connect?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can I upgrade from vBulletin 4.2.2 Patch Level 4 to vBulletin v5 Connect?

    Dear Sir/Madam,

    We have a forums running 4.2.2 Patch Level 4.

    We would like to upgrade to vBulletin v5 Connect.

    We have lost the log in information required for the upgrade so we are thinking of purchasing a new version of vBulletin v5 Connect.

    Is it possible to upgrade from vBulletin 4.2.2 Patch Level 4 to vBulletin v5 Connect with a new version?

    Will we be able to retain the style template and posts from the current forums?

    Thank you

  • #2
    Yes. You can do a direct upgrade and all your current data except calendar events will be migrated. vBulletin 4 styles are not compatible with vBulletin 5. vBulletin 5 uses a different variable system in an attempt to make things more secure. You would have to recreate your style.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      One very important thing you need to check before upgrading from VB 4.x to VB 5.x is to make your default database collation matches what you had used for VB 4.x. I have found for many people, especially English language forums when VB 4.x may have been installed years ago the database default was latin1_swedish_ci but more modern servers may be set to utf8_gengeral_ci or something else.

      In phpmyadmin or another mysql tool check the collation of the post and thread tables in VB4 and make sure the database default is set to the same before upgrading otherwise you will wind up with lots of errors.

      Comment


      • #4
        Thank you Wayne and Joe for the information.

        Comment


        • #5
          Thanks Joe and Wayne, What is the strategy for upgrading calendar, we have hundreds of calendar entries needed for historical audit purposes?

          Comment


          • #6
            Originally posted by YK0302 View Post
            Thanks Joe and Wayne, What is the strategy for upgrading calendar, we have hundreds of calendar entries needed for historical audit purposes?
            vB4 calendar entries are not imported into vB5's calendar. There is no way round this.
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.4.4 Demo
            AdminAmmo - My Cloud Demo

            Comment


            • #7
              Originally posted by YK0302 View Post
              Thanks Joe and Wayne, What is the strategy for upgrading calendar, we have hundreds of calendar entries needed for historical audit purposes?
              Unfortunately we can't offer any such solution. However if you keep a backup of the database tables dealing with VB4 calendar events before upgrading you may be able to find someone or some 3rd party service who can do the conversion for you or perhaps create some kind of add-on to at least present the content in some useful format to your users even if it is as a "read only" option.

              Comment


              • #8
                Originally posted by Joe D. View Post

                Unfortunately we can't offer any such solution. However if you keep a backup of the database tables dealing with VB4 calendar events before upgrading you may be able to find someone or some 3rd party service who can do the conversion for you or perhaps create some kind of add-on to at least present the content in some useful format to your users even if it is as a "read only" option.
                Thanks Joe and Mark, This could be a show stopper for us. I'll look at the display only option. We use reoccurring events a lot. I can't see any provision for reoccurring events either, are they supported?

                Comment


                • #9
                  Recurring events are not supported by the vBulletin 5 data model.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                  vBulletin 5 Documentation - Updated every Friday. Report issues here.
                  vBulletin 5 API - Full / Mobile
                  I am not currently available for vB Messenger Chats.

                  Comment

                  Related Topics

                  Collapse

                  Working...
                  X