Announcement

Collapse
No announcement yet.

WYSiWYG editor cuts posts

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • WYSiWYG editor cuts posts

    I have strange problem on my board.
    When writing posts using WYSiWYG editor, sometimes it cuts posts after enter (not always first enter, but in one post always same). Sometimes no matter how many times will i edit my post, it will be cut in same place again.
    It never happens, when I use simplified editor.

    Any ideas?
    my forum address is http://wowpilot.com/forum/

  • #2
    Bump. I'm having the SAME problem.

    Comment


    • #3
      Are you copy-n-pasting from something else? That is the usual cause of this. Apps like MS Word, for instance, have lots of hidden code in them.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        Negative, Steve.

        Anything done in the WYSIWYG editor that has multiple lines magically kills lines. Also, when people are trying to quote, it sometimes screws that quote up by cutting off the end of it.

        I...

        1) Reverted all templates to the original style.
        2) Ran Diagnostics. All files match up.
        3) Ran all rebuilding of indexes.

        Still, WYSIWYG is having problems. I upgraded from 3.6.0 and didn't expect for us to lose that editor.

        Comment


        • #5
          Does the same thing happen to you here? This is not something that occurs with the default vB code and templates, so I would suspect this is due to a modification you made.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            It is 100% not because of modification.

            We have three vbulletins on the server we are running on. All three forums suffer from this. Two are unmodified, one is modified.

            It's the WYSIWYG and whatever it's accessing on the server.

            Comment


            • #7
              Do you have the same problem here?
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Negative. It does NOT happen here.

                We tested it on a fresh install.

                We quoted someone with multiple lines as a reply... it leaves only the first line and chops everything under. We sometimes get "message is not long enough" errors, too.

                We're thinking it has something to do with the ' . It's like it doesn't know how to escape it properly in PHP? We are throwing in ' " '" randomly and it's seeming to truncate and chop.

                Comment


                • #9
                  What language and encoding are you using? If you are using UTF-8 you may have to empty the Blank Character Stripper for certain characters to work properly.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                  vBulletin 5 Documentation - Updated every Friday. Report issues here.
                  vBulletin 5 API - Full / Mobile
                  I am not currently available for vB Messenger Chats.

                  Comment


                  • #10
                    It also may be due to suhosin. Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

                    Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Here is phpinfo:

                      http://www.fullthrottlev6.com/forums/?do=phpinfo

                      Comment


                      • #12
                        www.roadraceforum.com/forums/

                        You can sign up here -
                        u: vbulletin
                        p: vbtest

                        Quote any garbage in the top thread. Add tons of single quotes, double quotes, smilies. You'll see the truncating in action.

                        Comment


                        • #13
                          Hmmm..I don't see anything that I recognize would cause this. However since it is not happening here, and you say this does not ocur with the original vB code and templates, then the only other possibility is a server issue.

                          I'll ask the other staff if they may have some ideas.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            Could you open a support ticket providing AdminCP, FTP and phpMyAdmin login details please.
                            Best Regards
                            Colin Frei

                            Please don't contact me per PM.

                            Comment


                            • #15
                              Submitted!

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X