Announcement

Collapse
No announcement yet.

How to delete all Posts to Moderate + Threads to Moderate

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to delete all Posts to Moderate + Threads to Moderate

    Hi,

    When i go to the admin cp up the top it displays ;

    Threads to Moderate - xx
    Posts to Moderate - xxxx

    My problem is that when I try to delete all of them, it has to load thousands of posts and when it does eventually load, it does not delete, so i tried to execute some commands to make them all appear yet the moderation que is still there.

    How to I remove of all these posts please ?

    Kind regards.

    Daniel.

  • #2
    This may be a server time and/or memory limit. To temporarily up your limits edit your includes/config.php file and add these lines right under the <?php line:

    ini_set('memory_limit', 64 * 1024 * 1024);
    ini_set("max_execution_time", "800");
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Problem is, it takes so long to load and it lags my pc totally, can I just have a query to delete?

      Comment


      • #4
        No sorry, there is no simple query to do this.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          thanks, worked.

          Comment


          • #6
            Hello,

            I am having the same issue, I need to delete about 9000 posts from the moderated section, but the browser stucks in loading the page...

            I have tuned to the following lines my php.ini ... I don't have access to the config.php, but it should be the same:

            PHP Code:
            max_execution_time 1000     Maximum execution time of each scriptin seconds
            max_input_time 
            60    Maximum amount of time each script may spend parsing request data
            memory_limit 
            64M      Maximum amount of memory a script may consume (32MB
            Do I have to tune it differently or any other suggestion?

            The default values were:
            PHP Code:
            ;max_execution_time 30     Maximum execution time of each scriptin seconds
            ;max_input_time 60    Maximum amount of time each script may spend parsing request data
            ;memory_limit 32M      Maximum amount of memory a script may consume (32MB

            Thank you
            Hosting Migliore

            Comment


            • #7
              I add that the message that I am having is:

              Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 24903681 bytes) in /home2/badjobco/public_html/forums/includes/adminfunctions.php on line 826

              Please help...
              Hosting Migliore

              Comment


              • #8
                Your PHP does not have enough memory allocated to it to complete this operation. Ask your host to increase the 'memory_limit' variable in php.ini to at least 64M.

                To temporarily up your limits edit your includes/config.php file and add these lines right under the <?php line:

                ini_set('memory_limit', 64 * 1024 * 1024);
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  As I wrote two posts ago I don't have access to config.php, I only can change he php.ini.

                  Now the php.ini has those values:
                  Code:
                  ;;;;;;;;;;;;;;;;;;;
                  ; Resource Limits ;
                  ;;;;;;;;;;;;;;;;;;;
                  
                  max_execution_time = 2000     ; Maximum execution time of each script, in seconds
                  max_input_time = 600    ; Maximum amount of time each script may spend parsing request data
                  memory_limit = 128M      ; Maximum amount of memory a script may consume (32MB)
                  But the problem is persisting
                  Hosting Migliore

                  Comment


                  • #10
                    Everyone has access to config.php. It's a part of vB. Nonetheless at this point you should start your own thread.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      I hate to bring this up again, but I have the SAME problem, but with 54,000 threads and I have the feeling the suggested "tricks" are going to do the job, my browser is dying just by opening the page, let alone clicking on something. is it possible to directly delete the mod queue from the sql database?

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X