Announcement

Collapse
No announcement yet.

class_core.php on line 1030

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • class_core.php on line 1030

    Hello I am trying to create a test forum which is a copy of my live forum. I exported my live forum to a file, then imported it into a test database I created. There is one difference between these two databases, my live forum db is mySQL 4.0 and my test forum db is mySQL 4.1. So I updated my config.php file to specify:

    $config['Database']['dbtype'] = 'mysqli';

    However, by doing this I am getting the fatal error for class_core.php on line 1030. If I leave this value 'mysql', I basically just get a default IE 'database error' html page with no explanation. I have used this test forum in the past about 6 months ago and it worked with no problem, the only difference now is the db versions. Would this cause my database error? At least since I get the class_core error does this at least tell me I am connecting to the db?

    Any help appreciated!

  • #2
    When you get the database error with it set to MySQL (not MySQLi), right click on the page and choose View Page Source, and copy what it says here. It has the full error message.

    Comment


    • #3
      Here's the error (and btw thanks for this info I never realized the browser source is where you could get the complete error):

      Database error in vBulletin 3.5.4:
      Invalid SQL:
      REPLACE INTO datastore
      (title, data, unserialize)
      VALUES
      ('birthdaycache', 'a:4:{s:4:\"day1\";s:10:\"2007-09-23\";s:4:\"day2\";s:10:\"2007-09-24\";s:6:\"users1\";N;s:6:\"users2\";N;}', 1);
      MySQL Error : Unknown column 'unserialize' in 'field list'
      Error Number : 1054

      Interesting error, since I don't know why there would be a difference in tables between the two db's (it's just export/import of the same file)...

      Comment


      • #4
        Hey I think I just solved my own problem. I forgot that about 4 months ago I upgraded my test forum to vBulletin 3.6 but did not upgrade my existing forum. So the vBulletin files are out of synch. I have no doubt this is the issue.

        But thanks for the help though I appreciate it!

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X