Announcement

Collapse
No announcement yet.

Error 2013 but server up for 6 days

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by blazin
    I had the ISP set the wait_timeout value to 28800... so far no errors!!! its been about 10 hours.... never went that long without getting them so this is a good sign.

    Thanks guys for your help!
    no probs
    :: Always Back Up Forum Database + Attachments BEFORE upgrading !
    :: Nginx SPDY SSL - World Flags Demo [video results]
    :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

    Comment


    • #17
      Still, NO errors, I think i found my solution!

      Comment


      • #18
        now i have the same problems.
        my ISP have the wait_timeout value set to 8.

        i hope i can get him to change that!
        php-resource.de
        The PHP Developer Community

        Comment


        • #19
          Originally posted by php-resource.de
          now i have the same problems.
          my ISP have the wait_timeout value set to 8.

          i hope i can get him to change that!
          8 !

          you might as well not access mysql at that setting!
          :: Always Back Up Forum Database + Attachments BEFORE upgrading !
          :: Nginx SPDY SSL - World Flags Demo [video results]
          :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

          Comment


          • #20
            i checked this setting with mysqlfront.
            maybe ther is a bug in this...
            php-resource.de
            The PHP Developer Community

            Comment


            • #21
              Originally posted by blazin
              I had the ISP set the wait_timeout value to 28800... so far no errors!!! its been about 10 hours.... never went that long without getting them so this is a good sign.

              Thanks guys for your help!
              I keep getting the error 2013 every now and then, maybe on average threee times per day. I emailed my host about the timeout value and they came back with:

              Our engineers have investigated the issue you have been experiencing and have suggested the following:
              The wait timeout on our share mysql servers is set to 300 seconds to avoid too many persitent inactive connections to the server, you may want to look into configuring the scripts to avoid persistent connections.

              Is this likely to be the problem? If so, will I get more errors as my userbase increases and will this be problematic?

              Thanks,
              Kerry

              Comment


              • #22
                You can turn off persistant connections in your config.php:

                PHP Code:
                // use persistant connections to the database
                // 0 = don't use
                // 1 = use
                $usepconnect 0
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #23
                  This is already set to 0 but I still occasionally get the errors.

                  Comment


                  • #24
                    Post the exact and complete error.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #25
                      Originally posted by Steve Machol
                      Post the exact and complete error.
                      Database error in vBulletin 2.3.0:
                      Invalid SQL: UPDATE session SET lastactivity=1047315097,location='/forum/showthread.php?s=&threadid=436' WHERE sessionhash='255dd65b2cf8d964dc6ac881a2fae22c'
                      mysql error: Lost connection to MySQL server during query
                      mysql error number: 2013
                      Date: Monday 10th of March 2003 05:14:47 PM
                      Script:
                      http://www.soccerpages.com/forum/forum/showthread.php?s=&threadid=436
                      Referer:

                      Database error in vBulletin 2.3.0:
                      Invalid SQL: UPDATE LOW_PRIORITY thread SET views=views+1 WHERE threadid='436' mysql error: Lost connection to MySQL server during query
                      mysql error number: 2013
                      Date: Monday 10th of March 2003 04:31:25 PM
                      Script:
                      http://www.soccerpages.com/forum/forum/showthread.php?s=&threadid=436
                      Referer: http://www.google.pl/search?lr=lang_en&cr=&q=Ajax+Feyenoord+hooligans&hl=pl&inlang=pl&ie=ISO-8859-2

                      Comment


                      • #26
                        This is still a server issue. You need to contact your host about this. Let them know that you have already confirmed that vB is running with persistant connections turned off.

                        See this post for the possible causes of a lost connection error:

                        http://www.vbulletin.com/forum/showt...265#post310265
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #27
                          [QUOTE='Steve Machol']This is still a server issue. You need to contact your host about this. Let them know that you have already confirmed that vB is running with persistant connections turned off.

                          See this post for the possible causes of a lost connection error:

                          http://www.vbulletin.com/forum/showthread.php?s=&postid=310265#post310265[/QUOTE]

                          I recently got this reply from my host:

                          Dear Sir,
                          Thank you for your recent enquiry on ticket 25454.
                          After further investigation our Engineers confirm that the errors you have reported is not related to the running of .PHP on the web server or MySQL on the MySQL server as there are several sites running vBulletin successfully without error on our Linux webservers. Unfortunately we are unable to assist any further.

                          What do I do now?

                          Thanks,
                          Kerry

                          Comment


                          • #28
                            Sorry but I don't see how they can say a lost connection to MySQL is not a server issue. Have you installed any hacks, or any additional scripts to the headinclude, header, or phpinclude templates? If so, remove them and see if the problem goes away.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #29
                              I haven't installed anything additional.

                              Comment


                              • #30
                                If that's true then there is no reason for those errors on a properly configured server. Sorry but there's nothing more I can recommend. The issue is still the server.
                                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                                Steve Machol Photography


                                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X