Announcement

Collapse
No announcement yet.

Problem With E-Mail Links

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem With E-Mail Links

    1. (primary issue) In my postbit template is $post[useremail] , which obviously contains the contents of my useremail template. However, even if my profile has the "allow e-mail" turned on this link isn't appearing within threads. Yet here at vBulletin it most definitely is. Is there any reason, bar the profile setting, that would cause this variable to not contain the template data?

    2. (secondary concern) In the postbit template the e-mail link is only processed if the member in question says they want their e-mail allowed. Yet in the member profile (user info display template) the e-mail link is hard-coded into the template, in other words it appears for every single person regardless of whether they have their e-mail option on or off?

    Thanks,

  • #2
    Wierd, I just got the following e-mail:
    Black Tiger has just replied to a thread you have subscribed to entitled - Problem With E-Mail Links - in the vBulletin 2.0 Troubleshooting and Problems forum of vBulletin Community Forum.

    This thread is located at:
    http://161.58.84.213/forum/showthrea...0&goto=newpost
    Yet that reply is definitely not here.

    Why is vBulletin.com coming up as an IP address these days anyway?

    Comment


    • #3
      He may have replied and then deleted the message.

      The IP is because John and co. are getting the new server all set and then they'll transfer the domain over.

      Comment


      • #4
        ^bump^

        Comment


        • #5
          Ensure that these options are set in your main options section of the admin control panel.

          Comment


          • #6
            You were right that was off!!! I was quickly scanning through those options (VERY long page) and not seeing that, but instead the other "e-mail options" which only has "Enable Email features?".

            Thanks Kier

            Comment


            • #7
              I'm not entirely sure why, but the display emails option is automatically set to 'no' for new installs...

              I'll ask the other guys if there is a specific reason for that...

              Glad your problem's fixed though.

              Comment


              • #8
                I would think the option is set to NO as default for privacy reasons.

                It's best to setup the defaults with maximum privacy in place, and then if the admin wants to losen restriction, *they* have to actively do it.

                Remember, you can't count on the individual users on the board to know or care about privacy, though it should be expected.
                Brian Shea (G+)
                FallenBrothers.com and SevenSages.com

                Comment

                Loading...
                Working...
                X