Announcement

Collapse
No announcement yet.

I have old mysql databases

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • kbarg
    started a topic I have old mysql databases

    I have old mysql databases

    If I buy a new license. Is there any way I can upgrade old databases I have from like 3.8 series to the latest version?

    I wanted to know before I bought a license.

  • Wayne Luke
    replied
    Please disable hooks via the /includes/config.php file. These won't carry over to vBulletin 5 anyway.

    Please disable all plugins on your board and tell us if the problem persists.

    To do this, edit your vBulletin config.php file currently on the server by adding the following line after the <?php line:

    define('DISABLE_HOOKS', true);

    Then reupload the config.php file into your forum's includes folder.

    Leave a comment:


  • kbarg
    replied
    I fixed that with the tools.php file. But NOw I have this error LOL sorry.

    Call to undefined function split() on line 40 in /home/vbull/public_html/includes/class_bootstrap.php(433) : eval()'d code
    #0 /home/vbull/public_html/includes/class_bootstrap.php(433): eval()
    #1 /home/vbull/public_html/includes/class_core.php(4391): vB_Bootstrap->process_templates()
    #2 /home/vbull/public_html/includes/class_core.php(4349): vB_Template->__construct('forumjump')
    #3 /home/vbull/public_html/includes/functions.php(4475): vB_Template::create('forumjump')
    #4 /home/vbull/public_html/includes/functions.php(3640): construct_quick_nav(Array, -1, true, true)
    #5 /home/vbull/public_html/includes/class_bootstrap.php(856): standard_error('Your password i...')
    #6 /home/vbull/public_html/includes/class_bootstrap.php(82): vB_Bootstrap->check_state()
    #7 /home/vbull/public_html/global.php(26): vB_Bootstrap->bootstrap()
    #8 /home/vbull/public_html/forum.php(67): require_once('/home/vbull/pub...')
    #9 /home/vbull/public_html/index.php(43): require('/home/vbull/pub...')
    #10 {main}

    Leave a comment:


  • kbarg
    replied
    Nor can I login directly to the admincp it just keeps reloading.

    Leave a comment:


  • kbarg
    replied
    It upgraded to 4.2.5

    Before I upgrade it further I wanted to login and make sure everything worked properly.

    I no longer have the old domain used back in 2008, and I am using a different domain. I cannot login. Everytime I do it tries to redirect me to the old website domain.

    Leave a comment:


  • kbarg
    replied
    Wayne Luke Outstanding, the upgrade is going through. Thank you for your help.

    Leave a comment:


  • Wayne Luke
    replied
    You'll need to manually delete the duplicates. It looks like you allowed Guests to vote on polls which causes this problem.

    Code:
    SELECT `pollid`, `userid`  FROM vb_pollvote GROUP BY `pollid`, `userid` HAVING count(`pollid`) > 1 AND count(`userid`) > 1
    That will return a list of poll IDs with duplicates. Delete duplicate rows until the query returns no results.

    Or you can delete the contents of your vb_pollvote table and invalidate all previous results.

    Code:
    TRUNCATE TABLE vb_pollvote;

    Leave a comment:


  • kbarg
    replied
    Ok, it is fixed. I had 7.1 installed but my cpanel defaulted to 7.3

    I am getting this error now:

    I am trying to upgrade from 3.6.8 to 4.2.5:

    Click image for larger version

Name:	example.png
Views:	33
Size:	60.4 KB
ID:	4414612
    Attached Files

    Leave a comment:


  • Mark.B
    replied
    PHP needs to be either 5.6, 7.0 or 7.1.

    No other php versions will work for 4.2.5.

    Leave a comment:


  • kbarg
    replied
    I did use my correct member id....

    Leave a comment:


  • kbarg
    replied
    I keep getting this garbarge
    • 4.2.5
    • 4.2.5
    • 4.2.5
    • 4.2.5
    • 4.2.5
    • 4.2.5
    • vbulletin-style.xml:
    • vbulletin-mobile-style.xml:
    • vbulletin-settings.xml:
    • vbulletin-language.xml:
    • vbulletin-navigation.xml:
    • vbulletin-adminhelp.xml:


    vBulletin 4.2.5 Upgrade System
    (Please be patient as some parts may take some time)
    Upgrading to 4.2.5
    Status: Aborted

    Action Required Unexpected Text:
    <br /> <b>Warning</b>: Use of undefined constant MYSQL_NUM - assumed 'MYSQL_NUM' (this will throw an Error in a future version of PHP) in <b>/home/user/public_html/vbull/install/init.php</b> on line <b>119</b><br /> <br /> <b>Warning</b>: Use of undefined constant MYSQL_ASSOC - assumed 'MYSQL_ASSOC' (this will throw an Error in a future version of PHP) in <b>/home/user/public_html/vbull/install/init.php</b> on line <b>119</b><br /> <br /> <b>Warning</b>: Use of undefined constant MYSQL_BOTH - assumed 'MYSQL_BOTH' (this will throw an Error in a future version of PHP) in <b>/home/user/public_html/vbull/install/init.php</b> on line <b>119</b><br /> <br /> <b>Warning</b>: Use of undefined constant file - assumed 'file' (this will throw an Error in a future version of PHP) in <b>/home/user/public_html/vbull/install/includes/class_upgrade.php</b> on line <b>1267</b><br /> <br /> <b>Warning</b>: Use of undefined constant file - assumed 'file' (this will throw an Error in a future version of PHP) in <b>/home/user/public_html/vbull/install/includes/class_upgrade.php</b> on line <b>1267</b><br /> <br /> <b>Warning</b>: Use of undefined constant file - assumed 'file' (this will throw an Error in a future version of PHP) in <b>/home/user/public_html/vbull/install/includes/class_upgrade.php</b> on line <b>1267</b><br /> <br /> <b>Warning</b>: Use of undefined constant file - assumed 'file' (this will throw an Error in a future version of PHP) in <b>/home/user/public_html/vbull/install/includes/class_upgrade.php</b> on line <b>1267</b><br /> <br /> <b>Warning</b>: Use of undefined constant file - assumed 'file' (this will throw an Error in a future version of PHP) in <b>/home/user/public_html/vbull/install/includes/class_upgrade.php</b> on line <b>1267</b><br /> <br /> <b>Warning</b>: sizeof(): Parameter must be an array or an object that implements Countable in <b>/home/user/public_html/vbull/includes/class_core.php</b> on line <b>4224</b><br /> <?xml version="1.0" encoding="windows-1252"?> <error>Customer Number Incorrect</error>

    Leave a comment:


  • kbarg
    replied
    Right on. I purchased a license before I got a response anyways. Sorry.

    I had a license purchased for a site that i ran a LONG time ago. The person who purchased the license disappeared a long time ago, and lucky I had backups. I found them on an old USB stick (the flash drive it was on was a 256mb, you can tell that was well over 10 years ago) wanted to view them . I know it seems silly to buy a license just to view old MySQL databases.

    Leave a comment:


  • Wayne Luke
    replied
    You don't need to install 3.8.X to upgrade the database to a newer version. If you have a complete database backup SQL file, then you can simply restore that file into MySQL/MariaDB and then run the upgrade script for either vBulletin 4.2.5 or 5.5.1. The script will update the database as needed.

    However, with a vBulletin 5 license, you can download one copy from the 3, 4, or 5 series.

    Leave a comment:


  • kbarg
    replied
    I mean install the 3.8 version I am using with a downloadable tarball. So I can upgrade it. I noticed you said your licenses come with VB4 included, but it doesn't say 3.0 series, so I was curious.

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X