Announcement

Collapse
No announcement yet.

Vbulletin upgrade failining

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Vbulletin upgrade failining

    Hello,

    I am o the 3rd forum upgrade and I am having some issues. I opened ticket 2287288, but till support has time to review my ticket, does anyone knows what there is to be done in this issue? I am runing the php update.php from ssh but it is failing at this step with this message :

    Upgrading to 5.0.0 Alpha 1
    ----------------------------------
    Step 132 - Error Could not find phrase 'invalid_contenttype_class_specified'. Arguments given were: "0' on /home/loganclub/public_html/core/vb/types.php : 591
    #0: vB_Utilities::getStackTrace() called in /[path]/core/install/includes/class_upgrade_cli.php on line 329
    #1: vB_Upgrade_Cli->execute_step(132, vB_Upgrade_500a1) called in /[path]/core/install/includes/class_upgrade_cli.php on line 283
    #2: vB_Upgrade_Cli->process_script('500a1') called in /[path]/core/install/includes/class_upgrade_cli.php on line 166
    #3: vB_Upgrade_Cli->init(NULL) called in /[path]/core/install/includes/class_upgrade.php on line 845
    #4: vB_Upgrade_Abstract->__construct(vB_Registry, array[len:10], 'upgrade', NULL, array[len:0]) called in /[path]/core/install/includes/class_upgrade_cli.php on line 90
    #5: vB_Upgrade_Cli->__construct(vB_Registry, array[len:10], 'upgrade', NULL, array[len:0]) called in /[path]/core/install/includes/class_upgrade.php on line 54
    #6: vB_Upgrade::fetch_library(vB_Registry, array[len:10], '', true) called in /[path]/core/install/upgrade.php on line 156

  • #2
    Can anyone help? I have opened my ticket 2 days ago

    Comment


    • #3
      Did this site have addons before upgrading? Please remove them and their generated content.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud customization and demonstration site.
      vBulletin 5 Documentation - Updated every Friday. Report issues here.
      vBulletin 5 API - Full / Mobile
      I am not currently available for vB Messenger Chats.

      Comment


      • #4
        If the upgrade went till vbulletin 5 .0.0.1 alpha, could it be an addon problem? I am installing it on a clean server, so only vbulletin 5 new script and database dump. Please assist, as this is the biggest forum, and I have no ideea how to proceed to get the upgrade done. Credentials are in the ticket.

        Thanks.

        Comment


        • #5
          It is a Content Type problem. There is no PHP class in vBulletin 5 to deal with one of the content types that exist in your contenttype table. Yes, this can carry over from vBulletin 4 if you had third-party addons that installed contenttypes but were not installed.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud customization and demonstration site.
          vBulletin 5 Documentation - Updated every Friday. Report issues here.
          vBulletin 5 API - Full / Mobile
          I am not currently available for vB Messenger Chats.

          Comment


          • #6
            So how to proceed? Should I uninstall all the plugins or disabiling them should be fine?

            LE I have uninstalled everything, but the update still fails at that step.Also not interested in having any modifications from version 3.7.x so I am willing to modify everything just to have all the information. Please advice.
            L.E.2 I think also this issue can be related with this problem that I had years ago, still have those classnames there. How can I get rid of them?
            https://www.vbulletin.com/forum/foru...nt-api-problem

            L.E.3 I have fixed that issue, with debug mode, deleted those classnames. Update script still fails at the same step. All the products are uninstalled.

            Thanks.
            Last edited by Cristi_XP; Thu 8th Nov '18, 3:04am.

            Comment


            • #7
              You should unistall third-party plugins and delete their data before upgrading as stated in my first reply.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud customization and demonstration site.
              vBulletin 5 Documentation - Updated every Friday. Report issues here.
              vBulletin 5 API - Full / Mobile
              I am not currently available for vB Messenger Chats.

              Comment


              • #8
                I have uninstalled everything that could been uninstalled...

                Comment


                • #9
                  I don't know what the issue is. You'll need to restore the vBulletin 4.X database from before you started your upgrade process and provide full server access in your ticket so someone can look at it.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                  vBulletin 5 Documentation - Updated every Friday. Report issues here.
                  vBulletin 5 API - Full / Mobile
                  I am not currently available for vB Messenger Chats.

                  Comment


                  • #10
                    I will also give you the credentials to the live server so you can check there. I am using vbulletin 3.7.4 and on this version works. The update goes till 5.0.0.1 Alpha, so if I am to install vbulletin 4, I think it should work, but I am installing 5.
                    Ticket updated with the information you need. Please help with this issue, as the old server has issues because of the php5.2, so I need to update fast to the new server.
                    Thanks!
                    Last edited by Cristi_XP; Fri 9th Nov '18, 5:24am.

                    Comment


                    • #11
                      Guys, I don`t wanna be stressing you, but there are 5 days since my ticket was opened and the only reply I had after first days was to provide an ftp account, after that silence. I am in really need of support here, as its not something that I am able to do by myself as update is failing. Can someone please help? I have provided live website credentials and also the new server information where I should update the vbulletin 5, uninstalled everything as requested...
                      Last edited by Cristi_XP; Fri 9th Nov '18, 5:28am.

                      Comment


                      • #12
                        What php version are you running? It needs to be at least php 5.6 for vBulletin 5.
                        MARK.B | vBULLETIN SUPPORT

                        TalkNewsUK - My vBulletin 5.4.4 Demo
                        AdminAmmo - My Cloud Demo

                        Comment


                        • #13
                          On the new server where I try to install but fails, I am using php 7.2 ... 7.1 or 7.0 - fails with all of them.
                          On the old server which is curently live and try to upgrade the DB to the new vbulletin, I am runing php5.2... and need to get rid of it fast.
                          Last edited by Cristi_XP; Fri 9th Nov '18, 7:11am.

                          Comment


                          • #14
                            Ticket updated with all the requested information. Can you please assist?

                            Comment


                            • #15
                              Does anyone has any news for me? I have done anything that was requested... and my ticket is 10 days old... without any resolution.

                              Thanks.

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X