Announcement

Collapse
No announcement yet.

upgrade from 5.4.1 to 5.4.3

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • upgrade from 5.4.1 to 5.4.3

    Hi ! when i uploaded the new files to overwrite existing files, i did transfer first with Plesk with overwrite option but I get file fusion, every new file is inside the old file: the new file "core" is inside the old file "core" ...etc.. i repeat uploading with Filezilla (overwriting option) = no changes, the upgrade was finish, but when i remove the install directory i found 2 of course that i removed, the site looks working perfectly at first sight, but i think it's not a clean upgrade..

    Please how to make this upgrade clean ? should I remove old files ( specified with date) ? the site is under construction but almost finished, should I reinstall VB ? thank you very much for help..
    Last edited by bendiesel; Wed 12th Sep '18, 2:47pm.

  • #2
    You should overwrite all of the existing files when prompted to do so. On a brand new site you can most likely get away with deleting the existing files and then reinstalling the default files from the upload folder if you don't have any customizations which required uploading files to the server. You should still run the upgrade, not the install to prevent the upgrade from overwriting your existing database.

    Comment


    • #3
      I did exactly as the instructions in documentation: filezilla, overwriting... etc, but i found old files inside the new files, this is very annoying and it make me lose time and energy to make the VB clean after upgrade, i ask if i can remove old files still existing in the new files after making the upload and the upgrade ? can I do this please to make VB clean ? or it's normal that I see old files inside new files ? thank you for your time and help..

      Comment


      • In Omnibus
        In Omnibus commented
        Editing a comment
        Can you be more specific about what you mean by "old files?" Are there a handful of old files or are there duplicates of everything?

    • #4
      they are the duplicate of every thing..

      Comment


      • #5
        Click image for larger version

Name:	1.png
Views:	1
Size:	52.6 KB
ID:	4398326

        Click image for larger version

Name:	2.png
Views:	1
Size:	48.1 KB
ID:	4398327

        this is a screeshot, we can see old (12sep) and new files (13sep)

        Comment


        • #6
          Those are two different folders. Look at the paths. One is "core" and the other is "core/core"

          There should not be a "core" folder inside the /core folder.

          Comment


          • #7
            yes this is the issue i get with all folders, i wonder if i can just delete the old folders to make it clean, is it possible ?

            Comment


            • #8
              Here's what I'd do, since it appears you're in root.

              1. Close the site in the admincp
              2. Make a new folder in httpdocs called oldfiles (or whatever you like)
              3. Move EVERYTHING ELSE into that folder
              4. Upload a fresh set of 5.4.3 files
              5. Copy the /core/includes/config.php folder out of oldfiles back into /core/includes in the root.
              6. Copy any image files (smilies, icons, and also attachments and avatars if they are stored in the file system) from oldfiles back to the correct position in the root.
              7. You may need to copy any other custom stuff such as htaccess etc from oldfiles into live
              8. Test the site loads ok
              MARK.B | vBULLETIN SUPPORT

              TalkNewsUK - My vBulletin 5.4.4 Demo
              AdminAmmo - My Cloud Demo

              Comment


              • #9
                thank you very much Mark.B ! i'm so grateful it works perfect !

                for those who find this clarification useful, in my case i also:

                1- copied the old files: config.php (already existing in /core/includes) and config.php.bkp in the root, just to follow your 7th point, and my old configuration before any upgrade.
                2- the site loads OK, so i was able to run the upgrade script, a window tell me that a table is already existing and you may run this for the 2nd time, i continue the upgrade
                3- i moved the old files in another directory off the httpdocs, just to keep it safe
                4- the site is perfect and running with 5.4.3, with all customisation

                God bless you Mark..

                many thanks also for In Omnibus

                Comment

                Related Topics

                Collapse

                Working...
                X