Announcement

Collapse
No announcement yet.

5.2.3->5.4.3 Upgrade Failing

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 5.2.3->5.4.3 Upgrade Failing

    Trying to upgrade an older 5.2.3 site to 5.4.3 and I got stuck at 5.2.5 alpha, which just timeouts almost immediately (about 5 seconds).
    The server returned no response. This is probably due to a timeout setting. Please contact vBulletin Support for assistance

    Script: 525a3
    Step: 4

    And the details:
    Upgrade Progress
    • Step 4 - The server returned no response. This is probably due to a timeout setting. Please contact vBulletin Support for assistance
    Our web log generally agrees:
    IP - - [21/Aug/2018:16:30:30 -0700] "POST /core/install/upgrade.php?version=525a3&step=4 HTTP/1.1" 200 255 "http://site/core/install/upgrade.php" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.106 Safari/537.36"
    Nothing else apparent in other log files. The web server is otherwise fine.

  • #2
    I've done some work to make sure that neither our fail2ban or our iptables are getting in the way, and the upgrade still times out at that point.

    Comment


    • #3
      I tuned up a few variables suggested elsewhere:

      max_execution_time = 120; [from 30]
      max_input_time = 120; [from 60]
      max_input_vars = 1000; [from missing]
      memory_limit = 1024M; [from 128M]

      That seemed to get me through this:
      • ------ Query Status ------
      • Time Elapsed: 00:01:12, State: updating, Query: DELETE FROM cacheevent WHERE `event` IN ('vB_Language_languageCache') /**cacheevent**/
      Onward ... We're now chugging through the 5.3s ...

      Comment

      Related Topics

      Collapse

      Working...
      X