Announcement

Collapse
No announcement yet.

Fatal Error Occurred when upgrading vbulletin from 4.2.5 to 5.3.4

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fatal Error Occurred when upgrading vbulletin from 4.2.5 to 5.3.4

    We are trying to upgrade from 4.2.5 to 5.3.4 in our lab environment but cannot perform the upgrade.

    Error message:
    "500a1 Step #132
    Fatal Error Occurred
    Error Could not find phrase 'invalid_contenttype_class_specified'. Arguments given were: "0' on C:\inetpub\sites\testsitename\testvb\core\vb\types.php : 589

    Script: 500a1
    Step: 132"

    Please help with this. I cant understand what is wrong and we wish to upgrade as soon as possible.
    Last edited by Mr B; Fri 8th Dec '17, 1:03am.

  • #2
    Wayne Luke , can you or other person from the support please respond on this? Im stuck on the upgrade in the test site environment... i cant figure it out. It seems to be related to channels in the vbulletin-channels.xml install script.

    Comment


    • #3
      Maybe Joe D. knows more about this? It seems similar like https://www.vbulletin.com/forum/foru...t_class_called and https://www.vbulletin.com/forum/foru...ed-in-step-141

      Comment


      • #4
        It seems like the step passes $contenttype = 0 to the function getContentTypeClass. So, maybe the step grabs a faulty contenttype somewhere from?

        Comment


        • #5
          I enabled more detailed PHP logging and noticed this on Step 131 in the same script (500a1).
          • "Step 131 - Updating page table
          • Warning: A non-numeric value encountered in ...\vb\datastore.php on line 816
          • Warning: A non-numeric value encountered in ...\vb\datastore.php on line 816
          • Warning: array_keys() expects parameter 1 to be array, null given in ...\vb\xml\import\page.php on line 41
          • Warning: array_diff(): Argument #2 is not an array in ...\vb\xml\import\page.php on line 41
          • Step 132 - Fatal Error Occurred

          Status: Aborted"

          Comment


          • #6
            Each time you reply, it lowers the priority. However, this can't be fixed in the forums. we need access to the database so we can determine what content class from vBulletin 4.X needs to be deleted so you can proceed. Click the link in the footer to submit a ticket with access to the database, FTP, and your vBulletin 4.X control panel.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud customization and demonstration site.
            vBulletin 5 Documentation - Updated every Friday. Report issues here.
            vBulletin 5 API - Full / Mobile
            I am not currently available for vB Messenger Chats.

            Comment


            • #7
              Wayne Luke Sorry, did not know that replies lowered the priority. I will submit a ticket. Can you remote the server with TeamViewer? It will be the most simple solution for us. We have a dedicated server for the forum.

              The contenttype table has this information (i have tested to delete 21,25,29 according to other similar threads but no luck). The class column is a BLOB so i added the friendly name last. The error message indicates argument 0 though.

              contenttypeid,class,packageid,canplace,cansearch,cantag,canattach,isaggregator,"CONVERT(cl ass using utf8)"
              1,...,1,0,1,0,1,0,Post
              2,...,1,0,0,1,0,0,Thread
              3,...,1,0,1,0,0,0,Forum
              4,...,1,0,0,0,0,0,Announcement
              5,...,1,0,1,0,0,0,SocialGroupMessage
              6,...,1,0,0,0,0,0,SocialGroupDiscussion
              7,...,1,0,1,0,1,0,SocialGroup
              8,...,1,0,0,0,1,0,Album
              9,...,1,0,0,0,0,0,Picture
              10,...,1,0,0,0,0,0,PictureComment
              11,...,1,0,1,0,0,0,VisitorMessage
              12,...,1,0,0,0,0,0,User
              13,...,1,0,0,0,0,0,Event
              14,...,1,0,0,0,0,0,Calendar
              15,...,2,0,1,0,1,0,BlogEntry
              16,...,2,0,1,0,0,0,BlogComment
              17,...,3,1,0,0,0,1,Section
              18,...,3,1,1,1,1,0,Article
              19,...,3,0,0,0,0,0,ContentNode
              20,...,3,1,1,1,0,0,StaticPage
              21,...,3,1,0,0,0,0,PhpEval
              22,...,1,0,0,0,0,0,PrivateMessage
              23,...,1,0,0,0,0,0,Infraction
              24,...,1,0,0,0,0,0,Signature
              25,...,1,0,0,0,0,0,UserNote
              26,...,2,0,0,0,0,0,BlogDescription
              27,...,2,0,0,0,0,0,BlogCustomBlock
              28,...,3,0,0,0,0,0,ArticleComment
              29,...,1,0,0,0,0,0,IPAddress
              Last edited by Mr B; Fri 8th Dec '17, 11:13am.

              Comment


              • #8
                Like I said we need to be able to access the database directly to determine the issue. I don't use TeamViewer because it is insecure. However, other technical support people might. SFTP is the best option for us to provide support in a timely fashion.
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                vBulletin 5 Documentation - Updated every Friday. Report issues here.
                vBulletin 5 API - Full / Mobile
                I am not currently available for vB Messenger Chats.

                Comment


                • #9
                  Before you attempted the upgrade the first time did you have the VB Blogs and VB CMS product enabled in Product Manager? I like to enable all products that came as part of VB 4.x natively, then redo the upgrade from the backup created before the first attempt/ It doesn't seem to work if you enable the products on the same database if you already attempted the upgrade and don't restore back.

                  Comment


                  • #10
                    A short update. I will troubleshoot a little bit more here before adding a support ticket.

                    In some way it seems related to out new web server with PHP 7.1.7 and MySQL 5.7.20. Because, when i use the same DB backup on the old server with PHP 5.6.30 and MySQL 5.5.x the upgrade running past step 132 in script 500a1. Really strange. Do you know if there are any known upgrade issues related to PHP 7.1.7 and MySQL 5.7.20?

                    Comment


                    • #11
                      Not that I am aware, can you post any PHP errors/warnings logged during the upgrade on PHP 7.1?

                      Comment


                      • #12
                        After some MySQL tweaking we have now been able to upgrade vBulletin 4.2.5 to 5.3.4 once in our lab environment. We will try the upgrade a few more times in lab environment before doing it in production.

                        So, our problems with the upgrade seems to have been related to some MySQL 5.7.20 settings which needed some tweaking.

                        Comment

                        Working...
                        X