Announcement

Collapse
No announcement yet.

Guests can see attachments uploaded before upgrade from vb4 to vb5.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Guests can see attachments uploaded before upgrade from vb4 to vb5.

    Is there anyone who upgraded that has the same problem? How long does it usually take before a bug becomes confirmed of closed?

    This is a major problem for my forum because members posted their attachments in vbuleltin 4 with the knowledge that guests could not see their attachments.
    Since this is a regression from what it used to be I hope this bug can be confirmed and fixed soon.

    I have made a bug report: http://tracker.vbulletin.com/browse/VBV-17015

    Guests can see attachments uploaded before upgrade from vb4 to vb5. Attachments uploaded after upgrade show blank page

    Setting for guests: Can Download Image Attachments: No.

    Normal vb5 behavior: Attachments shown as links to guest without permission to download attachment. When clicking shows a blank page

    Attachments uploaded after upgrade from vb4 to vb5 show blank page (when visiting as guests without permission to download)
    PROBLEM: Attachments uploaded before the upgrade are visible to guests (when visiting as guests without permission to download)
    Example 1: code of an attachment uploaded after upgrade (with vb5):
    Code:
    {"alt":"Click image for larger version Name:\thigh-resolution-images-1.jpg Views:\t1 Size:\t132,4 KB ID:\t12345","data-align":"none","data-attachmentid":"12345","data-size":"full"}
    Example 2: Code of an old attachment uploaded with vb4 (before upgrading to vb5)
    Code:
     IMG2=JSON]{"data-align":"none","data-size":"full","src":"https:\/\/www.domain.com\/forum\/attachment.php?attachmentid=123456&d=12345678910"}[/IMG2


    So the way attachments are placed in a post are different. Is there an easy quick fix?
    Last edited by chriske; Sun 5th Mar '17, 12:53pm.
    Please vote for:
    - Lightbox for all uploads
    - Attachment permissions for unregistered users

  • #2
    I see the link was broken so I updated it with the correct link: http://tracker.vbulletin.com/browse/VBV-17015

    Can anyone answer my questions:
    Is there anyone who upgraded to vb5 that has the same problem?
    How long does it usually take before a bug becomes confirmed of closed?

    I don't expect an answer on my question: Is there an easy quick fix?
    But if someone could take a look at the difference between how old en new attachments are placed in a post. And make a comment about it that would be great.

    Updated Example 2 bacause the CODE TAGS did not work when [IMG2=JSON] is used
    So i removed the first and last [ and ]
    Last edited by chriske; Sun 5th Mar '17, 12:54pm.
    Please vote for:
    - Lightbox for all uploads
    - Attachment permissions for unregistered users

    Comment


    • #3
      I hate bumping, but anyone?
      Please vote for:
      - Lightbox for all uploads
      - Attachment permissions for unregistered users

      Comment


      • #4
        You would need to create a ticket with access to the database. We can't determine what the issue is without access to the server.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        I am not currently available for vB Messenger Chats.

        Comment


        • #5
          Thanks Wayne, I just created a support ticket.

          I hope someone of support can pinpoint this problem.
          Please vote for:
          - Lightbox for all uploads
          - Attachment permissions for unregistered users

          Comment

          Related Topics

          Collapse

          Working...
          X