Announcement

Collapse
No announcement yet.

Table for topic urls

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Table for topic urls

    Hello,

    At which MySQL table are Vb 5 connect Topics' urls stored?

    Is there anyway to update table in database to be the same as topic name??

    Thanx

  • #2
    Topic URLs aren't really stored. They are generated based on the location of the topic, the starting post's nodeid and the title of the topic. What specifically are you trying to do?
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      Originally posted by Wayne Luke View Post
      Topic URLs aren't really stored. They are generated based on the location of the topic, the starting post's nodeid and the title of the topic. What specifically are you trying to do?
      I have successfully changed my site from Latin1 to utf8mb4 and the Arabic/Hebrew/old eastern characters appeared back in the database.

      I changed config file to utf8mb4

      BUT i am facing big problem with:

      1- Topic urls all encoded and now not linked to all google links at all !!, If i am able to restore them to pick the topic title as before it will work
      2- All images and avatars disappeared or with broken links
      3- pm registration problem !


      I really need a real help to revive the site, i have succeeded to jump a big step and don;t want to lose or return back!

      Thank you Wayne Luke

      Comment


      • #4
        How did you change your site from Latin1 to UTF8MB4? I am guessing that you're using Arabic. It is the only language that causes problems. Mostly because the characters were stored as HTML entities and not characters at all.

        Numbers 2 and 3 aren't even related.

        For 1, you cannot use UTF-8 in a URL. It must be encoded. There should be nothing that stops these URLs from working.

        For 2, attachments only use a nodeid. Are stored by UserID. Both of these are numbers.

        For 3, This would create new nodes with their own URLS based on the Private Message Channel. This channel isn't even exposed where you can change the name of it.


        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        I am not currently available for vB Messenger Chats.

        Comment


        • #5
          Hello Wayne,

          For 1, you cannot use UTF-8 in a URL. It must be encoded. There should be nothing that stops these URLs from working.
          I understand your point, but what i meant is that the old title is different in characters now from the new so the encoded url must be different.

          ====

          Please give a look here:


          This is old not converted url:

          hurras.org/ar/forum/منبر-الأقسام-العامة-والخدمات/قسم-الاستفسارات-والإقتراحات-الشكاوى-المناسبات-والإعلانات/57374-عيدكم-مبارك-كل-عام-وأنتم-بخير-جميعاً

          https://www.hurras.org/ar/forum/%D9%...B9%D8%A7%D9%8B

          =============

          This is the new converted url:

          hurras.org/new/forum/ظظطط-طظطظططظ-طظططظط-ظطظططظططھ/ظطظ-طظطططھظپطططططھ-ظطظطظطھططط%C2%ADططھ-طظطظطظظ-طظظظطططططھ-ظطظططظطظططھ/57374-طظٹطظظ-ظطططظ-ظظ-ططظ-ظطظطھظ-ططظٹط-طظظٹططظ

          here it is encoded:

          https://www.hurras.org/new/forum/%D8...D8%B8%E2%80%B9

          ==========

          If you try to just change ar to new you will get broken link

          Comment


          • #6
            For 2, attachments only use a nodeid. Are stored by UserID. Both of these are numbers.
            This is good news, it means i would get a solution for image problem

            After conversion, avatars broken except the default avatar.

            To solve i changed storing image to file system but (ALL pictures - except file data! disappeared) so i returned back to storing in database (most returned) but still avatars all missing. I mistakenly thought it is due to change in url scheme !

            Please Wayne, adopt the site for just one day : )

            Comment


            • #7
              Originally posted by Blackhorse View Post
              Hello Wayne,



              I understand your point, but what i meant is that the old title is different in characters now from the new so the encoded url must be different.

              ====
              This is the new converted url:

              hurras.org/new/forum/ظظطط-طظطظططظ-طظططظط-ظطظططظططھ/ظطظ-طظطططھظپطططططھ-ظطظطظطھططط%C2%ADططھ-طظطظطظظ-طظظظطططططھ-ظطظططظطظططھ/57374-طظٹطظظ-ظطططظ-ظظ-ططظ-ظطظطھظ-ططظٹط-طظظٹططظ

              here it is encoded:

              https://www.hurras.org/new/forum/%D8...D8%B8%E2%80%B9

              ==========

              If you try to just change ar to new you will get broken link
              Your site isn't using UTF-8. It seems you have the HTML character set as ar in the AdminCP. This won't work properly. You need to use the UTF-8 Character set and will most likely need to use the UTF-8 Local for Arabic. The locale should be something like ar_SA.UTF-8. Both the character set and the locale are Case Sensitive.

              Don't use vBulletin 4.X language files.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud customization and demonstration site.
              vBulletin 5 Documentation - Updated every Friday. Report issues here.
              vBulletin 5 API - Full / Mobile
              I am not currently available for vB Messenger Chats.

              Comment


              • #8
                Hello Wayne,

                Here is the configuration for Language Arabic and English

                Click image for larger version

Name:	1.png
Views:	30
Size:	162.8 KB
ID:	4413228

                Comment


                • #9
                  I am using UTF-8 ((for 3 days now)) in Admincp.. This is phenomenal : ) as it is the 1st time for this 14 years old site to use. I don't know from where you get that the HTML character set is ar not UTF-8? .. then i think there would be another place that must be corrected

                  the AdminCP for sure as in the picture up: I use:

                  HTML Character Set = UTF-8
                  UTF-8 Local for Arabic.
                  The locale i exchange between ar_EG.utf8 and ar_SA.utf8

                  As it is case sensitive, I get the locale from my server

                  [root@host ~]# localectl list-locales | grep ^ar

                  ar_AE
                  ar_AE.iso88596
                  ar_AE.utf8
                  ar_EG
                  ar_EG.iso88596
                  ar_EG.utf8
                  ar_SA
                  ar_SA.iso88596
                  ar_SA.utf8

                  Comment


                  • #10
                    What I notice now Wayne Luke ,

                    When i edit page in site builder, changing the link to be exact as the new arabic title, to resemble the old one and click save, it works well.

                    BUT i will not do it one by one through millions of urls!!

                    Sure there is an update or command to ask MySQL to update urls according to topic titles right?

                    And where in DB the save after edit page is stored?

                    Thanx

                    Comment


                    • #11
                      Sure there is an update or command to ask MySQL to update urls according to topic titles right?
                      No. There isn't. The URL for a topic is built automatically from the title of the node already stored in the database.

                      As far as vBulletin knows the URLS all look like this in the database:
                      Code:
                      forum/main\-forum/forum\-1\-1/(?P<nodeid>[0-9]+)(?P<title>(-[^!@\#\$%\^&\*\(\)\+\?/:;"'\\,\.<>= \[\]]*)*)(?:/contentpage(?P<contentpagenum>[0-9]+))?(?:/page(?P<pagenum>[0-9]+))?
                      I could give you a query to set the title for every node to be the exact same string of text.

                      I am pretty sure that you didn't cast your values correctly in converting them from ASCII to UTF-8 in the database. Our own scripts to do this are still in testing. Arabic is the most problematic language they encounter.

                      And where in DB the save after edit page is stored?
                      Node titles are stored in the node table within the title field.
                      Translations provided by Google.

                      Wayne Luke
                      The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                      vBulletin 5 Documentation - Updated every Friday. Report issues here.
                      vBulletin 5 API - Full / Mobile
                      I am not currently available for vB Messenger Chats.

                      Comment


                      • #12
                        Do you still have a backup of the pre-conversion database? If so and you give me a copy, I can try converting it.
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                        vBulletin 5 Documentation - Updated every Friday. Report issues here.
                        vBulletin 5 API - Full / Mobile
                        I am not currently available for vB Messenger Chats.

                        Comment


                        • #13
                          Originally posted by Wayne Luke View Post
                          I am guessing that you're using Arabic. It is the only language that causes problems. Mostly because the characters were stored as HTML entities and not characters at all.
                          I am thinking this is because Arabic can be written with many layers (all accents and versions can be represented on same word) يدرب = يُدرب= يُدّرب = يُدَرِّب= يُدَرِّبْ
                          I have no idea about html storing.

                          =============

                          No. There isn't. The URL for a topic is built automatically from the title of the node already stored in the database.
                          Well, That is a very good starting point, I have checked Node, I realized that:

                          1- The title part of the url is automatically taken from html title to be slugged in urlindent
                          2- this urlindent field is the only gibberish field i have !!
                          3- I noticed this gibberish characters push the node id in an url area which makes it difficult to be key factor or recognized by redirected links!!

                          ====

                          Here what worked for now:

                          4- As long as All Title and html title values are clear Arabic and perfectly converted ! and,
                          5- As long as it will build url automatically
                          6- then there is no harm from emptying all urlident which i did !- to allow to take url from title again which will do in clear arabic (as title is well read)
                          7- And only Task is to just re-write urlident for over 100 Channels and forums (one day task)

                          What about the other millions titles???

                          they will be directed but with no title (only by node number) which hopefully will be recognized, and hopefully they will get the title automatically back

                          Please Wayne, review the links again,

                          This is the new converted url:

                          hurras.org/new/forum/ظظطط-طظطظططظ-طظططظط-ظطظططظططھ/ظطظ-طظطططھظپطططططھ-ظطظطظطھططط%C2%ADططھ-طظطظطظظ-طظظظطططططھ-ظطظططظطظططھ/57374-طظٹطظظ-ظطططظ-ظظ-ططظ-ظطظطھظ-ططظٹط-طظظٹططظ

                          here it is encoded:

                          http://www.hurras.org/new/forum/%D8%...D8%B8%E2%80%B9
                          it was: hurras.org/new/forum/ظظطط-طظطظططظ-طظططظط-ظطظططظططھ/ظطظ-طظطططھظپطططططھ-ظطظطظطھططط%C2%ADططھ-طظطظطظظ-طظظظطططططھ-ظطظططظطظططھ/57374-طظٹطظظ-ظطططظ-ظظ-ططظ-ظطظطھظ-ططظٹط-طظظٹططظ

                          it beomes: org/new/forum/منبر-الأقسام-العامة-والخدمات/قسم-الاستفسارات-والإقتراحات-الشكاوى-المناسبات-والإعلانات/57374-
                          it beomes: org/new/forum/channel-name/forum-name/nodeid-

                          I only changed the channel and forum title, the title urlident was emptied node id restored to its place and now it open and you can change between the two sites (ar - new) even if there is no sluged topic title !.. I think this is a short term solution or the best one if it is really generated automatically, as i re-checked and still urlident fiels is empty!

                          =========
                          Last edited by Blackhorse; Tue 16th Apr '19, 12:22pm.

                          Comment


                          • #14
                            I could give you a query to set the title for every node to be the exact same string of text.
                            Please yes i am really in a big need for your help

                            I am just trying to make any possible solution which would be disastrous as i am not experienced, but i have no other option except your interference and saving My vBulletin site

                            ======


                            Do you still have a backup of the pre-conversion database? If so and you give me a copy, I can try converting it.
                            Yes, please, please try and help me, i am sure you will have the best insight and professionalism.

                            I am keeping two versions, one version two months old before conversion to innodb and utf8

                            and the current online version (3 days old) BUT this is a converted version (was converted using your vBulletin tools)

                            After it was converted i find Arabic didn't appear, so i had to convert it another time and the result that Arabic came back

                            I suggest you use the newest one - Can I send you the details on private?

                            Thank you so much Wayne

                            Comment


                            • #15
                              I don't know if I can fix your newer copy. You'd have to make both available to me via a Support Ticket.
                              Translations provided by Google.

                              Wayne Luke
                              The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                              vBulletin 5 Documentation - Updated every Friday. Report issues here.
                              vBulletin 5 API - Full / Mobile
                              I am not currently available for vB Messenger Chats.

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X