Announcement

Collapse
No announcement yet.

change language pack

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • change language pack

    friends, please: is there any way to change the current English language pack from my forum by the English language pack of the latest version of VB?
    In other words: I want to delete the current English language pack of my forum and put a new from the latest version of VB.

    thanks!

  • #2
    In the AdminCP ->

    Delete the English Language.
    Create a new Language called English.

    Languages & Phrases -> Language Manager.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      Thank you Wayne!

      two things happened when I tried to delete the package:
      - I received the following message: "You can not delete or disable user access to the language you have set the default language for your forum. If you want to delete or disable user access to this language, please set another language to be the default language first."

      I believe it's because I have only one language pack;

      - I then tried to create a second package and set it as default to then delete the initial package. unsuccessfully. the system returns a blank page (image) and does not create the new package.
      Click image for larger version

Name:	branco.png
Views:	24
Size:	29.2 KB
ID:	4413087
      any tips?

      Comment


      • #4
        Not sure what you're trying to do if you wanted to delete the only Language. Why do you need a new English Language Pack?
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        I am not currently available for vB Messenger Chats.

        Comment


        • #5
          the translation process was performed incorrectly. there was no creation of another translated package, but the replacement of English words. For this reason, the need to restore the original language pack in English. With this restore, I can restart the translation process correctly.

          Any other tips for restoring the original English language package?

          thank you !!

          Comment


          • #6
            You will need to upload the /core/install directory and run upgrade.php to reimport the Master language.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud customization and demonstration site.
            vBulletin 5 Documentation - Updated every Friday. Report issues here.
            vBulletin 5 API - Full / Mobile
            I am not currently available for vB Messenger Chats.

            Comment


            • #7
              thanks for the tip!

              I upgraded to version 551. The original English package was not restored.
              however, five packages of another language were restored. this helped in another problem that I will explain in another topic.

              also allowed me to delete the existing English package.
              however, by creating a new package with the English name, the original English package was not restored.
              I also could not create the English package by importing the original version 551 .xml file. The operation is performed, but the package does not appear in the listing.
              I also could not create the original English package through the upgrade. the operation is also performed, but the package does not appear in the listing.

              at the moment I am without any package with the English name. is this possible or is the system understanding that any of the existing packages is the English package?

              any other tips?

              Comment


              • #8
                I don't know what you've done. The Master Language is reimported on every upgrade. My guess is one of your other language packs is inadvertently overwriting the Master and until it is deleted you won't be able to use a proper English Language Pack. With no way of viewing your database and files without a Support Contract, there is no way to determine which of your old Language Packs is causing the problem.

                Only the vbulletin-language.xml file in the /core/install directory should include type="master" anywhere in the file.

                You should not import vBulletin 4.X Language files. they are not compatible with vBulletin 5 phrases.
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                vBulletin 5 Documentation - Updated every Friday. Report issues here.
                vBulletin 5 API - Full / Mobile
                I am not currently available for vB Messenger Chats.

                Comment


                • #9
                  Hello, thanks!

                  well, I did what you advised:
                  1) "Delete the English Language.
                  Create a new language called English "
                  2) "to upload the / core / install directory and run upgrade.php to reimport the master language."

                  nothing worked.

                  import from VB 4? There's nothing about it ...

                  I think the problem now is find out which language pack is overwriting the master language.
                  What are the steps to discover this: language.xml file being used? database? or some other place or file?
                  there must be some way to find and change this incorrect replacement of the master language.

                  thank you again!

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X