Announcement

Collapse
No announcement yet.

"Working" showing for extended period when posting

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • "Working" showing for extended period when posting

    When we post a new topic in our forum the yellow "working" message can sometimes show for up to 15 seconds. The topic always gets posted, but this is a really long time for a simple write to the database. Does anyone have any ideas on what might be causing this and/or which settings to modify or check to perhaps speed up the post process.

    Mark

  • #2
    What are the sizes of your cache, cacheevent, and searchlog tables?

    Are you using Memcached for caching and SphinxSearch for keyword searches?
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      cache = 843.6 MiB
      cacheevent = 186.6 MiB
      searchlog = 229.4 MiB

      I am using SphinxSearch for keyword searches
      Memcached is not installed on our server

      Comment


      • #4
        Those numbers aren't alarming based on the size of your site.

        Is the issue just happening on your account or on all accounts?

        If you create a test user with no subscriptions does the same issue occur?

        If you upgrade a copy of the site to 5.4.2 does the same issue occur?

        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        I am not currently available for vB Messenger Chats.

        Comment


        • #5
          It is happening to multiple users. One thing to note is that it does not happen always, in fact the Working... message usually appears for about 4 seconds and then goes away (I notice this forum has the same 3-4 second delay). But when it is slow, it is really slow, like at least 20 seconds, sometimes 40 seconds before it will clear off the screen. Our forum does not have heavy traffic, so I dont think its bandwidth or server load.

          We have not updated VB to v5.4.2 yet. Is there something in the fix log that addresses this issue?

          Should I try installing Memcached, or do the numbers above likely indicate that the issue is not cache size?

          Comment


          • #6
            Originally posted by mark.hs View Post
            It is happening to multiple users. One thing to note is that it does not happen always, in fact the Working... message usually appears for about 4 seconds and then goes away (I notice this forum has the same 3-4 second delay). But when it is slow, it is really slow, like at least 20 seconds, sometimes 40 seconds before it will clear off the screen. Our forum does not have heavy traffic, so I dont think its bandwidth or server load.
            The "Working" is when it sends the content to the server for processing. The server then returns the processed content and the page is supposed to be redrawn. Does this content contain YouTube Videos (just trying to match your issue with another one in a guess)?

            We have not updated VB to v5.4.2 yet. Is there something in the fix log that addresses this issue?
            Not explicitly but we're constantly refactoring code behind the scenes so that is up to date and takes advantage of changes in PHP for better efficiency.

            Should I try installing Memcached, or do the numbers above likely indicate that the issue is not cache size?
            The numbers don't reflect a caching issue.

            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud customization and demonstration site.
            vBulletin 5 Documentation - Updated every Friday. Report issues here.
            vBulletin 5 API - Full / Mobile
            I am not currently available for vB Messenger Chats.

            Comment

            Working...
            X