Announcement

Collapse
No announcement yet.

Please enter at least one valid recipient.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Please enter at least one valid recipient.

    In our vB4, we created a mod on registration page. That mod uses an extra field called `HomeTown`; we then "sticked" both "Username", ", " and "HomeTown" together to create the username:
    Code:
    foobar, London
    Notice the comma? Now Ive upgraded the forum to vB5 on a test server. Ive noticed when I try to send a PM to someone with a comma in their username, I get the error message. Sending a PM to someone without the comma, all is well. That user was registered before we implemented the hack (kevin).

    Code:
    Please enter at least one valid recipient. Type in the first three characters and you will get a list of matching user names
    Click image for larger version

Name:	Screen Shot 2018-06-11 at 11.03.31.png
Views:	86
Size:	40.1 KB
ID:	4393058



    Let's look at the username only "foobar, London". When a comma is in the username, would that trigger the error message? I suspect that's the issue. The aim is not to have anymore hacks in the core. Thanks

  • #2
    Commas are "stop character" and shouldn't be used in the usernames.

    You can file a bug report on this issue here: https://tracker.vbulletin.com/vbulletin5/

    Click "Report Issue" in the header.

    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X