Announcement

Collapse
No announcement yet.

Site won't load after VB5 upgrade

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Site won't load after VB5 upgrade

    Upgraded my site from VB4 to 5.4 and am unable to access the site. When I type my site's url I get this instead of the home page.

    Fatal error: Class 'vB5_Frontend_ApplicationLight' not found in /home/nwimac/public_html/index.php on line 37

    If I manually enter /forum/home, I am able to see the home page. Forum files are in a forum directory under public_html.

  • #2
    Did you replace and rename the .htaccess files? The one in vB5 is different from the one in vB4.

    Comment


    • #3
      Yes, deleted all vb4 files.

      Comment


      • #4
        vB5 has a file in the root called htaccess.txt

        . This must be renamed to .htaccess
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.4.2 Demo - FEATURING "ROUTE BY NODE"!
        AdminAmmo - My Cloud Demo

        Comment


        • #5
          Yes, file is renamed to .htaccess. below are contents. Since my install in not in root public_html, but in public_html/forum is there anything I need to do special?

          <IfModule mod_rewrite.c>
          RewriteEngine On

          # In some cases where you have other mod_rewrite rules, you may need to remove the
          # comment on the following RewriteBase line and change it to match your folder name.
          # This resets the other mod_rewrite rules for just this directory
          # If your site was www.example.com/forum, the setting would be /forum/
          #RewriteBase /

          #To redirect users to the secure version of your site, uncomment the lines below
          #RewriteCond %{HTTPS} !=on
          #RewriteRule .* https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]

          # Send css calls directly to the correct file VBV-7807
          RewriteRule ^css.php$ core/css.php [NC,L]

          # Redirect old install path to core.
          RewriteRule ^install/ core/install/ [NC,L]

          # Main Redirect
          RewriteCond %{REQUEST_URI} !\.(gif|jpg|jpeg|png|css)$
          RewriteCond %{REQUEST_FILENAME} !-f
          RewriteCond %{REQUEST_FILENAME} !-d
          RewriteRule ^(.*)$ index.php?routestring=$1 [L,QSA]

          # Because admincp is an actual directory.
          RewriteRule ^(admincp/)$ index.php?routestring=$1 [L,QSA]

          </IfModule>

          <IfModule mod_deflate.c>
          AddOutputFilterByType DEFLATE application/atom+xml \
          text/javascript \
          application/x-javascript \
          application/javascript \
          application/json \
          application/rss+xml \
          application/vnd.ms-fontobject \
          application/x-font-ttf \
          application/xhtml+xml \
          application/xml \
          font/opentype \
          image/svg+xml \
          image/x-icon \
          text/css \
          text/html \
          text/plain \
          text/x-component \
          text/xml
          </IfModule>

          <IfModule mod_expires.c>
          ExpiresActive On
          ExpiresByType application/x-javascript A1209600
          ExpiresByType text/javascript A1209600
          ExpiresByType application/javascript A1209600
          ExpiresByType text/css A31536000
          ExpiresByType image/x-icon A2592000
          ExpiresByType image/icon A2592000
          ExpiresByType application/x-ico A2592000
          ExpiresByType application/ico A2592000
          ExpiresByType image/gif A2592000
          ExpiresByType image/jpeg A1209600
          ExpiresByType image/jpg A1209600
          ExpiresByType image/png A1209600
          ExpiresByType application/x-shockwave-flash A1209600
          ExpiresByType font/ttf A2592000
          ExpiresByType font/otf A2592000
          ExpiresByType font/x-woff A2592000
          ExpiresByType image/svg+xml A2592000
          ExpiresByType font/truetype A2592000
          ExpiresByType font/opentype A2592000
          ExpiresByType application/x-font-woff A2592000
          ExpiresByType application/vnd.ms-fontobject A2592000
          </IfModule>

          <IfModule mod_headers.c>
          Header set Connection keep-alive
          <filesmatch "\.(ico|flv|gif|swf|eot|woff|otf|ttf|svg)$">
          Header set Cache-Control "max-age=2592000, public"
          </filesmatch>
          <filesmatch "\.(jpg|jpeg|png)$">
          Header set Cache-Control "max-age=1209600, public"
          </filesmatch>
          <filesmatch "\.(eot|woff|otf|ttf|svg)$">
          Header set Cache-Control "max-age=2592000, public"
          </filesmatch>
          # css and js should use private for proxy caching https://developers.google.com/speed/...geProxyCaching
          <filesmatch "\.(css)$">
          Header set Cache-Control "max-age=31536000, private"
          </filesmatch>
          <filesmatch "\.(js)$">
          Header set Cache-Control "max-age=1209600, private"
          </filesmatch>
          </IfModule>

          #don't allow some files that shouldn't really be present to be directly accessed.
          #note that attachements should never be directly accessed by the webserver because
          #we have permissions on the that are checked in the PHP code.
          <FilesMatch "(^#.*#|\.(bak|config|dist|inc|ini|log|gz|tar|zip|sh|sql|sw[op])|~)$">
          Order allow,deny
          Deny from all
          Satisfy All
          </FilesMatch>

          Comment


          • #6
            Ok, so what it seems to be is that the site does load but your custom home page doesn't.

            Your site is installed at /forum. vBulletin has no knowlwedge of anything going on in the level above, hence that won't load.

            You will need to arrange a redirect of domain.com to domain.com/forum/home so that your site's root redirects to your forum installation's /home page. This is outside the scope of our support as it is dependent on server configuration. Your hosts should be able to assist here.
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.4.2 Demo - FEATURING "ROUTE BY NODE"!
            AdminAmmo - My Cloud Demo

            Comment


            • #7
              So no way to do this in the index.php file?

              Comment


              • #8
                Host was able to help me setup a redirect. All good now.

                Thanks for your help.

                Comment

                Working...
                X