Announcement

Collapse
No announcement yet.

Turning off comments in a published article doesn't seem to work

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Bug / Issue] Turning off comments in a published article doesn't seem to work

    So I have a test article published, with comments enabled. I used another test user to post a comment.

    Now, I edit the article, and turn comments off. But the setting does not stick. After I click "Save", and then go edit it again, the setting has gone back to enabled. Can't you turn off comments once it was published with them on?

  • #2
    Could not confirm that. After I deactivate the comments (one comment of another user is posted) it is still deactivated after edit a second time. Tested with 5.3.4.
    vBulletin-forum.de | Das deutschsprachige vBulletin 5 Forum! | Widgets, Mods und Anleitungen auf deutsch.
    Team online, Navbar UnreadCount, Moderation-Info, New: Show hook-positions, Auto-close Threads, Latest Likes, Top-Posters PRO

    Comment


    • #3
      I just tried it again, 5.3.4. I cannot turn comments off.

      1. Test Article, with one comment from another user.
      2. I'm logged in as admin, and am the creator of the article.
      3. I click on the little Edit pencil icon at the bottom of the article.
      4. I set Comments to Off, and then click the Save button.
      5. The comments are still there, and so is the comment box.
      6. I click the edit button again; Comments is back to On.

      Comment


      • In Omnibus
        In Omnibus commented
        Editing a comment
        Comments don't turn off for administrators. Try posting a comment as a registered member after turning them off.

      • StephenKay
        StephenKay commented
        Editing a comment
        It's not allowing me to turn off the commenting. It simply will not remember the off setting. Guests and another test member can still see and post comments after I save it with comments off. Because it doesn't save the comments off setting for some reason.

    • #4
      Admins will always be able to post comments. Guests should not be able to post comments at any time with default permissions. personally, I recommend not letting guests create any content on your site. That is just asking for spam.

      I can't recreate the issue myself. It could be some addon is preventing that variable from being updated. Anyway, try closing the topic/article from the gear menu. Existing comments would remain on the article.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud customization and demonstration site.
      vBulletin 5 Documentation - Updated every Friday. Report issues here.
      vBulletin 5 API - Full / Mobile
      I am not currently available for vB Messenger Chats.

      Comment


      • StephenKay
        StephenKay commented
        Editing a comment
        Admins will always be able to post comments.
        This does not appear to be the case. I created a new article, no photos. I published it. The comment box is available. I edited it and turned comments off. Hit SAVE. Now the comment box is gone and it shows "posting comments is disabled" - for me, the admin.

        I duplicated the original problem. It appears to be a bug related to articles with photos. Please see my last post in this thread.

    • #5
      I have no add-ons.

      I created a new test article, and indeed, I can turn comments off and on and it works as expected. With this other first test article, it turns out I cannot change ANY of the advanced settings. Not just enabling/disabling comments, but page view, public preview etc. I change them, save the article, re-edit it and they have all reverted back to what they were. Somehow, my first test article got stuck in some way.
      Last edited by StephenKay; Tue 5th Dec '17, 6:52pm. Reason: removed erroneous information

      Comment


      • #6
        I have now duplicated the problem. It has to do with articles with photo attachments (my first test article had a photo, the second did not). Do this:

        Create a new article, give it a title and some text.
        Add a photo to it by clicking on the camera icon. I added a photo from a photo album. Do nothing else to it, default settings.
        Click the POST button with the default settings (Comments On) to publish the article.
        View the article - commenting is enabled.
        Edit the article. Turn all of the display options off, including Comments Off.
        Click the SAVE button.
        View the article - comments box is still available.
        Edit the article again - all display settings have reverted to their previous settings, including Comments On. You cannot edit them.

        Comment


        • #7
          Sounds like a bug that deserves a JIRA. Be sure to include the steps to reproduce.

          http://tracker.vbulletin.com/secure/...91&issuetype=1
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud customization and demonstration site.
          vBulletin 5 Documentation - Updated every Friday. Report issues here.
          vBulletin 5 API - Full / Mobile
          I am not currently available for vB Messenger Chats.

          Comment


          • #8
            Filed. http://tracker.vbulletin.com/browse/VBV-17976

            Comment

            Working...
            X