Announcement

Collapse
No announcement yet.

Users unable to log in, no error message

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Users unable to log in, no error message

    Here is something that we just noticed at bearhawkforums.com.

    When a user tries to log in via the little box on the upper right, they enter the user name and password, and the page refreshes but does not log them in. This seems to be happening across all browsers and platforms that we have tried, and for users of all authority types. The users who have remained logged in are able to use the site with normal functions, but if we try to log in with the same user on a different browser, it does not work.

    Some of the things that don't seem to matter:
    typing the url with or without https://
    incognito mode
    checking the "remember me" box

    I installed version 5.3.0 several days ago, so there is a chance that it is related to that, but it seems like I would have heard from someone before now if it has been broken since then.

    I'd appreciate any help with trying to troubleshoot this. It seems that there are a few unresolved threads in the support forums with similar problems.

    Here are the answers to the 7 questions:
    1. vBulletin Version 5.3.0
    2. PHP Version 5.6.29
    3. MySQL Version 5.6.34-log (I guess?)
    4. Any Addons installed- Tapatalk
    5. Does the issue occur in a default style? yes
    6. Does the issue occur using the English language provided? yes
    7. Error message on the screen- no
    8. Browser and Browser version used- confirmed in chrome, IE, Firefox, and Safari
    9. Did you clear the browser cache and did the error continue? Yes and yes
    10. A list of steps that can be used to recreate the issue. open the url in the browser and attempt to log in

  • #2
    What is the vBulletin URL defined in the Site URL settings in AdminCP? Does it use https or http? With or without www? Do users use that exact URL?

    You have to redirect one to the other (via htaccess or cPanel) so that your site is only accessible in one url format. That's also required for SEO.
    vB Mods That Rock!
    AutoLinker-vB5+vBCloud | OpenGraph | Blur Replies for Guests-vB5+vB4 | NavMenu Dropdown | Timed Sticky | Events Module | Editor Default Type | Moderator List | vB5 Latest Posts on Alexa!

    Comment


    • #3
      In the admincp we have https://bearhawkforums.com
      Just now I have set up the host to redirect concerning the www, but I'll need to do some research for redirecting the http to https. This seems like good things to fix for the long term, but being that the problem persists regardless of which way we type the URL, is there reason to believe that redirects are going to fix the problem?

      Comment


      • #4
        I have just now fixed the .htaccess to redirect the http to https, which I agree is a good idea. The problem persists however.

        Also, just another data point, if I type in the wrong password, it does give the usual password error message.

        Comment


        • #5
          Try changing the cookie domain settings in AdminCP from .bearhawkforums.com to (blank).
          vB Mods That Rock!
          AutoLinker-vB5+vBCloud | OpenGraph | Blur Replies for Guests-vB5+vB4 | NavMenu Dropdown | Timed Sticky | Events Module | Editor Default Type | Moderator List | vB5 Latest Posts on Alexa!

          Comment


          • #6
            Did that, cleared the browser cookies, and still the same condition. Thanks for your help by the way, all of this is progress.

            Comment


            • #7
              We're still stuck, does anyone have any suggestions?

              Comment


              • #8
                What is the cookie path settings?
                vB Mods That Rock!
                AutoLinker-vB5+vBCloud | OpenGraph | Blur Replies for Guests-vB5+vB4 | NavMenu Dropdown | Timed Sticky | Events Module | Editor Default Type | Moderator List | vB5 Latest Posts on Alexa!

                Comment


                • #9
                  Make sure that the login URL option is the same as the main URL including the https.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud site. vBulletin 5 API - Full / Mobile
                  Please do not PM me for support unless I specifically ask for information to be delivered that way.

                  Comment


                  • #10
                    Well, now it looks like I've locked myself out of the admincp. It's doing the same thing there, just redirecting back to the login screen. Let me try undoing the .htaccess and I'll report back.

                    Is there a place where I can edit that setting in a file or in the DB directly, instead of trying to get into the admincp?
                    Last edited by jaredyates; Sun 23rd Apr '17, 6:59am.

                    Comment


                    • #11
                      I found the setting frontendurl_login in the database, and the value is the same as the usual URL with the https. It also shows up that way on the settings page in the admincp.

                      I was able to login to the admin cp from another device. The "Path to save cookies" is .bearhawkforums.com/ and the "Cookie Domain " is blank.

                      So far, still unable to log into admincp from my usual device.
                      Last edited by jaredyates; Sun 23rd Apr '17, 7:25am.

                      Comment


                      • #12
                        Change the cookie path to / which is the default.
                        vB Mods That Rock!
                        AutoLinker-vB5+vBCloud | OpenGraph | Blur Replies for Guests-vB5+vB4 | NavMenu Dropdown | Timed Sticky | Events Module | Editor Default Type | Moderator List | vB5 Latest Posts on Alexa!

                        Comment


                        • #13
                          If you make changes to the settings table directly in the database, you have to run this query as well:
                          Code:
                          DELETE FROM datastore WHERE title IN ('miscoptions','publicoptions','options');
                          Otherwise, your changes will not be reflected in the operation of the site. You will also need to delete the cookies for your site as well.
                          Translations provided by Google.

                          Wayne Luke
                          The Rabid Badger - a vBulletin Cloud site. vBulletin 5 API - Full / Mobile
                          Please do not PM me for support unless I specifically ask for information to be delivered that way.

                          Comment


                          • #14
                            Thanks for the help, it looks like we are back in business after changing the cookie path. I was thinking I had tried that before, but maybe it was a combination of that and the https redirect in the htaccess? At any rate, it is fixed, which makes life much better.

                            Comment


                            • #15
                              Glad to hear it.
                              Translations provided by Google.

                              Wayne Luke
                              The Rabid Badger - a vBulletin Cloud site. vBulletin 5 API - Full / Mobile
                              Please do not PM me for support unless I specifically ask for information to be delivered that way.

                              Comment

                              Working...
                              X