Announcement

Collapse
No announcement yet.

Is vbulletin 5.2.4 compatible with PhP 7.0.11 - Facebook login not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Is vbulletin 5.2.4 compatible with PhP 7.0.11 - Facebook login not working

    I just tonight migrated from a shared Hostgator to a Snappy 2000 VPS.

    The site is running now mySQL 5.6 and PhP 7.0.11

    Immediate issue I notice is inability to login with Facebook. Gets as far as asking for FB username and PW, and then when click to login just freezes.

  • #2
    Check error logs on the server. Also enable debug mode to check if error appears on the page or JS console.

    GIPHY for vB5 AutoLinker Social Icons in Postbit Audio Player Clear Cache Cron DragDrop Upload Topic AutoUpdate Force Read Stop Links in Posts ...and more!

    Comment


    • #3
      In vbulletin debug mode, I noticed this at the bottom:
      Debug Information
      • Page ID: 1
      • Parent ID: 0
      • Page Template ID: 1
      • Route ID: 4
      • Page Type: default
      • Screen Layout ID: 2
      • Screen Layout Template: screenlayout_display_wide_narrow
      • Channel ID: 1
      • Node ID: 1
      • Database Asserts: 190 (?)
      • AJAX Requests: 21
      • Facebook Active: Yes
      • Style ID: 11
      • Templates/Renders: 45/117
      • CSS Templates: 11
      • JS Files: 6
      • Included Files: 172
      • Autoloaded Classes: 162
      • Current Time: Fri, 07 Oct 2016 07:34:29 +0000
      • Page Time: 0.6859
      and then after the FB attempt to login, which as noted just does nothing, the Debug Information looked about the same other than a changing number for AJAX Requests.

      Where is the JS console?

      ---

      There were two errors on the server

      [Fri Oct 07 01:40:45.851884 2016] [cgi:error] [pid 22590] [client 192.254.201.234:47225] AH01215: ('node_66812_lvl1data','nodeChg_ in /home/mdawg/public_html/forums/core/vb/database.php on line 1294: /usr/local/cpanel/cgi-sys/ea-php70

      [Fri Oct 07 00:13:32.515745 2016] [cgi:error] [pid 18694] [client 192.254.201.234:46467] AH01215: ('node_66812_lvl1data','nodeChg_ in /home/mdawg/public_html/forums/core/vb/database.php on line 1294: /usr/local/cpanel/cgi-sys/ea-php70

      but those were earlier at night not at the time I tried this login.

      ---

      Is anyone running PhP 7.0.11 with vb5 and able to login with vbulletin Facebook?
      Last edited by MDawg; Fri 7th Oct '16, 6:49am.

      Comment


      • #4
        I notice on your site that the URL you gave Facebook for your site is just domainname.com . Whereas you have your site set up to use the URL www.domainname.com . You should change the Facebook URL to www.domainname.com and then see if it works.

        Please don't PM or VM me for support - I only help out in the threads.
        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
        Want help modifying your vbulletin forum? Head on over to vbulletin.org
        If I post CSS and you don't know where it goes, throw it into the additional.css template.

        W3Schools <- awesome site for html/css help

        Comment


        • #5
          I have this in .htaccess

          RewriteCond %{HTTPS} !=on [NC]
          RewriteCond %{HTTP_HOST} !^www\.
          RewriteRule ^ http://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

          so that when anyone enters myforum.com it automatically goes to www.myforum.com

          Now, where do I go to change what you are asking?

          Comment


          • #6
            You need to make the change in your Facebook App page.

            Please don't PM or VM me for support - I only help out in the threads.
            vBulletin Manual & vBulletin 4.0 Code Documentation (API)
            Want help modifying your vbulletin forum? Head on over to vbulletin.org
            If I post CSS and you don't know where it goes, throw it into the additional.css template.

            W3Schools <- awesome site for html/css help

            Comment


            • #7
              I actually have two Facebook apps. (By the way, the name of the FB app used for vbulletin is mysite.com but that's just the display name I gave it, doesn't mean the login URL is mysite.com)

              One is for the oneall mod, where the Site URL given to FB is
              http://mysite.api.oneall.com/

              and for whatever reason, login for Facebook via that mod WORKS.


              But then the other FB app, created for vbulletin, has a Website Site URL within the app settings of:
              http://www.mysite.com/forums/
              which is exactly the same as my vBulletin URL and Login URL setting in the Admin CP (Admin CP / Settings / Options /
              Site Name / URL / Contact Details )
              and I'm not able to login via FB / vbulletin. This issue is happening only after the server change to the VPS, with the corresponding PhP 7.0.11


              -


              I then reverted PhP to 5.6 for my forum, deleted all cookies in the browser, and tried the vbulletin FB login again. This time with PhP 5.6 running I got:

              Error

              Error information: " 500 error Internal Server Error"


              so I then I went back to PhP 7, deleted all cookies, and same as before, just froze and no login.
              Last edited by MDawg; Fri 7th Oct '16, 1:20pm.

              Comment


              • #8
                Do you have the cURL and/or OpenSSL library enabled in your PHP? One is required to make contact to Facebook with vBulletin.

                The 500 server error is probably a PHP error somewhere. Look for an error_log file in your forum root directory. What are the last lines in it?
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                vBulletin 5 Documentation - Updated every Friday. Report issues here.
                vBulletin 5 API - Full / Mobile
                I am not currently available for vB Messenger Chats.

                Comment


                • #9
                  According to Hostgator: cURL, GET and Wget are enabled on all HostGator servers by default.

                  The only errors showing are:

                  [Fri Oct 07 16:51:55.479305 2016] [cgi:error] [pid 16088] [client 192.254.201.234:35602] AH01215: ('node_66812_lvl1data','nodeChg_ in /home/mdawg/public_html/forums/core/vb/database.php on line 1294: /usr/local/cpanel/cgi-sys/ea-php70
                  [Fri Oct 07 16:51:55.355117 2016] [cgi:error] [pid 17058] [client 192.254.201.234:35601] AH01215: ('node_66812_lvl1data','nodeChg_ in /home/mdawg/public_html/forums/core/vb/database.php on line 1294: /usr/local/cpanel/cgi-sys/ea-php70
                  [Fri Oct 07 11:33:49.164102 2016] [cgi:error] [pid 6730] [client 192.254.201.234:52044] AH01215: ('node_66812_lvl1data','nodeChg_ in /home/mdawg/public_html/forums/core/vb/database.php on line 1294: /usr/local/cpanel/cgi-sys/ea-php70
                  [Fri Oct 07 01:40:45.851884 2016] [cgi:error] [pid 22590] [client 192.254.201.234:47225] AH01215: ('node_66812_lvl1data','nodeChg_ in /home/mdawg/public_html/forums/core/vb/database.php on line 1294: /usr/local/cpanel/cgi-sys/ea-php70
                  [Fri Oct 07 00:13:32.515745 2016] [cgi:error] [pid 18694] [client 192.254.201.234:46467] AH01215: ('node_66812_lvl1data','nodeChg_ in /home/mdawg/public_html/forums/core/vb/database.php on line 1294: /usr/local/cpanel/cgi-sys/ea-php70

                  Comment


                  • #10
                    Any specific reason you're using FastCGI and not mod_php? All those errors are pointing the Visitor Message Node. Shouldn't be any reason to access that directly. Unfortunately, there isn't enough information to know what is going on. I doubt it is related to Facebook though.

                    Regardless of what Hostgator says, is cURLand/or OpenSSL appear in your PHP Info as listed in the vBulletin AdminCP?
                    Translations provided by Google.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                    vBulletin 5 Documentation - Updated every Friday. Report issues here.
                    vBulletin 5 API - Full / Mobile
                    I am not currently available for vB Messenger Chats.

                    Comment


                    • #11
                      Looking at your system, the browser is blocking (properly) the script from Facebook since they are being loaded from HTTPS.

                      http://www.facebook.com/impression.p...2jssdk%22%7D:1 GET https://www.facebook.com/impression....%22jssdk%22%7D net::ERR_BLOCKED_BY_CLIENT

                      If the addon you have installed works, I suggest using it and disabling the direct login functionality offered by vBulletin. There is absolutely no reason to offer both methods.
                      Translations provided by Google.

                      Wayne Luke
                      The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                      vBulletin 5 Documentation - Updated every Friday. Report issues here.
                      vBulletin 5 API - Full / Mobile
                      I am not currently available for vB Messenger Chats.

                      Comment


                      • #12
                        I think the addon just gets you logged in, but not sure if it gets you logged in in a way where the Facebook integration works for publishing posts. Which, isn't working anyway for me lately.
                        http://www.vbulletin.com/forum/forum...14#post4355614

                        Yes php info shows
                        cURL support enabled
                        cURL Information 7.19.7
                        OpenSSL support enabled
                        OpenSSL Library Version OpenSSL 1.0.1e-fips 11 Feb 2013
                        I don't even know what FastCGI versus mod_php is, what should I do?

                        ---

                        I had some vb4 issues after server transfer
                        http://www.vbulletin.com/forum/forum...-server-change
                        what about re-doing the upgrade here on the vb5 forum too?
                        Last edited by MDawg; Fri 7th Oct '16, 3:37pm.

                        Comment


                        • #13
                          Having both enabled can cause conflicts depending on the javascript that is being pulled from Facebook.

                          For instance, I get this error when opening your site:
                          Code:
                            1. Request URL: https://www.facebook.com/common/scribe_endpoint.php?c=jssdk_error&m=%7B%22appId%22%3A%22909508009113575%22%2C%22error%22%3A%22XD_INITIALIZATION%22%2C%22extra%22%3A%7B%22message%22%3A%22Failed%20to%20initialize%20in%2030000ms%22%2C%22revision%22%3A%222613010%22%7D%7D
                          1. Request Headers (2)
                          2. Query String Parametersview sourceview URL encoded
                            1. c: jssdk_error
                            2. m: {"appId":"909508009113575","error":"XD_INITIALIZATION","extra":{"message":"Failed to initialize in 30000ms","revision":"2613010"}
                          That isn't coming from our software but prevents Facebook Login from working. I get two other files (https://www.facebook.com/impression.php and https;//syndication.twitter.com/i/jot/) blocked by my client. We don't use those files either.
                          Translations provided by Google.

                          Wayne Luke
                          The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                          vBulletin 5 Documentation - Updated every Friday. Report issues here.
                          vBulletin 5 API - Full / Mobile
                          I am not currently available for vB Messenger Chats.

                          Comment

                          Related Topics

                          Collapse

                          Working...
                          X