Announcement

Collapse
No announcement yet.

Infamous An internal error has occurred and the module cannot be displayed.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Infamous An internal error has occurred and the module cannot be displayed.

    We are getting the following error when trying to access certain elements of Vb5 version 5.2

    "An internal error has occurred and the module cannot be displayed."

    It is only happening with a certain admin user it seems.

  • #2
    Enable debug mode to see the actual php error.

    GIPHY for vB5 | AutoLinker | User Social Network Icons in Postbit | Audio Attachments Player | Clear System Cache Cron | Drag-n-Drop Upload | Topic AJAX AutoUpdate | Force Read Topic | and a lot more...

    Comment


    • #3
      Thank you for the information. I put the forum in debug mode and on the front page the first error i get is

      An internal error has occurred and the module cannot be displayed. Template: widget_statistics Controller: site Method: getSiteStatistics Arguments: Array ( ) Errors:

      Code:
      Array
      (
          [0] => Array
              (
                  [0] => Unexpected error, post count is negative!
      If you do not want to see this exception, turn debug mode off.
      This issue is usually fixed by running AdminCP > Maintenance > General Update Tools > "Rebuild Topic Information", followed by "Rebuild Forum Information", then clearing the system cache (order matters).
      Please see VBV-14784 for more details. If a specific action has triggered this exception (ex. deleting a node), please create a JIRA with the details.
              )
      
          [1] => Array
              (
                  [0] => exception_trace
                  [1] => ## /home/admin888/public_html/core/vb/api/node.php(4008) Exception Thrown 
      #0 /home/admin888/public_html/core/vb/api/node.php(3966): vB_Api_Node->addChannelTotals(Array, Array, '15')
      #1 /home/admin888/public_html/core/vb/api/node.php(3471): vB_Api_Node->addChannelTotals(Array, Array, '2')
      #2 /home/admin888/public_html/core/vb/api/node.php(4486): vB_Api_Node->fetchChannelNodeTree('2', 3)
      #3 /home/admin888/public_html/core/vb/library/site.php(712): vB_Api_Node->getChannelStatistics('2')
      #4 /home/admin888/public_html/core/vb/api/site.php(118): vB_Library_Site->getSiteStatistics()
      #5 [internal function]: vB_Api_Site->getSiteStatistics()
      #6 /home/admin888/public_html/core/vb/api/wrapper.php(129): call_user_func_array(Array, Array)
      #7 [internal function]: vB_Api_Wrapper->__call('getSiteStatisti...', Array)
      #8 [internal function]: vB_Api_Wrapper->getSiteStatistics()
      #9 /home/admin888/public_html/includes/api/interface/collapsed.php(189): call_user_func_array(Array, Array)
      #10 /home/admin888/public_html/includes/vb5/template/runtime.php(506): Api_Interface_Collapsed->callApi('site', 'getSiteStatisti...', Array, false, true)
      #11 /home/admin888/public_html/includes/vb5/template.php(323) : eval()'d code(33): vB5_Template_Runtime::parseData('site', 'getSiteStatisti...')
      #12 /home/admin888/public_html/includes/vb5/template.php(323): eval()
      #13 /home/admin888/public_html/includes/vb5/template/cache.php(134): vB5_Template->render(false)
      #14 /home/admin888/public_html/includes/vb5/template.php(345): vB5_Template_Cache->replacePlaceholders('\r\n\t<!-- *** STA...')
      #15 /home/admin888/public_html/includes/vb5/template/cache.php(134): vB5_Template->render(false)
      #16 /home/admin888/public_html/includes/vb5/template.php(345): vB5_Template_Cache->replacePlaceholders('\r\n\t\t<meta name=...')
      #17 /home/admin888/public_html/includes/vb5/frontend/controller/page.php(245): vB5_Template->render()
      #18 [internal function]: vB5_Frontend_Controller_Page->index(1, '1', '1', '1', 1, 'Home Descriptio...', 0, '', 'Home', 0)
      #19 /home/admin888/public_html/index.php(86): call_user_func_array(Array, Array)
      #20 {main}
              )
      
      )
      The second error i get in private messaging when i click Inbox and then click on a message to go to that message

      An internal error has occurred and the module cannot be displayed. Template: widget_privatemessage_display => privatemessage_view => privatemessage_newpm => contententry => humanverify => humanverify_question Controller: hv Method: fetchHvQuestion Arguments: Array ( [0] => aebab6748a2769f63a9b5ac8d35ad0a9 ) Errors:

      Code:
      Array
      (
          [0] => Array
              (
                  [0] => invalid_hash
              )
      
          [1] => Array
              (
                  [0] => exception_trace
                  [1] => ## /home/admin888/public_html/core/vb/api/hv.php(216) Exception Thrown 
      #0 [internal function]: vB_Api_Hv->fetchHvQuestion('aebab6748a2769f...')
      #1 /home/admin888/public_html/core/vb/api/wrapper.php(129): call_user_func_array(Array, Array)
      #2 [internal function]: vB_Api_Wrapper->__call('fetchHvQuestion', Array)
      #3 [internal function]: vB_Api_Wrapper->fetchHvQuestion('aebab6748a2769f...')
      #4 /home/admin888/public_html/includes/api/interface/collapsed.php(189): call_user_func_array(Array, Array)
      #5 /home/admin888/public_html/includes/vb5/template/runtime.php(506): Api_Interface_Collapsed->callApi('hv', 'fetchHvQuestion', Array, false, true)
      #6 /home/admin888/public_html/includes/vb5/template.php(323) : eval()'d code(5): vB5_Template_Runtime::parseData('hv', 'fetchHvQuestion', 'aebab6748a2769f...')
      #7 /home/admin888/public_html/includes/vb5/template.php(323): eval()
      #8 /home/admin888/public_html/includes/vb5/template/cache.php(134): vB5_Template->render(false)
      #9 /home/admin888/public_html/includes/vb5/template.php(345): vB5_Template_Cache->replacePlaceholders('\r\n\r\n\r\n\t\r\n\t\r\n\t\t\r...')
      #10 /home/admin888/public_html/includes/vb5/template/cache.php(134): vB5_Template->render(false)
      #11 /home/admin888/public_html/includes/vb5/template.php(345): vB5_Template_Cache->replacePlaceholders('\r\n\r\n\r\n\r\n\r\n\r\n\t\r\n...')
      #12 /home/admin888/public_html/includes/vb5/template/cache.php(134): vB5_Template->render(false)
      #13 /home/admin888/public_html/includes/vb5/template.php(345): vB5_Template_Cache->replacePlaceholders('\r\n\t\r\n\t\r\n\r\n\r\n\r\n\r...')
      #14 /home/admin888/public_html/includes/vb5/template/cache.php(134): vB5_Template->render(false)
      #15 /home/admin888/public_html/includes/vb5/template.php(345): vB5_Template_Cache->replacePlaceholders('\r\n\r\n\r\n\r\n\r\n\r\n\r\n<...')
      #16 /home/admin888/public_html/includes/vb5/template/cache.php(134): vB5_Template->render(false)
      #17 /home/admin888/public_html/includes/vb5/template.php(345): vB5_Template_Cache->replacePlaceholders('\r\n\t\r\n\r\n\r\n\t\r\n\t\r\n...')
      #18 /home/admin888/public_html/includes/vb5/template/cache.php(134): vB5_Template->render(false)
      #19 /home/admin888/public_html/includes/vb5/template.php(345): vB5_Template_Cache->replacePlaceholders('\r\n\t<!-- *** STA...')
      #20 /home/admin888/public_html/includes/vb5/template/cache.php(134): vB5_Template->render(false)
      #21 /home/admin888/public_html/includes/vb5/template.php(345): vB5_Template_Cache->replacePlaceholders('\r\n\t\r\n\t\r\n\t\r\n\t\r\n\t...')
      #22 /home/admin888/public_html/includes/vb5/frontend/controller/page.php(245): vB5_Template->render()
      #23 [internal function]: vB5_Frontend_Controller_Page->index(13, '13', 'privatemessage_...', 'view', '50449')
      #24 /home/admin888/public_html/index.php(86): call_user_func_array(Array, Array)
      #25 {main}
              )
      
      )

      Comment


      • #4
        For the first error, did you try what the error suggested about rebuilding topic and forum information?
        For the second error, I don't know what that is.

        GIPHY for vB5 | AutoLinker | User Social Network Icons in Postbit | Audio Attachments Player | Clear System Cache Cron | Drag-n-Drop Upload | Topic AJAX AutoUpdate | Force Read Topic | and a lot more...

        Comment


        • #5
          http://tracker.vbulletin.com/browse/VBV-15707 same here
          WTF

          Comment


          • #6
            Originally posted by Skyyg Skyg View Post
            I don't think that's the same issue. "An internal error has occurred and the module cannot be displayed." is a generic error when a runtime php error occurs.

            GIPHY for vB5 | AutoLinker | User Social Network Icons in Postbit | Audio Attachments Player | Clear System Cache Cron | Drag-n-Drop Upload | Topic AJAX AutoUpdate | Force Read Topic | and a lot more...

            Comment


            • #7
              yes i would try to rebuild like Glenn said.

              Update Tools-> Rebuild Topics.
              then rebuild forum information
              then clear the system cache.

              if you just recently upgraded from vb 4. you should have does this already, its tells you to do this within your admincp.

              Comment


              • #8
                Ok i have done what cjg9590 has suggested. I had never done this after upgrading so im hoping this fixes things. Its wierd though that the error message only displays for some users and not all. Will post update on the progress of this solution

                Comment


                • #9
                  I rebuilt the Topics and rebuilt the forum information and clear the system cache and the error still shows. It shows in 2 spots under debug mode. Once on the front page and once in the private messages when you click on the private message in the inbox to open it. When debug is not turned on, the error only shows in private messaging. Also it is only happening with one admin user. Also i have some mods installed but for some reason i am having a hard time removing them. I remove them and they keep reappearing in the installed mod list.

                  Comment

                  Related Topics

                  Collapse

                  Working...
                  X