Announcement

Collapse
No announcement yet.

Sitemap changed in upgrade

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sitemap changed in upgrade

    Hi, I went in to rebuild the sitemap manually first time since the upgrade from .4 to .5

    But I get this error message in the page..

    Error: You did not enter a valid value for this setting.
    Sitemap File Path
    XML sitemap data must be written to the filesystem to function. Enter the full path to the directory the files should be written to. Do not include a trailing slash.

    This directory must be writable by the webserver.

    ./store_sitemap

    is
    ./store_sitemap different now? what should I change the site map file path to?


  • #2
    Add the full path to your sitemap (should be something like this: /home/***/public_html/core/store_sitemap) and make the site_map folder writable cmod/perms to 0777.
    Last edited by megabink; Sun 1st Feb '15, 1:47pm.

    Comment


    • yv3013
      yv3013 commented
      Editing a comment
      I don't know what your saying.really, that's too technical for me.
      It was working fine then boof.

  • #3
    This seems to have changed in 5.1.4 to 5.1.5. When I went to rebuilt after the upgrade, it forced me to enter a new full path. I didn't see anything in the release notes about it.

    Comment


    • #4
      Originally posted by DisasterDotCom View Post
      This seems to have changed in 5.1.4 to 5.1.5. When I went to rebuilt after the upgrade, it forced me to enter a new full path. I didn't see anything in the release notes about it.
      Same here...it took me an hour or so to solve this but it's working now!

      Comment


      • #5
        Can anyone give me instructions on how to do it?

        Comment


        • yv3013
          yv3013 commented
          Editing a comment
          or at least tell me what to ask my host service to do for me, they installed 5.1.5 for me so they will know what to do if I know what to tell them to do.

      • #6
        Originally posted by yv3013 View Post
        Can anyone give me instructions on how to do it?
        Do you have access to cPanel or FileZilla do you know where your vBulletin files are located on your server?
        1.find your vBulletin files on the server...open the core folder and find store_sitemap...if you use cPanel or FileZilla click on the store_sitemap folder (do not double click) now you will see on the end of that line a number mostly on folders it is 0755 and on files it is 0644...right click on that number and change it to 0777!

        2.now replace the ./store_sitemap with the example i gave in my first post...it can be that you need to replace the public_html with htdocs or whatever you use...the (***) is mostly your username on your server now save it and rebuild your sitemap!

        Comment


        • #7
          Thanks, I did the first bit and changed 755 to 777.

          Where do I replace the ./store_sitemap? you mean where it is in admin control panel?

          I'm stuck on the (***) part, mostly my user name on my server? how do I find that?

          /home/***/public_html/core/store_sitemap

          Comment


          • #8
            Originally posted by yv3013 View Post
            Thanks, I did the first bit and changed 755 to 777.

            Where do I replace the ./store_sitemap? you mean where it is in admin control panel?

            I'm stuck on the (***) part, mostly my user name on my server? how do I find that?

            /home/***/public_html/core/store_sitemap
            Yes in the admin control panel...go to settings--->click options--->find XML Sitemap click it and scroll down to Sitemap File Path,in this field you need to add: /home/***/public_html/core/store_sitemap and save it!
            I have to add...if you don't have a public_html folder then you need to rename the public_html part with the one you use...this is the folder where your vB files are located!

            The (****) is likely your username yes!...once you did everything right the the error will be gone and you can start to rebuild your sitemap manually or automatically that's up to you!
            Last edited by megabink; Mon 2nd Feb '15, 2:05pm.

            Comment


            • #9
              Thanks, I appreciate your help.

              How do I know exactly what *** is? I tried the main user name and admin user name, don't seem to work.

              I tested the sitemap after putting in the user names in webmaster tools, it gives this error when testing a sitemap submitted.

              General HTTP error: HTTP 403 error (Forbidden) HTTP Error: 403

              I don't think I have the right user name, where is it? or how do I find where *** is?

              Comment


              • #10
                Originally posted by yv3013 View Post
                Thanks, I appreciate your help.

                How do I know exactly what *** is? I tried the main user name and admin user name, don't seem to work.

                I tested the sitemap after putting in the user names in webmaster tools, it gives this error when testing a sitemap submitted.

                General HTTP error: HTTP 403 error (Forbidden) HTTP Error: 403

                I don't think I have the right user name, where is it? or how do I find where *** is?
                Do you have cPanel if so then look in the left panel (Stats) on the main page and find Home Directory should be on the second row...there you will find the *** part!

                Comment


                • #11
                  ok got that, thanks.

                  That side of it seems to work now but I still get the errors in webmaster tools after submitting the sitemaps.

                  am I doing it right? should all 3 site maps be submitted?
                  We encountered an error while trying to access your Sitemap.
                  Please ensure your Sitemap follows our
                  guidelines and can be accessed at the location you provided and then resubmit.
                  General HTTP error: HTTP 403 error (Forbidden) HTTP Error: 403

                  Comment


                  • megabink
                    megabink commented
                    Editing a comment
                    No Google needs only the path to your sitemap....the Google bots will only read what's inside the xml.gz files.
                    Do you allow guests/visitors on your site?....if not then Google bots can not see your site or your sitemap...or do you block Google via your htaccess maybe?

                  • yv3013
                    yv3013 commented
                    Editing a comment
                    No everything worked fine before the upgrade from 5.1.4 to 5.1.5.

                    Isn't this the path to my sitemap?

                    /core/xmlsitemap.php?fn=vbulletin_sitemap_node_0.xml.gz
                    /core/xmlsitemap.php?fn=vbulletin_sitemap_starter_1.xml.gz
                    /core/xmlsitemap.php?fn=vbulletin_sitemap_page_2.xml.gz

                    That's what i've always had on webmaster tools and it worked fine, now all of a sudden there these errors.

                    ok so I put in the path to my sitemap and same thing, those errors.

                    oh man, this is hopeless.

                    and what's going on with that text I pasted? is it just me or can everyone see it's gone outside the page?

                • #12
                  geez, what have I done?

                  Comment


                  • #13
                    I've the same problem, right after upgrading to 5.1.5.

                    First it works fine with "./store_sitemap". After upgrading from 5.1.4 (latest patch), i get the message "You did not enter a valid value for this setting". No sitemaps are made anymore. Not automatically, not manual.

                    I Already tried:
                    ./core/store_sitemap
                    /core/store_sitemap
                    ./store_sitemap
                    /store_sitemap
                    /domains/mydomainname.nl/public_html/core/store_sitemap (it's copied from DirectAdmin filebrowser and Filezilla root path)

                    The folder "store_sitemap" (and the files in it) are chmod 777.

                    How can I fix my broken sitemaps? My site (vBulletin) isn't found well by Google, but without sitemaps it's only get worse. Please help!

                    Comment


                    • yv3013
                      yv3013 commented
                      Editing a comment
                      Yeah not sure anyone is looking at this thread, I don't know what to do with it either.
                      i've fixed everything per instructions but google can't read the site map.

                  • #14
                    Same issue here guys .. I have excactly the same issue as you too ..

                    My folder "store_sitemap" (and the files in it) are chmod 777.

                    I tried theses paths :

                    ./core/store_sitemap
                    /core/store_sitemap
                    ./store_sitemap
                    /store_sitemap

                    But i still get this error message in the page..

                    Error: You did not enter a valid value for this setting.
                    Sitemap File Path

                    Comment


                    • #15
                      Well the information i provided worked for me but you need to add the correct path and don't use an url or domain name....i need to add i cmodded the vbulletin_sitemap.xml.gz files within the store_sitemap folder to 0666 instead of 0644...don't know this is save but that was the only way to get it to work!

                      Once you got the right path and it's accepted in your admin control panel you need to add the same path in your webmasters tool to add the sitemap!

                      Comment

                      Related Topics

                      Collapse

                      Working...
                      X