Announcement

Collapse
No announcement yet.

Upgraded PHP to 5.3 for vB5, got errors on vB4

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgraded PHP to 5.3 for vB5, got errors on vB4

    Hello everyone,

    After upgraded PHP to version 5.3.17 due to vB5 requirements. I got 404 error with Home and What's New tabs on vB4 Suite, everything else working fine. Do I missed something?
    I have vB 4.1.3 PL8 and vB5 on the same server. The vB5 seam OK. My server is cPanel WHM.

    Thanks in advanced.

  • #2
    A 404 error is a file not found error, it has nothing to do with PHP. Can you confirm the forumphp, index.php, and search.php exist on your server?

    VB4 is fully compatible with PHP 5.3.

    Comment


    • #3
      Yes, everything exist. If I reverse to PHP 5.2, the vB4 is working. The site using vB4 has htacess redirect from non www to www. Is that the problem?

      Comment


      • #4
        It shouldn't be the problem, but you can rename .htaccess to like .htaccessXXX temporarily to see if the problem goes away.

        What is the exact error showing up? Can you link to a page with the error?

        Comment


        • #5
          If I recall my last server change, there could be .htaccess changes, so look into that. Also, try disabling your modifications/plugins and see if you still have this problem.
          Note: To temporarily disable the plugin system, edit includes/config.php and add this line right under <?php


          PHP Code:
          define('DISABLE_HOOKS'true); 

          Please don't PM or VM me for support - I only help out in the threads.
          vBulletin Manual & vBulletin 4.0 Code Documentation (API)
          Want help modifying your vbulletin forum? Head on over to vbulletin.org
          If I post CSS and you don't know where it goes, throw it into the additional.css template.

          W3Schools &lt;- awesome site for html/css help

          Comment


          • #6
            Oh, I got 500 error not 404, sorry about that. I did rename the htacces but won't help and here is the site http://bienmong.com

            Comment


            • #7
              500 is a big difference, and more likely.

              I suggest you disable hooks like Lynne suggested above and see if you still have the problem.

              Comment


              • #8
                Yes, I did and go to ACP disable all then remove the line in config file and enable one by one. Only CMS and What's New have problem.

                Comment


                • #9
                  Just to be clear you weren't removing a line from config.php, you needed to add a line to config.php- did you do that?

                  The next step is to check your php and server error logs to see if there is a specific error being recorded.

                  Comment


                  • #10
                    Originally posted by Joe D. View Post
                    Just to be clear you weren't removing a line from config.php, you needed to add a line to config.php- did you do that?

                    The next step is to check your php and server error logs to see if there is a specific error being recorded.
                    Yes. I add the line in config file then go to ACP and disable all Products. After that, I remove the line in config file and enable one bye one.

                    Comment


                    • #11
                      No... Just add the line to config.php- don't do anything else except test and see if you have the same problem.

                      Enabling or disabling mods 1 by 1 is of no use unless the problem goes away with the line added to your config.php.

                      Comment


                      • #12
                        The problem not goes away and no server error log. I think something wrong with PHP and I have to recompile it. Thanks Joe and Lynne for your help.

                        Comment

                        Related Topics

                        Collapse

                        Working...
                        X