Announcement

Collapse
No announcement yet.

How do you save the settings of vB5 default style to prevent user selection?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How do you save the settings of vB5 default style to prevent user selection?

    I am generating styles on my test vB5 site (I still run vB4 on my live site).

    Having generated my new styles I don't want the old vB5 style to show. If I go to style manager and click off the x on the radio button next to vB5 default style then hit save, the changes don't save. If I choose "Edit style options" then "edit settings" that takes me to the screen which says "allow user selection". If I click "allow user selection" to no and hit "save" the changes don't save; the default style still remains available for users to select even though I don't want them to.

    How do I change this?

    PS: vBulletin.com seems very slow today. I had 60 seconds after I hit "post" where a little yellow box said "working" before my post finally appeared.
    Last edited by jdj; Fri 5th Sep '14, 9:30am.

  • #2
    Still got the same problem. I've set the settings of the vB5 default style to prevent user selection, but it won't save. I've gone to the channel manager and changed all the channels at style options, custom style for this channel to be my new style, and I've chosen "Override User's style choice" and hit save.

    However, if I then visit the site with my iPad not logged in the vbulletin default style still displays when I land on the site. At the moment the home page still displays the default 'forums' as the landing page. If I go to the site builder feature, turn this on and edit the navbar I can see that the target URL is just set as "/". So I'm guessing that ought to make the visitor land on one of my forums, all of which are set up to use something other than the default style.

    Am I missing something or is it that it just doesn't work? How do I change this? Is my only option to delete the vBulletin default style?

    Comment


    • #3
      Settings > Options > Style & Language Settings>

      Allow Users to Change Styles > No
      Default STyle > Set the style you want here as default.


      AdminCP > Styles & Templates > Style Manager

      Uncheck all styles, but the default style and click save display order

      Lastly, Maintenance > Clear System cache.

      Remember, administrators can always use and see all styles regardless of the settings.

      Comment


      • #4
        Thanks. I'm surprised though that you can't click the default style off to prevent user selection rather than changing this in vB settings options.

        Comment


        • #5
          Originally posted by Zachery View Post
          Settings > Options > Style & Language Settings>

          Allow Users to Change Styles > No
          Default STyle > Set the style you want here as default.


          AdminCP > Styles & Templates > Style Manager

          Uncheck all styles, but the default style and click save display order

          Lastly, Maintenance > Clear System cache.

          Remember, administrators can always use and see all styles regardless of the settings.
          I've done all this on my vB5 test site but it doesn't quite work. Now that I've changed the settings>options>style & language settings, set it to allow users to change styles>no and saved, and changed my default style to my new default style it has changed. But what happens now is that visitors still get a drop down box on the front page to choose the original default style. What turns up now if they select the old default style is my new default style but without the logo.

          Users also get an option to select one of my other styles which is attached to a specific forum, which has different colouring and a different logo. But what turns up if you select it is my new default style colours but with the bespoke logo. So basically it doesn't work although I don't know why.

          Edit: So having written all of the above I've gone back to my site and noted that the odd display of the bespoke style that is supposed to be attached to a specific forum that users are allowed to select although they should not be able to now doesn't work on the forum it's attached to either. So I've gone back to settings>options>style & language settings and changed them back to "allow users to change styles - yes" and saved and now the style does work on its bespoke forum. So this must be a bug of some kind although I'd struggle to describe it concisely.

          Basically on my test version of vBulletin 5.1.2PL3, which isn't customised at all and has no mods save that I have altered the css_additional.css template to change the maximum width, if you change the settings so that users are not supposed to be able to select styles they still can select them, but those styles don't work. And setting this setting to no inactivates custom styles attached to specific forums. I can't tell whether this is a bug in vB4.2.2PL1 (which is what I'm running on my live site) because I've got settings set on my live site so that users can select their own style. We don't have a problem with the live site because we deleted the original vbulletin default style years ago.

          Looks like this is something that just doesn't work and I don't have any option other than to delete the original default style.

          If I do this, will the original default style turn up again at next vB5 upgrade and undo all my changes?
          Last edited by jdj; Fri 5th Sep '14, 7:34am.

          Comment


          • #6
            Did you make sure to also disable the other styles by unchecking the check box in the style manager?

            Comment


            • #7
              Unchecking the box prevents regular users from seeing the styles listed in the drop-down menu. You, as an administrator account always see all styles regardless of if they are checked or not. There is no way to hide styles from administrators.

              Comment


              • #8
                Originally posted by Joe D. View Post
                Unchecking the box prevents regular users from seeing the styles listed in the drop-down menu. You, as an administrator account always see all styles regardless of if they are checked or not. There is no way to hide styles from administrators.
                I wasn't logged in when I went back to the site; so my status was "unregistered/not logged in". I could still select styles, they just didn't work properly.

                Comment


                • #9
                  Originally posted by Zachery View Post
                  Did you make sure to also disable the other styles by unchecking the check box in the style manager?
                  You can't disable the default style by unchecking the check box in the style manager; if you uncheck the box and save it doesn't save.

                  I can save my new style as the default: That's fine. With my other styles that are attached to specific forums what I do with this is in the forum manager (now channel manager) I set the forum to have its own custom style and click the box that says override users style choice. But what I've just discovered in vB5 is that if you then go to vB options and set the settings so that users can't choose styles, this then deactivates the custom styles even on those forums where they are supposed to be displayed. So this looks like some kind of bug but I wouldn't know whether it's unique to vB5 or whether it always existed in vB4.

                  PS: I don't want to disable all my styles; only the original vBulletin default style.
                  Last edited by jdj; Fri 5th Sep '14, 9:31am.

                  Comment


                  • #10
                    If the check box isn't going away when you save changes then that is the problem- for most people it does save and it does work.

                    Are you sure that the VB Default Style is not set to be the site's default style? (Check in Admin CP -> Settings -> Options -> Style & Language Options -> Default Style.)

                    The Default Style set there is the one style that cannot be disabled, but you can change it to another style.

                    Comment


                    • #11
                      If you find that the checkbox stays ticked and it's NOT what Joe says above, try going into the style itself by editing its setting, and setting it so it's not available for user selection.

                      In vB5 I have known the check boxes randomly "not work" like this.
                      MARK.B | vBULLETIN SUPPORT

                      TalkNewsUK - My vBulletin 5.5.2 Demo
                      AdminAmmo - My Cloud Demo

                      Comment


                      • #12
                        Originally posted by Mark.B View Post
                        If you find that the checkbox stays ticked and it's NOT what Joe says above, try going into the style itself by editing its setting, and setting it so it's not available for user selection.

                        In vB5 I have known the check boxes randomly "not work" like this.
                        With the original default style changed to one of my new styles I can now uncheck the box for the original default style. However, with the settings set so that users should not be allowed to change styles (in theory) I can still go to another computer, operating from a different IP address to the one I usually use and the drop down box allowing me to change styles still appears. Not logged in (so my status should be unregistered/not logged in) I can still choose different styles but sometimes it's only the logo that turns up, not the whole style. So there's a bug here that needs investigating.

                        Comment


                        • #13
                          Was this every resolved? I am facing the same issue.

                          Comment


                          • jdj
                            jdj commented
                            Editing a comment
                            I cannot remember what version of vB5 I was on when I had this problem and started this thread, but I'm currently on 5.1.6 and I don't have the issue today.

                        • #14
                          This thread is old and there have been many changes. Start a new thread with your version info and a description of the exact issue you are having.


                          Comment

                          Related Topics

                          Collapse

                          Working...
                          X