Announcement

Collapse
No announcement yet.

Having trouble going back to vb4

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Having trouble going back to vb4

    We were running vb 5.0.5, but we are now running vb4, mysql versiob 5.1.70-cll, PHP Version 5.4.18. Our url is, http://www.realjdjboard.com

    We put back the vb4 files, and the last copy for the database from vb4. We can not get to the message board. We are getting a blank white page. Our host told us to edit a file "class_bootstrap_framework.php", by adding "(include_path='.:/usr/lib/php:/usr/local/lib/php')" because the error log was pointing to it. The error log is still saying the file has as an issue. This is what we have for line 99,
    require_once(VB_PATH . 'vb.php')(include_path='.:/usr/lib/php:/usr/local/lib/php');

    This is the last record from the error log,
    [20-Jan-2014 15:30:22 America/Chicago] PHP Parse error: syntax error, unexpected '(' in /home/realjdjb/public_html/includes/class_bootstrap_framework.php on line 99

    I'm guessing the "(" is in the wrong place, or there are too many? Not sure what line 99 is supposed to look like?

    Any help will be appreciated!
    Thanks!!!

  • #2
    The two versions are not compatible.
    It's possible to upgrade to the higher version with the upgrader but not possible to downgrade to a lower version.


    vB5 is unequivocally the best forum software, but not yet...

    Comment


    • #3
      Originally posted by beishe8 View Post
      The two versions are not compatible.
      It's possible to upgrade to the higher version with the upgrader but not possible to downgrade to a lower version.
      If they have put back the vB4 files AND database, then it should be ok. Obviously, at the expense of losing later posts.
      MARK.B | vBULLETIN SUPPORT

      TalkNewsUK - My vBulletin 5.5.2 Demo
      AdminAmmo - My Cloud Demo

      Comment


      • #4
        The only way I can think of (regarding downgrading to vB4 without losing posts etc.) is that you first import your vB5 installation to a different forum software and from there back to vB4, if vB4 supports importing from that other forum software. That, of course, is not too comfortable and might also be costly, but it might still be worth it, if you are absolutely in need of a downgrade.
        Last edited by TLMD; Tue 21st Jan '14, 3:14am.

        Comment


        • #5
          Originally posted by beishe8 View Post
          The two versions are not compatible.
          It's possible to upgrade to the higher version with the upgrader but not possible to downgrade to a lower version.
          Check that the version of the files you have is the same as the version the database relates to.
          Also bear in mind that only 4.2.2 is compatible with php 5.4. If your database is an earlier version then you will need to upload the 4.2.2 files and run the upgrade script.

          Finally, make sure there is no trace of any vB5 files, especially .htaccess which may not be visible in your ftp client.
          MARK.B | vBULLETIN SUPPORT

          TalkNewsUK - My vBulletin 5.5.2 Demo
          AdminAmmo - My Cloud Demo

          Comment


          • #6
            We were aware that we'd be losing post. It wasn't a concern because there weren't many that was going to be lost. I do see .htaccess.bkp, when I open it there is 1 line "DirectoryIndex index.php".

            I have the vb5 files in its own directory called "vb5", should it be deleted?

            The error log is still pointing to class_bootstrap_framework.php

            I'm pretty sure the vb4 files & the database were what we had before upgrading to vb5. Is there a way to check the version without being able to see the board, or access the admin? Should I just go ahead and upgrade to 4.2.2?

            Thanks for the help Guys! We really appreciate it!!!

            Comment


            • #7
              Thanks a MILLION Guys! Upgraded to 4.2.2, and its working now!!! I'm thinking the php5.4 was the issue 'cause we were running 4.2.1.
              Thanks again!

              Comment


              • #8
                so, just want to be clear. I'm running 5.0.5, and there's no way to downgrade to 4.x without losing all posts and users? Also, we do not yet know the timing of vb 5.1, and we also don't know to what extent it will address the issues plaguing the current version? Is that about where we are right now? We just saw the note about the cloud/hosting service, seems to be moot if the software doesn't deliver or adequately QC'd.

                Comment


                • #9
                  Originally posted by rosevalleykennels View Post
                  We were running vb 5.0.5, but we are now running vb4, mysql versiob 5.1.70-cll, PHP Version 5.4.18. Our url is, http://www.realjdjboard.com

                  We put back the vb4 files, and the last copy for the database from vb4. We can not get to the message board. We are getting a blank white page. Our host told us to edit a file "class_bootstrap_framework.php", by adding "(include_path='.:/usr/lib/php:/usr/local/lib/php')" because the error log was pointing to it. The error log is still saying the file has as an issue. This is what we have for line 99,
                  require_once(VB_PATH . 'vb.php')(include_path='.:/usr/lib/php:/usr/local/lib/php');

                  This is the last record from the error log,
                  [20-Jan-2014 15:30:22 America/Chicago] PHP Parse error: syntax error, unexpected '(' in /home/realjdjb/public_html/includes/class_bootstrap_framework.php on line 99

                  I'm guessing the "(" is in the wrong place, or there are too many? Not sure what line 99 is supposed to look like?

                  Any help will be appreciated!
                  Thanks!!!
                  The error is telling you that vb.php doesn't exist within the allowed include path.

                  You need to use vBulletin 4.2.2 with PHP 5.4.18. After deleting all the vBulletin 5.X files and replacing them with your vBulletin 4.2.2 files, make sure the config.php file is updated and run /install/upgrade.php.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                  vBulletin 5 Documentation - Updated every Friday. Report issues here.
                  vBulletin 5 API - Full / Mobile
                  I am not currently available for vB Messenger Chats.

                  Comment

                  Related Topics

                  Collapse

                  Working...
                  X