Announcement

Collapse
No announcement yet.

Upgrade from 5.3.3 to 5.4.5 fails to support 5.3.3 site builder menu

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Site Builder] Upgrade from 5.3.3 to 5.4.5 fails to support 5.3.3 site builder menu

    I upgraded from 5.3.3 to 5.4.5 and the site builder is broken in several ways:

    1) The admin_sitebuilder_menu template is completely missing after the upgrade! (I had to pull the source code for it from elsewhere and create that template manually)
    2) The ajax/activate-sitebuilder request failed to load the "menu" JSON value (under the parent "css" attribute), because of the missing template from #1.
    3) admin-sitebuilder-rollup-545.js does not reference the main-navbar (id) DIV element any longer (in order to fill in the appropriate child element with the returned DOM fragments from the ajax call of #2)
    4) Even after re-creating the admin_sitebuilder_menu template manually, the admin-sitebuilder-rollup-545.js still does nothing with the "menu" value now successfully being returned from step #2 and all actions in that menu are empty (nothing happens with clicks, etc). Note that to see the menu show up, I have to "enable" site builder (turning "Edit Site" to "On") and refreshing the page.

    Something has dramatically changed between these two versions with regard to activating site builder and it's associated menu. Please help. Also note that I contract for a licensed customer, so if providing their license information helps to escalate this issue, let me know what I can provide in this regard.

  • #2
    None of this happens on a default installation.

    Did your upgrade run without errors? Did you upload the entire 5.4.5 package AND run the upgrade script? Did it give you an 'Upgrade Complete' message at the end?
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.5.2 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      Mark.B
      Did your upgrade run without errors?
      Yes, besides some template conflicts that I saw from within the Admin CP, POST-UPGRADE. However, if you mean "errors" that still allowed the upgrade process to continue and not stop, then I can't be sure, since the status panel of the upgrade script (via HTTP) was quite long and I didn't read all of it, besides the last 20 or so lines.

      Did you upload the entire 5.4.5 package AND run the upgrade script?
      I uploaded the "upload" folder from the zip file of 5.4.5 and ran the upgrade script via HTTP. I followed the official online VB upgrade tutorial.

      Did it give you an 'Upgrade Complete' message at the end?
      Yes, along with the "Now, delete the install directory and go to the Admin CP" message.

      Comment


      • #4
        Please make sure you're using unedited templates. Updated templates would be listed under Styles -> Find Updated Templates. Template changes can cause these errors. Especially with such a large jump in functionality. There are probably close to 1,000 issues resolved between 5.3.3 and 5.4.5.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        I am not currently available for vB Messenger Chats.

        Comment


        • #5
          Wayne Luke
          Please make sure you're using unedited templates. Updated templates would be listed under Styles -> Find Updated Templates.
          Will that page show conflicts with templates? Because as I posted above, on the Admin CP homepage, it listed template merges and conflicts after the upgrade. And I manually merged the conflicting templates. Right now, when I go to Styles -> Find Updated Templates in the upgraded Admin CP, it shows "All templates are up-to-date."

          Comment


          • #6
            Wayne Luke or Mark.B Do either of you know if the Site Builder was changed at some point from 5.3.3 to 5.4.5 such that the items I listed in my OP are expected? Especially, #1.

            Comment


            • #7
              The way the Site Builder menu is built was completely redone and separated from the User Menu in the 5.4.X series. This enables it to work better on smaller screens.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud customization and demonstration site.
              vBulletin 5 Documentation - Updated every Friday. Report issues here.
              vBulletin 5 API - Full / Mobile
              I am not currently available for vB Messenger Chats.

              Comment


              • #8
                Wayne Luke
                The way the Site Builder menu is built was completely redone and separated from the User Menu in the 5.4.X series. This enables it to work better on smaller screens.
                Thanks. I'll have to run through the template conflicts again, then, because I'm assuming my manual resolution of the conflicts removed the "new" way Site Builder is displayed/interacts with the DOM, in favor of the older style (prior to 5.4.x).

                Comment


                • #9
                  Wayne Luke or Mark.B Per my last post, I manually merged the 5.4.x sitebuilder way of doing things in the header template with the customizations I need for the header template and now the 5.4.x sitebuilder works as expected. You can close this issue. Thanks.

                  Comment

                  Related Topics

                  Collapse

                  Working...
                  X