Announcement

Collapse
No announcement yet.

very slow pages

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • very slow pages

    My site runs in alpine docker containers.
    It was running with PHP 7.1.5 and 10.1.22-MariaDB
    I have since upgraded my containers to PHP 7.19 and 10.1.26-MariaDB

    However vbulletin pages now take 28 seconds to load, before they were < 1 second.
    The other PHP sites I host in this container are fine (piwik, rainloop, wordpress).

    What can i do to find out why vbulletin has become so slow, are there any granular debug logs which will help me isolate the issue?

    Thanks

    FYI, running current stable and i've also tried 5.3.3 rc2.

    i've tried enabbling the logger but get this error

    nginx_1 | 168.168.33.250 - - [19/Sep/2017:12:18:56 +0000] "GET / HTTP/2.0" 500 0 "-" "Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3110.0 Safari/537.36" "-"
    nginx_1 | 2017/09/19 12:19:12 [error] 6#6: *159 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught Error: Call to undefined function simplexml_load_file() in /var/lib/nginx/vb5/core/libraries/log4php/src/main/php/configurators/LoggerConfigurationAdapterXML.php:82
    nginx_1 | Stack trace:
    nginx_1 | #0 /var/lib/nginx/vb5/core/libraries/log4php/src/main/php/configurators/LoggerConfigurationAdapterXML.php(43): LoggerConfigurationAdapterXML->loadXML('/var/lib/nginx/...')
    nginx_1 | #1 /var/lib/nginx/vb5/core/libraries/log4php/src/main/php/configurators/LoggerConfiguratorDefault.php(162): LoggerConfigurationAdapterXML->convert('/var/lib/nginx/...')
    nginx_1 | #2 /var/lib/nginx/vb5/core/libraries/log4php/src/main/php/configurators/LoggerConfiguratorDefault.php(118): LoggerConfiguratorDefault->parseFile('/var/lib/nginx/...')
    nginx_1 | #3 /var/lib/nginx/vb5/core/libraries/log4php/src/main/php/configurators/LoggerConfiguratorDefault.php(86): LoggerConfiguratorDefault->parse('/var/lib/nginx/...')
    nginx_1 | #4 /var/lib/nginx/vb5/core/libraries/log4php/src/main/php/Logger.php(517): LoggerConfiguratorDefault->config" while reading response header from upstream, client: 139.59.109.12, server: forums.xxxxxx.net, request: "GET / HTTP/1.1", upstream: "fastcgi://172.19.0.2:9000", host: "forums.xxxxxxx.net"
    Last edited by ep0ch; Tue 19th Sep '17, 4:24am.

  • #2
    You seem to be missing the SimpleXML extension.

    AutoLinker-vB5+vBCloud | NavMenu Dropdown-vB5+vBCloud | TimedSticky | Video Attachments Player | Blur Replies for Guests | Drag/Drop Upload | Topic Starter Ribbon | Topic AJAX Auto-Update

    Comment


    • #3
      cheers, it ended up being memcached... so I had to change php to use files for session and remove all references to memcached in vbulletin config.php.
      memcached is more trouble that its worth

      Comment


      • #4
        You can flush memcached from the command line:

        https://www.cyberciti.biz/faq/linux-...ched-instance/
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        I am not currently available for vB Messenger Chats.

        Comment


        • #5
          memcached just seems to not work at all, must be an issue with the latest alpine linux package. I give up with it, it's caused me nothing but issues in the past anyway.

          Comment

          Working...
          X