Announcement

Collapse
No announcement yet.

cant build ios app Incorrect SSL Cipher

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • cant build ios app Incorrect SSL Cipher

    im getting this error when trying to build ios app i have no idea how to change ciphers or what im suposed to do. Incorrect SSL Cipher Cipher : DHE-RSA-AES256-GCM-SHA384HE-RSA-AES256-GCM-SHA384. The site must use one of the acceptable Ciphers. See here

  • #2
    Where exactly are you getting that error? In the Mobile Publisher or when trying to upload the package in the Apple Developer portal?
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - Highlight the correct navigation tab when you are on a custom page
    - "Quick Route" Interface...
    - Allow to use custom icons for individual forums

    Comment


    • #3
      Make sure your server is using TLS 1.2 and that all URLs are accessed via HTTPS with a valid certificate. This is an Apple requirement.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud customization and demonstration site.
      vBulletin 5 Documentation - Updated every Friday. Report issues here.
      vBulletin 5 API - Full / Mobile
      I am not currently available for vB Messenger Chats.

      Comment


      • #4
        I am getting error in publisher. I am running tls 1.2 and all pages are https with valid certificate

        Comment


        • #5
          I've created a ticket with the Mobile Publisher development team to see how to resolve this.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud customization and demonstration site.
          vBulletin 5 Documentation - Updated every Friday. Report issues here.
          vBulletin 5 API - Full / Mobile
          I am not currently available for vB Messenger Chats.

          Comment


          • #6
            This is what I received...
            The issue is with the key exchange. They are using DHE while Apple requirements call for ECDHE.

            Reference: https://developer.apple.com/library/...P40009251-SW33

            The connection must use either the AES-128 or AES-256 symmetric cipher. The negotiated TLS connection cipher suite must support perfect forward secrecy (PFS) through Elliptic Curve Diffie-Hellman Ephemeral (ECDHE) key exchange, and must be one of the following:
            TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384
            TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256
            TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA384
            TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA
            TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256
            TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA
            TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384
            TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256
            TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384
            TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256
            TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA
            You need to discuss this with your hosting provider so the exchange can be updated to the proper protocol.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud customization and demonstration site.
            vBulletin 5 Documentation - Updated every Friday. Report issues here.
            vBulletin 5 API - Full / Mobile
            I am not currently available for vB Messenger Chats.

            Comment


            • #7
              ok i figured at had to be resolved with my host i just had no idea what to tell them to get it fixed

              Comment

              Working...
              X