Announcement

Collapse
No announcement yet.

Import stops

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Import stops

    I'm importing 50,000 posts. About 6,000-7,000 posts into the import, it just stops. No error message. Nothing in the PHP error log. If I import a different set of posts, same thing. I have upped the PHP memory and execution time and rebooted to make certain they took hold. Is there any way to find out where/why it gets stuck?

  • #2
    Increase your PHP Timeout values. Increase your MYSQL Timeout values. Increase your Apache timeout values. Most things expect a script to finish in less than 30 seconds.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      PHP timeout is set to one hour.

      Comment


      • #4
        Yes but your MySQL and Apache timeouts also have to be set appropriately.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        I am not currently available for vB Messenger Chats.

        Comment


        • #5
          PHP execution time is one hour. I don't see how MySQL could timeout. Not running Apache. I upped the IIS timeout to one hour and the IIS Application Pool timeout to 40 minutes. No good. It runs for about 10-12 minutes and then either halts or gets a 500 Internal server error. Usually, it just stops. Timeouts should cause errors anyhow.

          Comment


          • #7
            OK, I got further. If you are running FASTCGI, which everyone using IIS does, FASTCGI has an additional timeout. This is fixed in IIS 7 by:


            C:\Windows\System32\inetsrv\appcmd set config -section:system.webServer/fastCgi "-[fullPath='C:\Program Files (x86)\PHP\php-cgi.exe'].activityTimeout:3600"

            This fixes the internal server error. I still have the problem with the import stopping with no error. However, I can get about 30,000 posts imported before the hang. There is no error on the hang. No error in the PHP error log either.

            Comment


            • #8
              Are you using the non-threadsafe version of PHP? What version of PHP are you using?
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud customization and demonstration site.
              vBulletin 5 Documentation - Updated every Friday. Report issues here.
              vBulletin 5 API - Full / Mobile
              I am not currently available for vB Messenger Chats.

              Comment


              • #9
                Non-threadsafe. PHP 5.3.10. The site works fine. It's Impex that is having a problem.

                Comment


                • #10
                  I think I just haven't pumped up the numbers enough. One hour is too short.

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X