Announcement

Collapse
No announcement yet.

Vbulletin 4.2.5 on php 7.1

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Vbulletin 4.2.5 on php 7.1

    Good morning,
    I have a forum on the vbulletin 4.2.5 engine and everything was fine when I was in PHP 5.6, but I had to change the server, and the new version is PHP 7.1 and I have 2 problems:
    1. By posting, it doubles, i.e. Adds 2 same posts one below the other, and the option to merge duplicates does not work here.

    2. You can not edit any post, after clicking "edit" only the mouse pointer circle rotates and nothing happens.

    In config.php, I have disabled all modifications and errors still exist, I turn on error messages and no message appears.

    Today I noticed that the error related to editing posts and duplicating posts does not have a mobile style.

    They appear in the default vbulletin style and all desktop styles, but not on the mobile style.

    Anyone have any ideas?

  • #2
    This is probably not a PHP 7.1 issue but rather a change in server and server configuration issue. The primary reason for double posting and timeouts for editing is a slow server or insufficient resources on the server - but not always. Last year, I had a similar problem with one site and despite efforts by server tech support I could not resolve it. I change to a different host and the problem vanished.

    Have you tried getting your host involved? Getting them to look at server logs and let you know what's going on?

    Is it shared hosting? VPS? Dedicated?
    Psychlinks Mental Health Support Forum
    Local Search Forum

    Comment


    • #3
      When I moved the site to the New VPS server, at my request I installed PHP 5.6 and everything was fine, nothing doubled and you could edit posts, but they set something wrong, because every three days there were Mysql errors and you had to fix the tables using innodb_force_recovery. They could not solve the problem, so I reinstalled the system and default is the PHP 7.1 version and the server service strongly advises against the reinstallation of PHP 5.6. That's why I want to stay on this version of PHP but I have to eliminate these errors.


      This is the same VPS server only after reinstalling the system I have PHP 7.1 and these errors. I also noticed that on the normal default style, there are doubled posts in addition to the department for administration and moderators, but edit in this section just like the whole forum can only be on the mobile style.
      Last edited by DarkArea; Sat 2nd Feb '19, 11:23am.

      Comment


      • #4
        It's definitely server related.

        The first step step should be to check the server error logs for the exact time these issues occur.

        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.5.1 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #5

          I checked the error logs of my site and only had two entries in them:
          PHP Code:
          [Sun Jan 27 04:05:31.499366 2019] [php7:warn] [pid 28271] [client xxxxxxxxxxxxxxPHP Warning:  preg_replace(): Empty regular expression in /web/darkarea.pl/public_html/includes/cron/amp_auto_tagger_cron.php on line 134refererhttp://darkarea.pl/filmy-z-napisami-lub-bez-napisow-59/widows-2018-a-1671799/ 
          I have already removed the amp auto tagger plugin


          PHP Code:
          [Sat Jan 19 05:00:34.337165 2019] [php7:warn] [pid 6015] [client xxxxxxxPHP Warning:  file_get_contents(/web/darkarea.pl/public_html/vbseo/resources/xml/config.xml): failed to open streamNo such file or directory in /home/admin/web/darkarea.pl/public_html/vbseo/includes/functions_vbseo_pre.php on line 279

          [Sat Jan 19 05:00:34.349591 2019] [php7:warn] [pid 6015] [client xxxxxxxxPHP Warning:  include_once(/web/darkarea.pl/public_html/vbseo/../includes/VBSEO_VB_CONFIG): failed to open streamNo such file or directory in /home/admin/web/darkarea.pl/public_html/vbseo.php on line 17 
          vbseo I uninstalled a long time ago, but the files on the server are because when I try to delete them, I have a 404 error on the page and no page.

          Comment


          • #6
            You need to get the files off the server!
            vBSEO is insecure and hasn't been updated in many years. The company that made it ceased trading a long time ago.

            You need to remove the files, uninstall the product and remove their .htaccess rules.

            https://www.vbulletin.com/forum/foru...32#post4363832
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.5.1 Demo
            AdminAmmo - My Cloud Demo

            Comment


            • #7
              Super, complete deletion of redirects from htaccess and all files solved the problem, no duplicate posts and you can edit posts.

              Thanks a lot.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X