Announcement

Collapse
No announcement yet.

Error when trying to upgrade from VB4.1.10 to VB4.2.5

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error when trying to upgrade from VB4.1.10 to VB4.2.5

    Hi All,

    I have the following error when i was trying to upgrade my vb4.1.10 to vb4.2.5. What should i do?


    Click image for larger version

Name:	Screenshot 2018-10-24 at 9.03.01 PM.png
Views:	1
Size:	685.1 KB
ID:	4401163


    Code:
    Unexpected Text:  
     <br /> <b>Warning</b>:  A non-numeric value encountered in <b>/home/dplayboy/public_html/forumvb4/includes/class_core.php</b> on line <b>5842</b><br /> <br /> <b>Warning</b>:  A non-numeric value encountered in <b>/home/dplayboy/public_html/forumvb4/includes/class_core.php</b> on line <b>5842</b><br /> <?xml version="1.0" encoding="windows-1252"?> <error>Customer Number Incorrect</error>

  • #2
    You should enter the correct Customer Number, as the error tells you to do.

    Comment


    • #3
      Originally posted by In Omnibus View Post
      You should enter the correct Customer Number, as the error tells you to do.
      Apparently my customer number is correct. error for wrong customer number is like below. Anyway the "warning" error was already there before i key in customer number. Anyone else can help?

      Click image for larger version

Name:	Screenshot 2018-10-24 at 10.21.46 PM.png
Views:	1
Size:	789.4 KB
ID:	4401167

      Comment


      • #4
        What version of PHP are you using?

        Comment


        • #5
          Originally posted by In Omnibus View Post
          What version of PHP are you using?
          ea-php71. it's 7.1. mysql is 5.6.38-1

          what should i do?

          Comment


          • #6
            Originally posted by decentplayboy View Post

            ea-php71. it's 7.1. mysql is 5.6.38-1

            what should i do?
            What character set are you using?

            Comment


            • #7
              Originally posted by In Omnibus View Post

              What character set are you using?
              html character set is ISO-8859-1

              Comment


              • #8
                Is PHP 7.1, the default PHP on the server? The behavior is indicative of running a version lower than the minimum required of PHP 5.6.30. If you add a file to your vBulletin directory with the following code what version does it show?

                Code:
                <?php
                phpinfo();
                ?>
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                vBulletin 5 Documentation - Updated every Friday. Report issues here.
                vBulletin 5 API - Full / Mobile
                I am not currently available for vB Messenger Chats.

                Comment


                • #9
                  Originally posted by Wayne Luke View Post
                  Is PHP 7.1, the default PHP on the server? The behavior is indicative of running a version lower than the minimum required of PHP 5.6.30. If you add a file to your vBulletin directory with the following code what version does it show?

                  Code:
                  <?php
                  phpinfo();
                  ?>
                  put this above file in my vbulletin folder. It show 7.1.23 PHP Version 7.1.23

                  what should i do?

                  Comment


                  • #10
                    Open a support ticket with access to your server. The link is in the footer of this page.
                    Translations provided by Google.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                    vBulletin 5 Documentation - Updated every Friday. Report issues here.
                    vBulletin 5 API - Full / Mobile
                    I am not currently available for vB Messenger Chats.

                    Comment


                    • #11
                      Originally posted by Wayne Luke View Post
                      Open a support ticket with access to your server. The link is in the footer of this page.
                      Hi, here is the background, i have a live vb4.1.10 running on an old server (5-6years). I made a copy of vb4.1.10 database and move to new server. I uploaded fresh vb5.2.5 files and upgrade my vb4.1.10 database on new server. is this the rootcause for getting the error?

                      Comment


                      • #12
                        You cannot use vBulletin 5.2.5 with PHP 7.1. Nor will we provide support for vBulletin 5.2.5. It should be considered end of life. You will need to use vBulletin 5.4.4 files. Why you would want to use an insecure version of the software that has about 2,000 additional bugs in it, I don't know.
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                        vBulletin 5 Documentation - Updated every Friday. Report issues here.
                        vBulletin 5 API - Full / Mobile
                        I am not currently available for vB Messenger Chats.

                        Comment


                        • #13
                          Originally posted by Wayne Luke View Post
                          You cannot use vBulletin 5.2.5 with PHP 7.1. Nor will we provide support for vBulletin 5.2.5. It should be considered end of life. You will need to use vBulletin 5.4.4 files. Why you would want to use an insecure version of the software that has about 2,000 additional bugs in it, I don't know.
                          Hi Wayne, I have a live vb5.4.4 forum which i upgraded from vb4.1.10 last week. i encountered many issues. That's why i am consider back vb4.2.5. since you not encourage me to use vb4.2.5. i will work full time on vb5.4.4 issues. i opened few tickets on vb5.4.4 already 1 day ago and waiting for supports. thanks

                          Comment


                          • #14
                            Originally posted by decentplayboy View Post

                            Hi Wayne, I have a live vb5.4.4 forum which i upgraded from vb4.1.10 last week. i encountered many issues. That's why i am consider back vb4.2.5. since you not encourage me to use vb4.2.5. i will work full time on vb5.4.4 issues. i opened few tickets on vb5.4.4 already 1 day ago and waiting for supports. thanks
                            Wait, some confusion here.

                            4.2.5 is fine to use. It's the final release in the vB4 series.
                            5.2.5 is not, as the latest release in the vB5 series is 5.4.4.

                            So, earlier in the thread you said 4.2.5, and your screenshot shows that. But then you said 5.2.5. I think that's where the problem lies. With support issues it's important to be very specific, because even one digit wrong can cause confusion.
                            MARK.B | vBULLETIN SUPPORT

                            TalkNewsUK - My vBulletin 5.4.4 Demo
                            AdminAmmo - My Cloud Demo

                            Comment

                            Related Topics

                            Collapse

                            Working...
                            X