Announcement

Collapse
No announcement yet.

PHP Error Help Please!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] PHP Error Help Please!

    Hello, I would like some help with an issue that has been happening the past 3 days.

    The first thing that happened was our server ran out of space. The VB database started giving an error as it was unavailable because of this.

    We cleared the space and then as expected the table searchcore_text got marked as "crashed and should be repaired".

    We repaired it through php myadmin and the forum started to work again, no problems there.

    However..

    Then we started to get random error messages when trying to start/edit/post a new post or thread. It's this:

    "HTTP Error 500.0 - Internal Server Error
    C:\Program Files (x86)\Parallels\Plesk\Additional\PleskPHP5\php-cgi.exe - The FastCGI process exited unexpectedly"

    Error code 0xc0000005.

    The issue here is that when we click "submit post/thread" we don't always get the error, it's totally random. But the posts are always published, even when the error shows up.

    Also, when the error appears, the published post/thread does not show up in the "new posts" section of the forum or the "newly replied" threads section of the forum.

    VB 4.2.2 level 6
    PHP 5.2.17

    Any ideas on what we should do to correct this? Thank you!
    Last edited by supra10; Sat 20th Oct '18, 1:02pm.

  • #2
    500 is a server error, not a software error. PHP 5.2 was declared EOL back in 2011. vBulletin 4.2.2 was released five years ago. You should update both of these in any case.

    Comment


    • MasetX
      MasetX commented
      Editing a comment
      This proposal goes nowhere because many projects can not just change everything. They would bounce off many users of their projects. IB already has experience with that. If you do not change this kind of marketing soon, the VB community will continue to shrink as the software does not really get better.

      Plesk has learned here and supports PHP down to version 5.2 so there is no reason to risk a project because of the PHP version.

      However, if you do not use too many mods you should update to the last possible version of your series, ie 3.8.11 or 4.2.5 and use PHP 7.1 because the performance of the VB will increase a lot. Unfortunately, VB5 is not useful because it is very slow even on new hardware.

      Google translated

    • In Omnibus
      In Omnibus commented
      Editing a comment
      There are no circumstances under which I would ever recommend someone continue using PHP versions or software versions which are known security risks. There's a huge difference between being able to get something to work and safeguarding the personal data contained within the database. No one should ever recommend a solution that does not put the security of data first. It's also impossible to use the latest version of vBulletin 4.x without upgrading the PHP to 5.6 or higher and the mysql version to 5.5 or higher and switching from mysql to mysqli so you're talking in circles. No one other than you said anything about vBulletin 5. It seems like your only purpose in being here is to attack that version of the software. How does that assist a vBulletin 4 customer?

  • #3
    https://talk.plesk.com/threads/after...ctedly.336448/

    Comment


    • #4
      I would certainly suggest upgrading php to 5.6 or 7.1 and upgrading vBulletin to 4.2.5.
      Then see if the errors persist.
      If you have a lot of third party add-ons, I would probably use php 5.6.
      MARK.B | vBULLETIN SUPPORT

      TalkNewsUK - My vBulletin 5.4.4 Demo
      AdminAmmo - My Cloud Demo

      Comment


      • #5
        Make sure you're not using APC or APCU.

        Unfortunately, we don't have a test environment for your version of PHP and vBulletin anymore. Such out of date software isn't allowed to run on corporate servers due to the security risks involved. However, if you provide the .htaccess and PHP Error logs that correspond with the error, we may be able to provide additional guidance.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        I am not currently available for vB Messenger Chats.

        Comment

        Related Topics

        Collapse

        Working...
        X