Announcement

Collapse
No announcement yet.

'vb_blog_attachmentlegacy' doesn't exist

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • steamboats
    started a topic 'vb_blog_attachmentlegacy' doesn't exist

    'vb_blog_attachmentlegacy' doesn't exist

    I'm getting database errors since I've upgraded from vb3.8.x to vb4.2.5: 'vb_blog_attachmentlegacy' doesn't exist

    I know it probably was a mistake to delete the blog and the blog database tables before the update and I probably did some other things I shouldn't have one. But it was an emergency situation and I had to act quickly. So now I ended up with receiving these error messages and hope to find a way to get rid of them:

    -------------------------------------------------------
    Database error in vBulletin 4.2.5:

    Invalid SQL:

    SELECT newattachmentid
    FROM vb_blog_attachmentlegacy
    WHERE oldattachmentid = 55;

    MySQL Error : Table '
    DATABASENAME.vb_blog_attachmentlegacy' doesn't exist
    Error Number : 1146

    -------------------------------------------------------

    Is there anything I can do to stop this errors from happening? I don't care about the legacy attachments etc., just want to eliminate the database errors ...

    I've checked old database backups but didn't find this table there - so the idea to simply restore the missing table, which was my fist thought, won't work.

    Thanks for any idea how to deal with this!

    Kind regards,
    Franz

  • steamboats
    replied
    Thanks a lot; upgrade was smooth and the issue is solved :-)

    Leave a comment:


  • Joe D.
    replied
    Just download the VB4 Forum, Blogs & CMS version and re-run the upgrade.php script. It will upgrade you from Forum Only to Suite.

    Take a database backup before upgrading.

    Leave a comment:


  • steamboats
    replied
    Okay, got it :-) Now: How can I switch from "forum only" to the "Forum, CMS &, Blogs" version? I've only installed the "forum only" version ...

    Leave a comment:


  • Wayne Luke
    replied
    It is part of the vBulletin 4 Publishing Suite when you download it.

    Leave a comment:


  • steamboats
    replied
    I don't have it installed as in the download section it says "It can not be installed on vBulletin 4!" ...

    Leave a comment:


  • Wayne Luke
    commented on 's reply
    Do you have the blog product installed in vBulletin 4? You should make sure this is installed. If you don't want to make available to your users, then select "Disable" from the product list in the AdminCP.

  • steamboats
    commented on 's reply
    It's not during the upgrade. The upgrade itself worked like a charm. It's now, after the upgrade with the message board fully operational and running. I just get these error messages by mail notification ...

  • Wayne Luke
    replied
    What step is this?

    Though the easiest way to eliminate the errors is to reinstall the vBulletin Blog product and make sure it is enabled during the upgrade.

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X