Announcement

Collapse
No announcement yet.

ckEditor just a grey field, can't post anything

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • steamboats
    started a topic ckEditor just a grey field, can't post anything

    ckEditor just a grey field, can't post anything

    after upgrading to vBulletin 4.2.5 from 3.8.11 everything works fine, except from the most important thing: I can't post anything because instead of the editor there is just a grey field (see screenshot).

    Firefox webconsole shows the following error: uncaught exception: [CKEDITOR.editor.setMode] Unknown mode "enhancedsource".

    Google Chrome console reports the same, and in addition: GET http:// www.mydomain.org/ forum/ clientscript/ ckeditor_config.js?v=425&t=B8DJ5M3 net::ERR_ABORTED

    I'm using the default template, all plugins and products are deactivated (Skimlink, ForumRunner) or I did uninstall them even before the update. The issue appears in all browsers. PHP version is 5.6.

    Any idea how I can fix this ant get the ckEditor to work properly?

    Thanks and kind regards,
    Franz
    Last edited by steamboats; Wed 25th Apr '18, 11:07am.

  • steamboats
    replied
    Thank you so much for your help and patience. As you guided me in the right direction, eventually I found the solution: It was a setting in the .htaccess, implemented to increase security, blocking the URL containing the term "config" ...

    Again thanks a lot!

    Leave a comment:


  • Mark.B
    replied
    Originally posted by steamboats View Post
    I've tried the Standard Control setting as one of my first attempts to solve the issue. It doesn't make any difference, still get the error for the ckEditor. I'll digg into that 403-error as I guess that's where the real issue is.
    I think you also have to enable it in your own profile....UserCP > Options > Miscellaneous Options > Message Editor Interface > Standard Editor

    Leave a comment:


  • steamboats
    replied
    I've tried the Standard Control setting as one of my first attempts to solve the issue. It doesn't make any difference, still get the error for the ckEditor. I'll digg into that 403-error as I guess that's where the real issue is.

    Leave a comment:


  • steamboats
    replied
    Okay, I understand what the problem is. I'll digg into this with my hoster. It's weird as it's exactly the same configuration, same file and folder rights set as in the fresh install where it works without any issues.

    Thanks for guiding me in the (hopefully) right direction to get closer to a solution :-)

    Leave a comment:


  • Wayne Luke
    replied
    You can disable CKEditor under Settings -> Options -> Message Editor Interface Options. Set the three settings to Enable Standard Controls. Not as pretty but should get the job done until the server issue is resolved.

    Leave a comment:


  • steamboats
    replied
    here is a screenshot of the browser consule error message(s).

    Leave a comment:


  • Wayne Luke
    replied
    Visiting your site, I get a forbidden 403 error on your ckeditor_config.js script. This is causing the problem and it is originating from the webserver. If it isn't mod_security then something on the web server it blocking it. We cannot diagnose this issue.

    Failed to load resource: the server responded with a status of 403 (Forbidden)
    Click image for larger version

Name:	2018-04-27_11-43-35.png
Views:	7
Size:	93.8 KB
ID:	4390453

    Leave a comment:


  • Wayne Luke
    replied
    What are the javascript errors in your browser's console? There has to be more than the one in the first post or you're triggering something like NoScript in your browser.

    Leave a comment:


  • steamboats
    replied
    I don't have access to the Apache logs. But we've ruled out mod_security as cause for the issue before by (briefly) deactivating mod_security completely. Also, a clean, fresh installation of vBulletin works without issues; the issue only appears in my working installation which is an upgrade from vb 3.8.11

    Leave a comment:


  • Wayne Luke
    replied
    Do you have access to the Apache Logs? It should tell you what is triggering mod_security.

    Leave a comment:


  • steamboats
    replied
    New default style was the first thing I tried and unfortunately, disableing the hooks doesn't have any effect either.

    Leave a comment:


  • Joe D.
    replied
    Have you tried disabling add-ons by adding this line to your config.php file?

    PHP Code:
    define("DISABLE_HOOKS",true); 

    Have you created a default style by going to Admin CP -> Styles & Templates -> Style Manager -> Add New Style, and create a new style with no parent style, and try that one.

    Leave a comment:


  • steamboats
    replied
    sorry for the many posts - juts an update: I recovered the main install with a backup, so I'm now at the beginning again: editor is gray and I have no idea how to solve this issue ...

    Leave a comment:


  • steamboats
    replied
    I compared all settings, didn't find anything that might cause the issue. exported the setting from the fresh install and imported into the main -- with the result that the forum now is showing a blank page. It's gettign worse and worse. Please, HELP!

    Leave a comment:

Related Topics

Collapse

Working...
X