Announcement

Collapse
No announcement yet.

Error when changing Welcome PM.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error when changing Welcome PM.

    Hey folks!

    I have had a welcome PM forever. I just went into admincp to update it, and when I tried to save, I got the error message.

    Paula

  • #2
    Maybe you've misspelled the variables or something is not wrong with this phrase.
    First remove the translated text and see how it goes.
    Then again do the update or translation

    Comment


    • #3
      Please disable the plugin/hook system completely, using the following instructionsL

      Edit includes/config.php and add the following code:
      Just below
      Code:
      <?php
      enter
      Code:
      define('DISABLE_HOOKS', true);
      Do you still have the same problem?
      MARK.B | vBULLETIN SUPPORT

      TalkNewsUK - My vBulletin 5.4.2 Demo - FEATURING "ROUTE BY NODE"!
      AdminAmmo - My Cloud Demo

      Comment


      • #4
        Thank you both!

        Originally posted by Saeed Fazlollahzadeh View Post
        Maybe you've misspelled the variables or something is not wrong with this phrase.
        First remove the translated text and see how it goes.
        Then again do the update or translation
        This isn't the problem actually. Even when I use the default text, it changes nothing.

        Mark: I edited the config.php by removing the two // in front of
        PHP Code:
        define('DISABLE_HOOKS'true); 
        but that only resulted in more lines (see image).


        Paula

        Comment


        • #5
          Just a note that I found strange. The config.php reads

          PHP Code:
          vBulletin 4.2.2 Patch Level 4 
          I'm using and have upgraded ages ago to 4.2.5!!!
          Paula

          Comment


          • #6
            The config file is not updated in an upgrade.

            What is your php version? If it is php 7.x then you probably have modifications that are incompatible with later versions of php.

            The errors however are simply php warnings, and do not prevent execution of the code. They should not be displayed on a production server, they should only be logged. You should speak to your host about this.
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.4.2 Demo - FEATURING "ROUTE BY NODE"!
            AdminAmmo - My Cloud Demo

            Comment


            • #7
              It is indeed 7X php. Looks like I am going to have to upgrade to VB5. Scary move.
              Paula

              Comment


              • #8
                Originally posted by gsk8 View Post
                It is indeed 7X php. Looks like I am going to have to upgrade to VB5. Scary move.
                No you don't.

                vBulletin 4.2.5 is validated for PHP 7.1.x

                It is not validated for PHP 7.2 though but that shouldn't cause any problems. Most cPanel versions now allow you to select the PHP version for each account.

                However, upgrading to vBulletin 4.2.5 and/or PHP 7.x does require modification of certain add-ons.

                Add this to your config.php file right under <?php

                Code:
                define('SKIP_ALL_ERRORS', true);
                define('SKIP_DS_ERRORS', true);
                If you list your add-ons, I can tell you which ones I know can be modified to work with vBulletin 4.2.5.
                Psychlinks Mental Health Support Forum
                Local Search Forum

                Comment


                • #9
                  Thanks I appreciate that!

                  Added the lines, but got even more "1032"errors

                  PHP Code:
                  <?php
                  define
                  ('DISABLE_HOOKS'true);
                  define('SKIP_ALL_ERRORS'true);
                  define('SKIP_DS_ERRORS'true);
                  Paula

                  Comment


                  • #10
                    What version of PHP are you using? If it is 7.2.X, you will need to downgrade to 7.1.X or you will continue to receive these warnings.
                    Translations provided by Google.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                    vBulletin 5 Documentation - Updated every Friday. Report issues here.
                    vBulletin 5 API - Full / Mobile
                    I am not currently available for vB Messenger Chats.

                    Comment


                    • #11
                      PHP 7.0.24

                      Update: I have reinstalled VB 4.2.5 and do not see the errors anymore.
                      Paula

                      Comment

                      Loading...
                      Working...
                      X