Announcement

Collapse
No announcement yet.

admin must add the domain to the whitelist

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • admin must add the domain to the whitelist

    Today when I try to do anything from within admincp, I get the following message:

    In order to accept POST requests originating from this domain, the admin must add the domain to the whitelist.
    It was working fine when I went home last night but I can't do anything this morning. I didn't change anything. The domain hasn't changed. Our IT department says they didn't do anything. Even if I wanted to adjust the referrer domains in admincp, it won't let me. I get this error trying to do so. I can login to admincp and navigate around, I just can't do anything. We have 3 vBulletin servers on the same Linux box and I'm getting the same thing from all three. I'm dead in the water from the administration point of view until I find out why this happened and what to do to fix it. PLEASE tell me you have some advice for me. Help?

    Thanks in advance. - Kim
    Our forums: http://forums.opensuse.org, http://forums.microfocus.com, http://forums.netiq.com, and http://forums.suse.com

  • #2
    Firstly, things don't change on their own. Something has been altered.

    As things stand you will need to add the domain to the whitelist in the admincp. Since you cannot use the admincp, you need to get round the issue temporarily by adding the following to /includes/config.php. right under the <?php line at the top:

    PHP Code:
    define('SKIP_REFERRER_CHECK'true); 

    Then you should be able to get to:
    Admin CP -> Settings > Options -> General Settings -> Post Referrer Whitelist

    Add the domain in there an save.
    Then remove the line from the config file.
    Last edited by Mark.B; Fri 26th Jan '18, 12:46pm.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.5.2 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      Thanks Mark. Yea, I'm with you. Things don't change without someone changing SOMETHING. I'll add that to the config file and see what happens. I'm *somewhat* befuddled as our domain didn't change. I'll report back what happens.
      Our forums: http://forums.opensuse.org, http://forums.microfocus.com, http://forums.netiq.com, and http://forums.suse.com

      Comment


      • #4
        That worked somewhat. I was able to work in admincp without the error and change the Poste Referrer Whitelist. I added every domain we use there. After I returned the config file to it's original state, I tried it and got the error again. Should I assume that SOMETHING in our domain changed? I read in here somewhere it could have something to do with the cookie domain? I'm *assuming* that it's checking the domain I'm running admincp from in this instance, am I correct or mistaken there? I'll have to follow up with our IT department and see if there was any type of domain change anywhere in our system. If you have any other suggestions or words of wisdom I'll be grateful. Thansk again Mark.
        Our forums: http://forums.opensuse.org, http://forums.microfocus.com, http://forums.netiq.com, and http://forums.suse.com

        Comment


        • #5
          I am having the same issue - the define('SKIP_REFERRER_CHECK', true); did not do the trick for me and look forward to any updates to this thread.



          I'm moving my forum to a new hosting provider and changing the domain name at the same time.

          The error (In order to accept POST requests originating from this domain, the admin must add the domain to the whitelist.) started to show after I changed details to the new domain under Settings - Options - Site Name / URL / Contact details

          ... and the tip above did not work for me. When I login to the site now, it keeps kicking me back to the old domain... Is there someplace else the information much be changed? would it help to re-upload the /install/tools and try something in there?

          Thanks in advance for any help!!

          IntroToCryptos


          Click image for larger version

Name:	vbulletin-options-sitename.jpg
Views:	32
Size:	34.6 KB
ID:	4396782

          Comment


          • #6
            Originally posted by introtocryptos View Post
            I am having the same issue - the define('SKIP_REFERRER_CHECK', true); did not do the trick for me and look forward to any updates to this thread.



            I'm moving my forum to a new hosting provider and changing the domain name at the same time.

            The error (In order to accept POST requests originating from this domain, the admin must add the domain to the whitelist.) started to show after I changed details to the new domain under Settings - Options - Site Name / URL / Contact details

            ... and the tip above did not work for me. When I login to the site now, it keeps kicking me back to the old domain... Is there someplace else the information much be changed? would it help to re-upload the /install/tools and try something in there?

            Thanks in advance for any help!!

            IntroToCryptos


            Click image for larger version

Name:	vbulletin-options-sitename.jpg
Views:	32
Size:	34.6 KB
ID:	4396782
            That screenshot looks like vBulletin 5 - this thread is about vBulletin 4.

            If you can please start a new thread in the vBulletin 5 support section we will try to assist.

            Please provide full details of the issue including any error messages.
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.5.2 Demo
            AdminAmmo - My Cloud Demo

            Comment

            Related Topics

            Collapse

            Working...
            X