Announcement

Collapse
No announcement yet.

localhost vB4 problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • localhost vB4 problem

    I set up a localhost on my laptop to run an off-line version of my vB4 forum. I closed my real forum, backed up the database and copied the forums folder structure to my laptop MAMP setup, then got my database onto my local MySQL server. Everything looked good but it's not. I made all of the proper changes to my config.php file pointing to the local server and file structure and entered the local SQL user and password, so I think that's OK.

    But when I attempt to access the forum with my browser I get no errors, but a completely white (empty) web page. What's odd is if I go to open the admin area, I do get the vB Admin login screen but once I login with my password (which works), again, I get a white empty page.

    Anyone ever see this or know what I am doing wrong?

    Thanks

  • #2
    White pages indicate a PHP Error. You will need to look in your PHP Error Log. However, if I had to take a guess, you probably don't have the iconv library installed in PHP.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    Vote for your most annoying bugs.
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      Thanks Wayne. (I am trying to figure out if I have the iconv library installed or not)

      Here are the PHP error log entries from attempting to open the forum:

      vB_Database has a deprecated constructor in C:\MAMP\htdocs\forums\includes\class_core.php on line 83
      [16-Jan-2018 23:33:32 UTC] PHP Deprecated: vB_Datastore has a deprecated constructor in C:\MAMP\htdocs\forums\includes\class_core.php on line 1479
      [16-Jan-2018 23:33:32 UTC] PHP Deprecated: vB_Input_Cleaner has a deprecated constructor in C:\MAMP\htdocs\forums\includes\class_core.php on line 1820
      [16-Jan-2018 23:33:32 UTC] PHP Deprecated: vB_Registry has a deprecated constructor in C:\MAMP\htdocs\forums\includes\class_core.php on line 3139
      [16-Jan-2018 23:33:32 UTC] PHP Deprecated: vB_Session has a deprecated constructor in C:\MAMP\htdocs\forums\includes\class_core.php on line 3541
      [16-Jan-2018 23:33:32 UTC] PHP Deprecated: vBulletinHook has a deprecated constructor in C:\MAMP\htdocs\forums\includes\class_hook.php on line 27
      [16-Jan-2018 23:33:32 UTC] PHP Fatal error: Redefinition of parameter $line in C:\MAMP\htdocs\forums\vb\exception\parser.php on line 25

      Comment


      • #4
        Please make sure you're using vBulletin 4.2.5 on your local machine.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        Vote for your most annoying bugs.
        I am not currently available for vB Messenger Chats.

        Comment


        • #5
          OK, that's a good place to start. It's 4.2.3. I will upgrade it and be back after I try it again. Thanks Wayne

          Comment


          • #6
            4.2.3 doesn't work with PHP 5.6 or higher. vBulletin 4.2.5 works with PHP 5.6.X and PHP 7.1.X.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud customization and demonstration site.
            vBulletin 5 Documentation - Updated every Friday. Report issues here.
            vBulletin 5 API - Full / Mobile
            Vote for your most annoying bugs.
            I am not currently available for vB Messenger Chats.

            Comment


            • #7
              Originally posted by JonUrban View Post
              Thanks Wayne. (I am trying to figure out if I have the iconv library installed or not)

              Here are the PHP error log entries from attempting to open the forum:

              vB_Database has a deprecated constructor in C:\MAMP\htdocs\forums\includes\class_core.php on line 83
              [16-Jan-2018 23:33:32 UTC] PHP Deprecated: vB_Datastore has a deprecated constructor in C:\MAMP\htdocs\forums\includes\class_core.php on line 1479
              [16-Jan-2018 23:33:32 UTC] PHP Deprecated: vB_Input_Cleaner has a deprecated constructor in C:\MAMP\htdocs\forums\includes\class_core.php on line 1820
              [16-Jan-2018 23:33:32 UTC] PHP Deprecated: vB_Registry has a deprecated constructor in C:\MAMP\htdocs\forums\includes\class_core.php on line 3139
              [16-Jan-2018 23:33:32 UTC] PHP Deprecated: vB_Session has a deprecated constructor in C:\MAMP\htdocs\forums\includes\class_core.php on line 3541
              [16-Jan-2018 23:33:32 UTC] PHP Deprecated: vBulletinHook has a deprecated constructor in C:\MAMP\htdocs\forums\includes\class_hook.php on line 27
              [16-Jan-2018 23:33:32 UTC] PHP Fatal error: Redefinition of parameter $line in C:\MAMP\htdocs\forums\vb\exception\parser.php on line 25
              Those are all PHP 7 errors, so you must use 4.2.5
              This is my signature.

              Comment


              • #8
                Other option is to install PHP version 5.3.x. (Presumably an older version of MAMP) if you want to more closely match your live version.

                Comment


                • #9
                  Thanks everyone.

                  Comment

                  Working...
                  X