Announcement

Collapse
No announcement yet.

Trying to upgrade to 4.2.5 and getting unexpected text error processing blog, step 18 of 20

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trying to upgrade to 4.2.5 and getting unexpected text error processing blog, step 18 of 20


    Unexpected Text:
    <?xml version="1.0" encoding="windows-1252"?> <br /> <b>Warning</b>: mysqli_query(): (42000/1064): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' ) ) WHERE ipid IS NULL' at line 6 in <b>/public_html/forum/includes/class_core.php</b> on line <b>1386</b><br /> <?xml version="1.0" encoding="windows-1252"?> <errors> <error><![CDATA[<p>Database Error</p> Invalid SQL: SELECT bt.userid, bt.dateline, blogtextid, ipaddress, firstblogtextid FROM blog_text bt JOIN blog bl USING (blogid) LEFT JOIN ipdata ip ON ( bt.ipaddress = ip.ipid AND bt.blogtextid = ip.contentid AND bt.userid = ip.userid AND ip.contenttypeid IN (, ) ) WHERE ipid IS NULL; You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' ) ) WHERE ipid IS NULL' at line 6]]></error> <error_html><![CDATA[<p>Database error in vBulletin 4.2.5</p> <p>Invalid SQL: SELECT bt.userid, bt.dateline, blogtextid, ipaddress, firstblogtextid FROM blog_text bt JOIN blog bl USING (blogid) LEFT JOIN ipdata ip ON ( bt.ipaddress = ip.ipid AND bt.blogtextid = ip.contentid AND bt.userid = ip.userid AND ip.contenttypeid IN (, ) ) WHERE ipid IS NULL;<p> <p> <strong>MySQL Error</strong> : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' ) ) WHERE ipid IS NULL' at line 6<br /> <strong>Error Number</strong> : 1064<br /> <strong>Request Date</strong> : Saturday, October 7th 2017 @ 01:52:22 PM<br /> <strong>Error Date</strong> : Saturday, October 7th 2017 @ 01:52:22 PM<br /> <strong>Script</strong> : http://domain/forum/install/upgrade.php<br /> <strong>Referrer</strong> : http://domain/forums/install/upgrade.php<br /> <strong>Classname</strong> : vB_Database_MySQLi<br /> <strong>MySQL Version</strong> : 5.5.51-38.2<br /> </p>]]></error_html> </errors>

    I was instructed to enable blog in admin panel but my whole forum is no longer accessible since starting the update. Any help in simple terms much appreciated.

  • #2
    Anyway to start upgrade over at step one? I would prefer just to upgrade the forum only without the blogs.

    Comment


    • #3
      You need to log into the admincp and enable the blogs and CMS products, then re-run the upgrade, it will carry on where it left off.

      To do this you will need to temporarily rename the /install folder, while you access the admincp, then rename it back.

      The only way to start the upgrade from step one is to restore the original database from backup.
      MARK.B | vBULLETIN SUPPORT

      TalkNewsUK - My vBulletin 5.4.2 Demo - FEATURING "ROUTE BY NODE"!
      AdminAmmo - My Cloud Demo

      Comment


      • #4
        Originally posted by ilovekittens View Post
        Anyway to start upgrade over at step one? I would prefer just to upgrade the forum only without the blogs.
        Unless you have the forum only version of vb4 installed you cannot do that, it will always run the blog and cms upgrade steps.
        This is my signature.

        Comment

        Loading...
        Working...
        X