Announcement

Collapse
No announcement yet.

Errors - Please help.. Upgraded to 4.2.5 plus PHP 7.2 and Apache 2.4

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Errors - Please help.. Upgraded to 4.2.5 plus PHP 7.2 and Apache 2.4

    Everything seems to be running ok, but error log is filling up with stuff like this, Please help.

    [05-Oct-2017 21:57:41 America/Chicago] PHP Warning: Use of undefined constant MYSQL_NUM - assumed 'MYSQL_NUM' (this will throw an Error in a future version of PHP)
    [05-Oct-2017 21:57:41 America/Chicago] PHP Warning: Use of undefined constant MYSQL_ASSOC - assumed 'MYSQL_ASSOC' (this will throw an Error in a future version of PHP)
    [05-Oct-2017 21:57:41 America/Chicago] PHP Warning: Use of undefined constant MYSQL_BOTH - assumed 'MYSQL_BOTH' (this will throw an Error in a future version of PHP)
    [05-Oct-2017 21:57:41 America/Chicago] PHP Warning: Use of undefined constant STYLEID - assumed 'STYLEID' (this will throw an Error in a future version of PHP)
    [05-Oct-2017 21:57:41 America/Chicago] PHP Warning: Use of undefined constant day - assumed 'day' (this will throw an Error in a future version of PHP)

    Plus tons more just like those.
    High Voltage Computer Repair Service, Edwardsville, IL
    GoHighVoltage Computer Repair Forum

  • #2
    vBulletin 4 does not support php 7.2.

    You will need to downgrade php to 7.1.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.4.2 Demo - FEATURING "ROUTE BY NODE"!
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      Thank you Mark! You rock! Appreciate you!
      High Voltage Computer Repair Service, Edwardsville, IL
      GoHighVoltage Computer Repair Forum

      Comment


      • #4
        PHP 7.2 isnt even released yet, its still in RC.
        This is my signature.

        Comment


        • #5
          Will vBulletin v4.2.5 be patched to support PHP7.2 once it's out of RC stage?

          Comment


          • #6
            Originally posted by mark99 View Post
            Will vBulletin v4.2.5 be patched to support PHP7.2 once it's out of RC stage?
            There are no plans to do so at the moment. Development on vB4 has now ceased.
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.4.2 Demo - FEATURING "ROUTE BY NODE"!
            AdminAmmo - My Cloud Demo

            Comment


            • #7
              Wouldn't support for PHP7.2 kind of fall under the category of being a security fix? Since to be sure we must use the latest versions available. Disappointed that vB4 is being sent to the death bed, a lot of sites still use it.

              Comment


              • #8
                Originally posted by mark99 View Post
                Wouldn't support for PHP7.2 kind of fall under the category of being a security fix? Since to be sure we must use the latest versions available. Disappointed that vB4 is being sent to the death bed, a lot of sites still use it.
                That's a bit of a stretch to be honest. php 5.6 is still perfectly secure, as are php 7.0 and 7.1.

                There are no plans at the moment, however I can remember a time when there were no plans to update vB4 to php 5.4, so never say never.
                MARK.B | vBULLETIN SUPPORT

                TalkNewsUK - My vBulletin 5.4.2 Demo - FEATURING "ROUTE BY NODE"!
                AdminAmmo - My Cloud Demo

                Comment


                • #9
                  Originally posted by mark99 View Post
                  Wouldn't support for PHP7.2 kind of fall under the category of being a security fix?
                  No it wouldnt, PHP 7.0 & 7.1 are fully supported by PHP for many years yet.

                  Originally posted by Mark.B View Post
                  There are no plans at the moment, however I can remember a time when there were no plans to update vB4 to php 5.4, so never say never.
                  The difference being that the person who made that happen for php 5.4, 5.5, 5.6, 7.0 & 7.1 no longer works at IB.
                  IB management have made it clear they want to kill off vB4 support, hence the removal of all the pages from the main marketing site the other week.

                  This is my signature.

                  Comment


                  • #10
                    Originally posted by stingray27 View Post
                    No it wouldnt, PHP 7.0 & 7.1 are fully supported by PHP for many years yet.


                    The difference being that the person who made that happen for php 5.4, 5.5, 5.6, 7.0 & 7.1 no longer works at IB.
                    IB management have made it clear they want to kill off vB4 support, hence the removal of all the pages from the main marketing site the other week.
                    Not promoting a now old product is not the same as ending support.

                    Whilst at the moment there are no plans for further vB4 releases, should that change we have developers who would be able to work on it.
                    MARK.B | vBULLETIN SUPPORT

                    TalkNewsUK - My vBulletin 5.4.2 Demo - FEATURING "ROUTE BY NODE"!
                    AdminAmmo - My Cloud Demo

                    Comment

                    Related Topics

                    Collapse

                    Working...
                    X