Announcement

Collapse
No announcement yet.

vBulletin 4.2.5

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • vBulletin 4.2.5

    vBulletin 4.2.5 Alpha 1 has been released today.

    This is primarily being updated for compatability with php 7.x.x

    While the code has been lightly tested, please bear in mind that its an alpha, and may have issues.

    Please feel free to use it and log any problems in Jira (http://tracker.vbulletin.com/secure/...jspa?pid=10020).
    Note however that only bugs related to the changes made are likely to be looked at.

    You can also discuss the release in this thread.

    ---------------
    The final release of 4.2.5 has been made. https://www.vbulletin.com/forum/foru...99#post4369799

    Please note: You are required to install the mbstring library in PHP to use vBulletin 4.2.5.
    Last edited by Wayne Luke; Mon 10th Jul '17, 9:13am.
    Baby, I was born this way

  • #2
    Very cool, thank you Paul.

    Comment


    • #3
      Thanks Paul!

      When can we have a stable vb4 version for compatability with php 7.x.x?
      Web Hosting Forum - Learn web hosting and offering your web hosting plans for free!

      Comment


      • #4
        Originally posted by Mattwhf View Post
        Thanks Paul!

        When can we have a stable vb4 version for compatability with php 7.x.x?
        We do not have release dates.

        Once it goes from Alpha to Beta it should be ok to use on production sites, though again we have no release dates.
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.4.4 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #5
          Originally posted by Mattwhf View Post
          Thanks Paul!

          When can we have a stable vb4 version for compatability with php 7.x.x?
          When its ready.

          People need to actually download and use it, and report back any issues.
          We have already ironed out everything we could find, but there is always likely to be something we missed.

          This should happily run on php 5.5 & 5.6 as well.
          Baby, I was born this way

          Comment


          • #6
            Originally posted by Paul M View Post

            When its ready.

            People need to actually download and use it, and report back any issues.
            We have already ironed out everything we could find, but there is always likely to be something we missed.

            This should happily run on php 5.5 & 5.6 as well.
            Trying, but failing on skimlinks step

            Code:
            Unexpected Text:
            <?xml version="1.0" encoding="windows-1252"?>
              syntax error, unexpected ';' on line 1 in /home/mydomain/public_html/includes/class_core.php(5559) : eval()'d code<br />
            #0 /home/mydomain/public_html/includes/class_core.php(4681) : eval()'d code(707): vB_Template_Runtime::runMaths('-10-')<br />
            #1 /home/mydomain/public_html/includes/class_core.php(4681): eval()<br />
            #2 /home/mydomain/public_html/includes/class_core.php(4653): vB_Template->render_output(true)<br />
            #3 /home/mydomain/public_html/includes/adminfunctions_template.php(903): vB_Template->render(true)<br />
            #4 /home/mydomain/public_html/includes/adminfunctions_template.php(1332): write_style_css_directory('2', '2,-1', 'ltr')<br />
            #5 /home/mydomain/public_html/includes/adminfunctions_template.php(1384): build_style('2', 'VBulletin', Array, '2,-1', '\t', false)<br />
            #6 /home/mydomain/public_html/includes/adminfunctions_template.php(620): build_style(-1, 'MASTER STYLE', Array, '', '', false)<br />
            #7 /home/mydomain/public_html/includes/class_upgrade_product.php(1153): build_all_styles(0, 0, '', false, 'standard')<br />
            #8 /home/mydomain/public_html/install/includes/class_upgrade_skimlinks.php(170): vB_Upgrade_Product->post_install()<br />
            #9 /home/mydomain/public_html/install/includes/class_upgrade.php(1770): vB_Upgrade_skimlinks->step_3(Array)<br />
            #10 /home/mydomain/public_html/install/includes/class_upgrade_ajax.php(616): vB_Upgrade_Version->execute_step(3, 1, Array)<br />
            #11 /home/mydomain/public_html/install/includes/class_upgrade_ajax.php(405): vB_Upgrade_Ajax->execute_step(3, 0, Object(vB_Upgrade_skimlinks), Object(vB_AJAX_XML_Builder), 1, NULL, 0, Array, Array)<br />
            #12 /home/mydomain/public_html/install/includes/class_upgrade_ajax.php(151): vB_Upgrade_Ajax->process_step('skimlinks', 3, 0, 1, NULL, 0, false, 0, Array, Array)<br />
            #13 /home/mydomain/public_html/install/includes/class_upgrade.php(373): vB_Upgrade_Ajax->init(Object(vB_Upgrade_skimlinks))<br />
            #14 /home/mydomain/public_html/install/includes/class_upgrade_ajax.php(80): vB_Upgrade_Abstract->__construct(Object(vB_Registry), Array, 'upgrade')<br />
            #15 /home/mydomain/public_html/install/includes/class_upgrade.php(49): vB_Upgrade_Ajax->__construct(Object(vB_Registry), Array, 'upgrade', NULL)<br />
            #16 /home/mydomain/public_html/install/upgrade.php(53): vB_Upgrade::fetch_library(Object(vB_Registry), Array, '', true)<br />
            #17 {main}<br /><br /><br />
            <b>Fatal error</b>:  syntax error, unexpected ';' on line 1 in /home/mydomain/public_html/includes/class_core.php(5559) : eval()'d code
             in <b>/home/mydomain/public_html/vb/vb.php</b> on line <b>286</b><br />

            Comment


            • #7
              Nevermind. Fixed.

              Had CSS set to store as files...
              Last edited by kane@airrifle; Tue 9th Aug '16, 7:42am.

              Comment


              • #8
                On forums with thread prefixes enabled.

                Code:
                PHP Warning: Invalid argument supplied for foreach() in ..../includes/functions_prefix.php on line 131
                On editing a prefixed thread from the admin menu. This happens on some but not all prefixed threads.

                Code:
                #1 : vbstop() called in ..../includes/class_core.php on line 5740
                #2 : us_get_value() called in ..../includes/class_core.php on line 5695
                #3 : vb_unserialize() called in ..../postings.php on line 1319
                Invalid unserialize type: W at position 0

                Comment


                • #9
                  Profiles in Admin CP.

                  Code:
                  #1 : vbstop() called in ..../includes/class_core.php on line 5795
                  #2 : us_get_null() called in ..../includes/class_core.php on line 5737
                  #3 : us_get_value() called in ..../includes/class_core.php on line 5695
                  #4 : vb_unserialize() called in ..../includes/adminfunctions_profilefield.php on line 136
                  #5 : print_profilefield_row() called in ..../admincp/user.php on line 777
                  
                  Expected ; at position 1found o

                  Comment


                  • #10
                    online.php

                    Bug
                    #1 : vbstop() called in ..../includes/class_core.php on line 5740 #2 : us_get_value() called in ..../includes/class_core.php on line 5695 #3 : vb_unserialize() called in ..../includes/functions_online.php on line 2453 #4 : convert_ids_to_titles() called in ..../online.php on line 716 #5 : require(..../online.php) called in ..../dbseo.php on line 498
                    Invalid unserialize type: O at position 0
                    Dutch Online Computer hulp - www.pctuts.be

                    Comment


                    • #11
                      The first error doesnt seem related to any changes made for 3.8.11, but I put a workaround fix in place anyway.

                      The second error is related to moderator logs, which is probably why it only happens on some threads, still looking at that.

                      That error wont actually occur in the final version, the alpha is set to report any strange issues with the unserialize emulator.
                      This will be turned off at some point so it just behaves like php's unserialize, and simply returns false on anything it cannot unserialize.

                      The other (third) error would also not happen for the same reason, but is a poor bit of (ancient) programming, so I fixed it anyway.
                      Baby, I was born this way

                      Comment


                      • #12
                        Originally posted by bollie View Post
                        online.php

                        Bug
                        #1 : vbstop() called in ..../includes/class_core.php on line 5740 #2 : us_get_value() called in ..../includes/class_core.php on line 5695 #3 : vb_unserialize() called in ..../includes/functions_online.php on line 2453 #4 : convert_ids_to_titles() called in ..../online.php on line 716 #5 : require(..../online.php) called in ..../dbseo.php on line 498
                        Invalid unserialize type: O at position 0
                        dbseo.php is not a vbulletin file, but I believe I see what's up there anyway, please log this properly. Thanks.


                        Please log bugs in JIRA (Tracker), not in this thread.
                        Baby, I was born this way

                        Comment


                        • #13
                          Alpha 2 should be available at the end of this week.
                          Baby, I was born this way

                          Comment


                          • #14
                            Originally posted by Paul M View Post
                            Alpha 2 should be available at the end of this week.
                            I haven't seen this bug brought up but:

                            PHP Code:
                            Call to undefined function split() on line 172 in /var/www/vhosts/DOMAIN/httpdocs/forums/forum.php(791) : eval()'d code
                            #0 /var/www/vhosts/DOMAIN/httpdocs/forums/forum.php(791): eval()
                            #1 {main} 
                            I will log it with Jira.

                            Comment


                            • #15
                              split()
                              This error is one of the plugins installed on your forum.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X