Announcement

Collapse
No announcement yet.

Blank page when try to edit post

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    That database error is worrisome. If you get it with hooks disabled there is likely one or more xml files in your /includes/xml/ folder that were from old mods you uninstalled but never deleted the files. You must delete the files from any mods you uninstalled, uninstalling from the AdmiNCP is not enough.

    Comment


    • #17
      Database error posted in post above is fixed... one mod cause that and now i have no database errors... all files are deleted ... i have now only problem with editing posts what are made with copy-paste. I sent you PM and You can see yourself what i mean.

      regards

      bosss
      Welcome to Libar

      Comment


      • #18
        Hi, I have the same problem.
        bosss, have you managed to fix it?

        Comment


        • #19
          Originally posted by applemaniacos View Post
          Hi, I have the same problem.
          bosss, have you managed to fix it?
          No!
          Welcome to Libar

          Comment


          • #20
            What is the collation on the database and database tables? What is the charset for your language file in AdminCP > Languages and Phrases > Language Manager?
            Vote for:

            - *Admin Settable Paid Subscription Reminder Timeframe*
            -
            *PM - Add ability to reply to originator only*
            - Add Admin ability to auto-subscribe users to specific channel(s)
            - Highlight the correct navigation tab when you are on a custom page
            - "Quick Route" Interface...
            - Allow to use custom icons for individual forums

            Comment


            • #21
              HTML Character Set - ISO-8859-1

              still same problems - and now use vb 4.2.5 - php - 7.1 and
              MySQL Version 10.1.31-MariaDB-cll-lve
              Welcome to Libar

              Comment


              • #22
                Unless you're using English and no mobile devices, you don't want to use character set ISO-8859-1. You want this to be set to UTF-8 in order to support Mobile Devices and any language other than English.

                Don't really recommend MariaDB. It is just a Fork of MySQL without all the features and optimizations. You should upgrade to the latest version for best performance and capabilities. At least then you can use INNODB tables like we recommend.
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                vBulletin 5 Documentation - Updated every Friday. Report issues here.
                vBulletin 5 API - Full / Mobile
                I am not currently available for vB Messenger Chats.

                Comment


                • #23
                  Thanks for answer.
                  You mean that i need change ISO-8859-1 to UTF-8 in my admincp - > Languages and Phrases > Language Manager. It was ISO-8859-1 whan i install vbulletin...time ago ...and i use most english and Kroatian (only in posts).

                  regards

                  bosss
                  Welcome to Libar

                  Comment


                  • #24
                    Yes... A long time ago, we weren't trying to use language properly. When vBulletin 4 was first released (almost a decade ago), Smartphones were just getting started and Tablets were a potential money maker that no one had cracked yet except in niche markets.
                    Translations provided by Google.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                    vBulletin 5 Documentation - Updated every Friday. Report issues here.
                    vBulletin 5 API - Full / Mobile
                    I am not currently available for vB Messenger Chats.

                    Comment


                    • #25
                      Thanks ..will try to change to UTF-8 and maybe that fix problem.

                      regards

                      bosss
                      Last edited by bosss; Tue 10th Jul '18, 10:59am.
                      Welcome to Libar

                      Comment


                      • #26
                        Made changes but still same problem... edit post = empty.


                        regards

                        bosss
                        Welcome to Libar

                        Comment


                        • #27
                          I've seen that problem where HTML is allowed in a forum. Can you check if that is the case? It seems to allow extra formatting characters to be posted that can't be interpreted, as well as references to CSS classes that don't exist.

                          The problem only occurs where someone is copy-pasting content from another site. It sometimes breaks the CSS for the forum as well, but either way the post cannot be edited.
                          Psychlinks Mental Health Support Forum
                          Local Search Forum

                          Comment


                          • #28
                            Allow Html is set to NO in my admincp, and Yes you have right -
                            The problem only occurs where someone is copy-pasting content from another site. It sometimes breaks the CSS for the forum as well, but either way the post cannot be edited.
                            When try edit post - post is empty...

                            regards

                            bosss
                            Welcome to Libar

                            Comment


                            • #29
                              The problem with copying and pasting content (effectively html) from other sites is that the editor isn't actually built to do that. It will make a best effort at converting stuff but it will often fail.

                              WYSIWYG is designed so that you can compose a post and see how how it going to look 'on the fly'. It isn't intended for copying entire blocks of third party html. Depending on what's being copied, it may work or it may not, and as you've noted can break the css as well in extreme cases.
                              MARK.B | vBULLETIN SUPPORT

                              TalkNewsUK - My vBulletin 5.4.2 Demo - FEATURING "ROUTE BY NODE"!
                              AdminAmmo - My Cloud Demo

                              Comment


                              • #30
                                Originally posted by Mark.B View Post
                                The problem with copying and pasting content (effectively html) from other sites is that the editor isn't actually built to do that. It will make a best effort at converting stuff but it will often fail.

                                WYSIWYG is designed so that you can compose a post and see how how it going to look 'on the fly'. It isn't intended for copying entire blocks of third party html. Depending on what's being copied, it may work or it may not, and as you've noted can break the css as well in extreme cases.
                                Thanks for answer!
                                Problem is only when i copy croatian or swidish letters - englis no problem.

                                regards

                                bosss
                                Welcome to Libar

                                Comment

                                Working...
                                X