Announcement

Collapse
No announcement yet.

Settings errer

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Settings errer

    Errer how come it's admincp will be fine

    Warning: Invalid argument supplied for foreach() in [path]/admincp/css.php on line 451

    Warning: trim() expects parameter 1 to be string, array given in [path]/includes/adminfunctions_options.php on line 1032

    Warning: trim() expects parameter 1 to be string, array given in [path]/includes/adminfunctions_options.php on line 1032

  • #2
    To troubleshoot this, first download a fresh copy of the vBulletin ZIP file from the Members Area then reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php:

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

    Do you have the same problem?
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - Highlight the correct navigation tab when you are on a custom page
    - "Quick Route" Interface...
    - Allow to use custom icons for individual forums

    Comment


    • #3
      same problem

      i am install new vBulletin ZIP file,disable the plugin system,and i am delete all styles. this time use only Default Style,bit i have same problem. what can i do?

      Click image for larger version

Name:	Captura de pantalla_2012-06-11_172051.png
Views:	1
Size:	71.5 KB
ID:	3687487
      Click image for larger version

Name:	Captura de pantalla_2012-06-11_172742.png
Views:	1
Size:	31.8 KB
ID:	3687488
      Click image for larger version

Name:	Captura de pantalla_2012-06-11_173037.png
Views:	2
Size:	13.6 KB
ID:	3687489
      Click image for larger version

Name:	Captura de pantalla_2012-06-11_173211.png
Views:	2
Size:	22.3 KB
ID:	3687490

      Comment


      • #4
        Originally posted by Yuvraj121 View Post
        i am install new vBulletin ZIP file,disable the plugin system,and i am delete all styles. this time use only Default Style,bit i have same problem. what can i do?

        [ATTACH=CONFIG]59951[/ATTACH]
        [ATTACH=CONFIG]59952[/ATTACH]
        Originally posted by Trevor Hannant View Post
        Next, disable all plugins.Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php:

        define('DISABLE_HOOKS', true);
        You did follow this step correct? Sorry I cannot see that info in the screenshot, assuming you did but please let us know .


        Former vBulletin Support Staff
        Hacked recently? See my blog post "Recovering a Hacked vBulletin Site".
        Thinking outside the box? Need modification support? Visit www.vBulletin.org and have at it!
        Need a Host? - I recommend URLJet

        Comment


        • #5
          yes i am follow this steps correctly. but still have same problems.i send you screenshoot and show you erorrs




          Click image for larger version

Name:	Captura de pantalla_2012-06-11_173037.png
Views:	2
Size:	13.6 KB
ID:	3687491Click image for larger version

Name:	Captura de pantalla_2012-06-11_173211.png
Views:	2
Size:	22.3 KB
ID:	3687492

          Comment


          • #6
            What is this setting:

            Admin CP -> Settings -> Options -> Style & Language Settings -> Store CSS Stylesheets as Files?

            Comment


            • #7
              Admin CP -> Settings -> Options -> Show All Settings when i am save anytnink then it message comes

              Comment


              • #8
                Originally posted by Yuvraj121 View Post
                Admin CP -> Settings -> Options -> Show All Settings when i am save anytnink then it message comes
                After Options you need to double click the Style & Language Settings.

                Comment


                • #9
                  What to do now

                  Comment


                  • #10
                    Try editing each setting group individually instead of using All Settings. If you get the error message again, make note of which setting group you were editing when it happened so we can narrow it down.

                    Comment


                    • #11
                      Originally posted by Yuvraj121 View Post
                      What to do now
                      How are you have this setting? Store CSS Stylesheets as Files. Is is set to Yes or No?

                      Comment


                      • #12
                        when i am save any think in Setting Group, then i receive this message

                        Attached Files
                        Last edited by Yuvraj121; Mon 11th Jun '12, 11:04am.

                        Comment


                        • #13
                          That setting group is from a third-party modification. I'm not sure what modification it is from, but you'll need to make sure that it is up-to-date and working for your version of vBulletin or disable or uninstall it.

                          Comment


                          • #14
                            errer has recovered thanks,to make it right


                            Warning: Invalid argument supplied for foreach() in [path]/admincp/css.php on line 451




                            Click image for larger version

Name:	Captura de pantalla_2012-06-11_223711.png
Views:	1
Size:	52.2 KB
ID:	3687496 Click image for larger version

Name:	Captura de pantalla_2012-06-11_223743.png
Views:	1
Size:	18.7 KB
ID:	3687497
                            Last edited by Yuvraj121; Mon 11th Jun '12, 12:43pm.

                            Comment


                            • #15
                              Disable your plugins from the config as Trevor said and keep them like that, test your admin pages and if you do not found errors that means you'll need to make sure that your plugins are up-to-date and working for your version of vBulletin or disable/uninstall as Matthew said
                              Please feel free to contact me if you have any questions or concerns

                              Links: vBulletin Manual - Code Documentation - FAQ - Bug Tracker - Lemon Juice
                              vBulletin 5 Connect: Extensions - Articles - Features - Purchases

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X