Announcement

Collapse
No announcement yet.

Home is now .com/content.php instead of just .com

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] Home is now .com/content.php instead of just .com

    After upgrading to 4.2 I've reset the default tab to the CMS of my site, which works fine, except now the default "home" URL of my website ends in .com/content.php instead of the more simplistic and preferable .com.

    Is there any way to correct this? May sound silly to most, but I am a bit of a perfectionist and it just looks uglier now. I realise that the default CMS page is content.php, but before vBulletin hid it and now it doesn't.

    Additionally, is the {session.sessionurl_q} following the content.php in the target URL for the CMS necessary (listed in the Navigation Manager)? Occasionally a trailing string of numbers accompanies the URL which is even uglier. I've set it to just content.php instead of content.php{session.sessionurl_q}for the meantime, but have no idea what relevance it has with the workings of vBulletin. If someone can enlighten me I'd be most appreciative

  • #2
    You'd need to edit your index.php. Change:
    PHP Code:
    define('VB_REDIRECT'true); 
    to
    PHP Code:
    // define('VB_REDIRECT', true); 
    Change:
    PHP Code:
    require('forum.php'); 
    to
    PHP Code:
    require('content.php'); 
    The session URL is necessary to stay logged in if the user has cookies disabled. It shouldn't appear unless it is necessary.

    Comment


    • #3
      There is a few posts about not editing the index.php anymore, but on my test forum I was also unable to find a way to render the domain without www.domain.com/content/

      Only with the index.php edits it worked, I have the original file on live, but the CMS (as main page) is .pt/content/

      Comment


      • #4
        Originally posted by Gumble View Post
        There is a few posts about not editing the index.php anymore, but on my test forum I was also unable to find a way to render the domain without www.domain.com/content/

        Only with the index.php edits it worked, I have the original file on live, but the CMS (as main page) is .pt/content/
        This is because if you edit index.php and decide to use a different script as your default in the future, the redirect won't happen properly. As such, we have to recommend against editing it because it breaks a little bit of the Navigation Manager.

        Ultimately though, you have to decide what is best for your installation.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        I am not currently available for vB Messenger Chats.

        Comment


        • #5
          Originally posted by Gumble View Post
          There is a few posts about not editing the index.php anymore, but on my test forum I was also unable to find a way to render the domain without www.domain.com/content/
          Yeah, as Wayne said, it breaks the Navigation Manager's "default tab" setting. It is also the only way for it to not redirect you to content.php or forum.php (or anythingelse.php) if that bothers you at all.

          Comment


          • #6
            Gotcha, thanks for clarify this issue, for a while I was thinking was just me missing some proper setting and find ou a lot keep suggesting the index edits, and when I seen Matthew pointing it I got confused

            Comment


            • #7
              Have to confess I edited mine as per the "old" way. I am a traditionalist, and I wanted the default URL to be the forumhome, and I wanted the forumhome to be index.php not forum.php.

              I also have a modification on forumhome that ceased to work under the new setup, I didn't bother investigating why that was.
              MARK.B | vBULLETIN SUPPORT

              TalkNewsUK - My vBulletin 5.5.2 Demo
              AdminAmmo - My Cloud Demo

              Comment


              • #8
                Please i want www.naijafinder.com/content.php to be removed. I want my cms page to just be www.naijafinder.com

                Please how do i go about it. I notice search Engine do not like redirect of index page to another page..e.g Redirected to: http://www.naijafinder.com/content.php
                Please i want it to be www.naijafinder.com

                Your feedback will be welcomed
                money making ideas forum | Business Startup| Marketing Ideas

                Comment


                • #9
                  Originally posted by felixkomo View Post
                  Please i want www.naijafinder.com/content.php to be removed. I want my cms page to just be www.naijafinder.com

                  Please how do i go about it. I notice search Engine do not like redirect of index page to another page..e.g Redirected to: http://www.naijafinder.com/content.php
                  Please i want it to be www.naijafinder.com

                  Your feedback will be welcomed
                  Follow the instructions provided by Matthew in post #2 - https://www.vbulletin.com/forum/show...=1#post2300210
                  • Edit the file and make the changes listed, save.
                  • Re-Upload to your server, overwrite the old file.


                  *Please note - https://www.vbulletin.com/forum/show...=1#post2300271


                  Former vBulletin Support Staff
                  Hacked recently? See my blog post "Recovering a Hacked vBulletin Site".
                  Thinking outside the box? Need modification support? Visit www.vBulletin.org and have at it!
                  Need a Host? - I recommend URLJet

                  Comment


                  • #10
                    Can I start a discussion on whether or not this is a bug?

                    In my opinion, the homepage should always just be .com for SEO purposes.

                    It didn't take me long to find this thread, but I feel that I shouldn't have even had to look for it and the default in navigation should just function at .com level without anything after it.

                    I should only be searching for this thread if I want the homepage to redirect to .com/content.php etc.
                    http://www.bordersdown.net - 10 years of videogame reviews and chat

                    Comment


                    • #11
                      Originally posted by Matthew Gordon View Post
                      You'd need to edit your index.php. Change:
                      PHP Code:
                      define('VB_REDIRECT'true); 
                      to
                      PHP Code:
                      // define('VB_REDIRECT', true); 
                      Change:
                      PHP Code:
                      require('forum.php'); 
                      to
                      PHP Code:
                      require('content.php'); 
                      The session URL is necessary to stay logged in if the user has cookies disabled. It shouldn't appear unless it is necessary.

                      I just tried this but for some reason my homepage doesn't work still. http://www.yolosocial.com/

                      Any idea? I see my forum, cms and blog sub pages easily. Thank you.

                      Comment


                      • #12
                        Find out the source of the Forbidden error. That is coming from Apache.

                        If I try to go directly to index.php at: http://www.yolosocial.com/index.php then I get a 404 or File Not Found error. Did you upload index.php to your server?
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                        vBulletin 5 Documentation - Updated every Friday. Report issues here.
                        vBulletin 5 API - Full / Mobile
                        I am not currently available for vB Messenger Chats.

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X