Announcement

Collapse
No announcement yet.

Fatal error: Storing of variables is not enabled within XCache in [path]/includes/class_datastore.php

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Fatal error: Storing of variables is not enabled within XCache in [path]/includes/class_datastore.php

    I just moved my site/forums to a new server which is running php 5.4. xcache is installed on the server, however, I cannot get the forums to load and get the following error:

    Fatal error: Storing of variables is not enabled within XCache in [path]/includes/class_datastore.php

    What does this mean and how can I fix this?

    Rob

  • #2
    What's your Vbulletin version?

    Comment


    • #3
      4.2.1
      Rob

      Comment


      • #4
        You will need to upgrade to 4.2.2 (or downgrade to PHP 5.3) as PHP 5.4 is not suported for 4.2.1. Not 100% sure it would cause a fatal error but you need to sort that first.

        Comment


        • #5
          Originally posted by RobAC View Post
          I just moved my site/forums to a new server which is running php 5.4. xcache is installed on the server, however, I cannot get the forums to load and get the following error:

          Fatal error: Storing of variables is not enabled within XCache in [path]/includes/class_datastore.php

          What does this mean and how can I fix this?
          besides ideally using vB 4.2.2 latest for PHP 5.4, the error you have is most likely misconfigured Xcache settings for data caching you have disabled Xcache variable cache - i.e. if you set xcache.var_size=0 in Xcache settings as opposed to enabling it with an actual value to allocate memory to the variable cache i.e. xcache.var_size=32M and restarting apache or php service for changes to take effect
          :: Always Back Up Forum Database + Attachments BEFORE upgrading !
          :: Nginx SPDY SSL - World Flags Demo [video results]
          :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

          Comment


          • #6
            Originally posted by donald1234 View Post
            You will need to upgrade to 4.2.2 (or downgrade to PHP 5.3) as PHP 5.4 is not suported for 4.2.1. Not 100% sure it would cause a fatal error but you need to sort that first.
            The error has nothing to do with php (or vb) version.
            As George rightly points out, it means xcache is not configured correctly.
            Baby, I was born this way

            Comment


            • #7
              Originally posted by Paul M View Post

              The error has nothing to do with php (or vb) version.
              As George rightly points out, it means xcache is not configured correctly.
              I did say that the error probably has nothing to do with the PHP version but it is never the less something that needs rectifying.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X