Announcement

Collapse
No announcement yet.

Soft Deleted Posts Not Showing Who Deleted Them and Reason

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Soft Deleted Posts Not Showing Who Deleted Them and Reason

    When a post is soft deleted on my forum, mods and admins can see who deleted it and why but registered users can't. I've been looking all over the settings and I can't figure out what is not ticked. All usergroups are set to can see deletion notices except unregistered users. Can someone please point me in the right directions because I have searched the forums and Jira. I found an old issue that says it was resolved. I'm on the latest version of 4.2.1
    Vote for my suggestions here and here

  • #2
    Bumping. Does anyone have an answer? What setting am I missing or is this a bug already in Jira I have over looked?
    Vote for my suggestions here and here

    Comment


    • #3
      This function works fine on a 4.2.1 install.

      1. Create a new style & test with it.
      2. Disable your plugins via config.php

      Start with those two & report back, its either a style issue or a hack you have installed breaking it, most likely a style issue.
      Gentoo Geek

      Comment


      • #4
        Does this happen if you create a new default style with no parent?
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.5.2 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #5
          it was a fresh install of the forum on 4.2.0 I just upgraded to 4.2.1, and it is still an issue. It's not a plugin or a hack because I didn't have any installed when this issue occurred, Only plugin I have now is "VM messages default on profile". It's not a styling issue because I never removed the default style nor have I touched the default style and it is happening on that style as well. I swear there has to be a setting I am missing. I just can't seem to figure out what.
          Vote for my suggestions here and here

          Comment


          • #6
            Are all the templates in a default style set as default, there are tempaltes changes between 4.2.0 & 4.2.1, just because you didnt touch, doesnt mean its correct.

            Edit the templates for the default style & revert all of them.
            Gentoo Geek

            Comment


            • #7
              All of the templates for the default style are set to the default templates. However it cannot be a styling issue when I can see it and if I set a usergroup to super moderator level they can see it. Just no group below super moderator can see it. So it has to be a permissions issue. I just don't know where.
              Vote for my suggestions here and here

              Comment


              • #8
                Just to be sure I am being clear on what the problem is.

                Registered users and Moderators can see that a post was deleted. It just shows as a blank post by whoever originally made the post, and doesn't say who deleted it like it does for Super mods, and Administrators. If a reason is put in, the reason will show up, but that is all. Now for Super Moderator level and above, it shows the person who deleted the message and the reason if it was put in. If I switch Registered Users and Moderators to no for "Can see deletion notices" nothing is displayed.

                So registered users and moderators can see the deletion notices they just can not see who deleted them. Supermoderators and Administrators can see both the deletion notice and who deleted the message.

                My default style is experiencing this issue. It is the same style that was installed with the forum, and has never been edited. When I install a forum and create a custom style I never touch the default for the specific reason that it is always good to have a control. This issue was being experienced before the forum was upgraded, and is being experienced after the upgrade to the latest version. When I did the upgrade, I had no template version conflicts. All changes were successfully merged, so reverting the default template does nothing because vbulletin will just come back with a message that says "nothing to do" it doesn't need to be reverted because it is the correct upto date template.

                The version the forum is on now is 4.2.1. Prior to that the forum was installed on 4.2.0 PL 3
                Vote for my suggestions here and here

                Comment


                • #9
                  Bumping again.
                  Vote for my suggestions here and here

                  Comment


                  • #10
                    Still looking for a solution to this issue. Or at least a verification of a bug.
                    Vote for my suggestions here and here

                    Comment


                    • #11
                      I'm still looking for a resolution please. Any help? I've created new styles, reverted templates and it happens on all of them.
                      Vote for my suggestions here and here

                      Comment


                      • #12
                        Can someone please help me with this? I've been trying to get someone to help me for a month now. PLEASE! I'm begging you, because it is bugging the hell out of me why this isn't working.
                        Vote for my suggestions here and here

                        Comment


                        • #13
                          Who deleted the message and the reason is only available to users who have permission to manage posts via inline moderation. This means Admins, Super Moderators, and Moderators.

                          To change this, you would need to edit the postbit_deleted template. This is not a supported change. You would have to check at www.vbulletin.org if you're not fluent in vBulletin template code.
                          Translations provided by Google.

                          Wayne Luke
                          The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                          vBulletin 5 Documentation - Updated every Friday. Report issues here.
                          vBulletin 5 API - Full / Mobile
                          I am not currently available for vB Messenger Chats.

                          Comment


                          • #14
                            This helps thank you.
                            Vote for my suggestions here and here

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X