Announcement

Collapse
No announcement yet.

Vbulletin 4.2.1 Facebook Problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Vbulletin 4.2.1 Facebook Problem

    Hi all,
    I followed few guides on how to set the facebook connect to my vbulletin forum
    I can connect to the facebook but i cant publish threads or "like" threads i set everything like in the guides and in the Youtube videos and nothing working for me

    any help?

  • #2
    There are a couple of fixes you may need for Facebook until the next VB 4.x version comes out.

    If you are getting an "absolute URL required" error on the Like Button do this-

    To fix go to the Admin CP -> Plugins & Products -> Add New Plugin

    Product: vBulletin
    Hook: fb_like_button
    Title: Facebook Like Fix

    PHP Code:
    if ($show['fb_likebutton'] AND (is_browser('ie') || is_browser('opera')))
    {
    $templater->register('href'get_fbcanonicalurl());

    Set "Active" to YES and SAVE.

    The error should go away.

    This is because Facebook changed how the like button should work.



    To get the "Publish to Facebook" to like you need to update several files-

    Download the facebook SDK from https://github.com/facebook/facebook-php-sdk (choose to download the "ZIP" file and extract it)

    Upload the three files from \src to your \includes\facebook directory.



    That should fix both issues.

    Comment


    • #3
      I did everything but yet no "like" button or "publish on facebook" option
      any other ideas?

      Comment


      • #4
        My steps were for people who see the options but were getting errors after they hit like or after they checked the "Publish to Facebook" option and it didn't work.

        If you're not seeing either go to Admin CP -> Settings -> Options -> Facebook Options and make sure you have enabled the Facebook Platform, copied in your Facebook App ID and Secret, and more toward the bottom, enabled the Like Button for threads (and blogs / articles if using the Suite.)

        If still having issue can you please link to your site.

        Comment


        • #5
          Update for anyone else- The issue here was his site was closed to guests and Facebook features (Like Button and Publish to Facebook) are only available on pages open to guests- if you have a private forum the buttons won't show in that forum. If the entire site is private you won't see the buttons at all.

          Comment


          • #6
            Excuse me, I know this is six months old, but since I am facing the same problem, what do you mean by "site open to guests"? Guests can see my site, they can see the "Like" buttons in threads and when they press them they are asked to log in with they Facebook account, but the F-Connect button at the top is not doing anything. Any help would be greatly appreciated.

            I am using both Firefox and Safari on a Mac (Maverick) to test this. Results are the same in both browsers.
            John Caradimas

            Comment

            Related Topics

            Collapse

            Working...
            X