Announcement

Collapse
No announcement yet.

New post search returning blank white pages (no errors indicated)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] New post search returning blank white pages (no errors indicated)

    Title says it all...

    first appeared yesterday pm on my 4.1.0 pl1 live site, 4.1.0 pl1 test site working fine.

    I've searched these forums and done the following troubleshooting:

    backed up database.

    admincp/maintenance:
    /update counters/empty search index/rebuild search index
    /rebuild thread information/rebuild forum information/rebuild post cache
    /repair optimize tables
    /diagnostics/suspect file versions (after disabling all products and plugins excepting vb, blog, and cms as per instructions found in this forum). results were blog files that did not contain expected contents and known mod files that were not part of vbulletin.

    I then uploaded 4.1.1 (excepting image folder) using ascii transfer and ran upgrade.php which completed successfully.

    New post i.e. "What's new" or using advanced search to find all posts by a user returns a blank white page. Checked with my host to see if they had made changes on the server side and they hadn't.

    I'm at a loss. Can anyone help?

  • #2
    Please see this for all the known causes of blank or 'white' pages:

    http://www.vbulletin.com/docs/html/blank_pages
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Thanks Steve; I went thru all the troubleshooting steps to no avail but eventually, with the help of my host, was able to fix the problem.

      The fix was related to a bug in php:

      PHP Version 5.3.5-pl0-gentoo
      http://bugs.php.net/bug.php?id=51425

      Line 836 of criteria.php contained the following code

      Code:
      if (method_exists($this->search_type, 'get_display_name'))
      Changing the code line to this fixed the white page search results problem

      Code:
      if (is_object($this->search_type) && is_callable($this->search_type->get_display_name()))
      Thought vB might want to talk to the PHP people about this.



      Comment


      • #4
        Thanks for that info. I have updated the manual to add that
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Thanks for the info, will also contact my host to see if they can fix this for me...I am getting the same issue :/
          The 47 Ronin Gaming - www.47r-squad.com

          Comment


          • #6
            This was an easy fix for me. I restored my database and I got blank pages.

            To fix it:
            Go to styles and download all your styles. Then upload them and replace the originals w/ same name, etc. Hope it helps someone.

            Comment


            • #7
              Originally posted by shooterdfl View Post
              Thanks Steve; I went thru all the troubleshooting steps to no avail but eventually, with the help of my host, was able to fix the problem.

              The fix was related to a bug in php:

              PHP Version 5.3.5-pl0-gentoo
              http://bugs.php.net/bug.php?id=51425

              Line 836 of criteria.php contained the following code

              Code:
              if (method_exists($this->search_type, 'get_display_name'))
              Changing the code line to this fixed the white page search results problem

              Code:
              if (is_object($this->search_type) && is_callable($this->search_type->get_display_name()))
              Thought vB might want to talk to the PHP people about this.


              After upgrading from 3.8 to 4.1.2 and 3 search index rebuilds this was the only thing that would fix my search results as well. THANK YOU!!

              Comment


              • #8
                I believe this has been reported: http://tracker.vbulletin.com/browse/VBIV-12746
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  This thread is nearly four years old so the information is years out of date.

                  If you are running php 5.5, you need to use vBulletin 4.2.3. No earlier version of vB4 is compatible with php 5.5.
                  If you need further support, please start your own thread with full details of the issue.
                  MARK.B | vBULLETIN SUPPORT

                  TalkNewsUK - My vBulletin 5.5.2 Demo
                  AdminAmmo - My Cloud Demo

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X