Announcement

Collapse
No announcement yet.

Sitemap - Missing XML tag

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Sitemap - Missing XML tag

    Hi Gang, I get an error from Google webmaster tools
    My site map address is ok and Google seems to split the file into 2 (is this normal)?
    It sees link from the first part of the split as so :
    xmlsitemap.php?fn=vbulletin_sitemap_forum_0_33.xml.gz


    However it throws an error for the second part which is :
    xmlsitemap.php?fn=vbulletin_sitemap_thread_1_0.xml.gz

    The error is :

    Sitemap errors and warnings
    Line Status Details 2 Missing XML tag
    This required tag is missing. Please add it and resubmit. Parent tag: urlset
    Tag: url
    Problem detected on: May 15, 2010
    Could someone shed any light on this please ?

    Thanks in advance.

  • #2
    I get this as well - is there a fix?

    Comment


    • #3
      Anybody?

      Comment


      • #4
        Bumpety bump.. I'm getting this now as well. Any fix yet?
        British Filipino

        Comment


        • #5
          I cannot duplucate this.

          To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

          Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

          [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

          Next, disable all products (except vB Blog and vB CMS if you are running the Suite.)

          Admin CP -> Plugins & Products -> Manage Products -> Disable

          Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

          Admin CP -> Plugins & Products -> Plugin Manager

          You must do BOTH of those steps in order to disable all non vBulletin Modifications.

          Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

          Do you have the same problem?
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Well I have the same on a brand new install. Followed everything here (it is a forum version only) and it does the same. Someone got a fix? It is just on the "threads" xml.

            Comment


            • #7
              Start a new thread with all the relevant details, including the link to your site.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment

              Working...
              X