Announcement

Collapse
No announcement yet.

Logging In Issues

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    yes, seems fine. I've set the f parameter for emailing members to see if this helps. Other than this, I'm stumped.
    Cheers!

    RECORDING ORG
    created for musicians, by musicians

    Comment


    • #62
      Well -f parameter won't work when I have save mode disabled. I can't see it being a config issue when I get email. Could be a particular email provider is blocking their email. I'm also thinking this is related to browsers and OS of the member. Something outside vB control.
      Cheers!

      RECORDING ORG
      created for musicians, by musicians

      Comment


      • #63
        Yes all quite possible, best to find out what browser they are using, if they are using a modern one then you may have a corruption in your DB.

        Edit: Have you tried Repair / Optimize Tables?
        sigpic
        - Computer Hardware & Software Tech Support Forum - & Maternal Online | Pregnancy & Parenting Portal

        Comment


        • #64
          I have had a few reports from our clients about the issue. We work also with integrations, and users with integrations were even more affected. Basically, we found out that the issue was caused by a sudden change in vBulletin 4.0.1 cookie prefix structure. Basically, the developers added a "_" after the cookie prefix, thus effectively changing your old cookie prefix. This, coupled with integrated software that used the old prefix structure seemed to cause problems.

          Basically, I reverted the edits done by vB developers in class core to use the old cookie structure, and the issues were all gone.

          I am not sure if this applies to everybody in this thread, of course - and mine is obviously just a temporary hack.

          Basically, in includes/class_core.php, find:

          Code:
          		define('COOKIE_PREFIX', (empty($this->config['Misc']['cookieprefix']) ? 'bb' : $this->config['Misc']['cookieprefix']) . '_');
          And replace it with

          Code:
          		define('COOKIE_PREFIX', (empty($this->config['Misc']['cookieprefix']) ? 'bb' : $this->config['Misc']['cookieprefix']));
          I have not investigated if this change was done for some other purpose, so I cannot guarantee anything about this right now. We needed a fast fix, and this helped us.
          CarlitoBrigante on vb.org - MagnetiCat.com
          Professional vBulletin development, support, upgrades

          Comment


          • #65
            It would be better to report the issue to your third party developers and have them fix their code, rather than "fixing" vb's code.

            Comment


            • #66
              Zachery, that's obvious (and I did use fix referring to our situation, not to the code). But :

              1. A change like this should have been reported. There are dozens of integrations using cookies. The change went unannounced (no trace of this in 4.0.1 announcement thread), and as a result, a lot of people are having problems. My 2 cents - a lot of people in this thread are having problems because of this.
              2. A change like this should happen only for a good reason, not for code "aesthetics". So, I am just asking for the reason of this change.

              In brief, in terms of code this is a small change; in terms of real life usage of vB, this is not a secondary change. Cookies are a fundamental part of a system based on login, and that is marketed as a "framework" upon which users can build their websites. Substantially, with this release, vBulletin is forcing an "hidden" cookie change to all those running vBulletin. Is this a trifle matter, especially if you are running a huge community?

              Reporting a change like this is a matter of respect towards third party developers, as well, that benefit from vBulletin, but that also add a lot to its value.
              Last edited by DirtyHarry; Sun 31st Jan '10, 11:08am. Reason: Added stuff.
              CarlitoBrigante on vb.org - MagnetiCat.com
              Professional vBulletin development, support, upgrades

              Comment


              • #67
                Originally posted by Dankebud View Post
                I had this problem as well. What I found out thou is that if people has http://sitename.com as there bookmark but the board settings were http://www.sitename.com there would not be able to login. However, when a few of us used the site default it showed us logged in. Not sure if this points to a cookie issue, since a few of us cleared cookies prior with no luck.
                I'm starting to have login problems after i'v changed my preferred domain from " http://www.asiaphoto.com " to " http://asiaphoto.com " instead.
                i set up redirects in my .htaccess ( 301 )

                in my current situation, i can't even log in as administrator, otherwise i can configure AdminCP > Options > Settings > Cookies and HTTP Header Options > Cookie Domain?

                what should i do?

                reset my .htaccess to revert back the preference to www ?

                Comment


                • #68
                  Have you tried changing the cookie prefix in config.php so that it's not trying to use the older invalid one?
                  Vote for:

                  - *Admin Settable Paid Subscription Reminder Timeframe*
                  -
                  *PM - Add ability to reply to originator only*
                  - Add Admin ability to auto-subscribe users to specific channel(s)
                  - Highlight the correct navigation tab when you are on a custom page
                  - "Quick Route" Interface...
                  - Allow to use custom icons for individual forums

                  Comment


                  • #69
                    anyone manage to fix this and if so which 'fix' did you use, i see alot of suggestions but very few people coming back and saying it has worked for them.

                    I am having the same issues

                    Comment


                    • #70
                      If you're ahving cookie issues start your own thread.

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X