Announcement

Collapse
No announcement yet.

Moving to a new server with different PHP and mysql charset

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Moving to a new server with different PHP and mysql charset

    I want to move my vb 4.2.5 (and another one 3.8.11) to a new server.


    Old server:

    Debian 8.11

    PHP 5.6.38-0+deb8u1 (cli) (built: Sep 20 2018 02:32:02)
    Copyright (c) 1997-2016 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with XCache v3.2.0, Copyright (c) 2005-2014, by mOo
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies
    with XCache Optimizer v3.2.0, Copyright (c) 2005-2014, by mOo
    with XCache Cacher v3.2.0, Copyright (c) 2005-2014, by mOo
    with XCache Coverager v3.2.0, Copyright (c) 2005-2014, by mOo

    mysql Ver 14.14 Distrib 5.6.41, for Linux (x86_64) using EditLine wrapper


    DB: latin1_swedisch_ci MyISAM



    New Server:

    Debian 9.5

    PHP 7.0.30-0+deb9u1 (cli) (built: Jun 14 2018 13:50:25) ( NTS )
    Copyright (c) 1997-2017 The PHP Group
    Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.0.30-0+deb9u1, Copyright (c) 1999-2017, by Zend Technologies

    mysql Ver 15.1 Distrib 10.1.26-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2

    UTF8


    I tried different export / import stuff, but I was never able to get rid of the UTF8 Problem. The Umlaute where never right.

    What do I have to do to transfer the forum to the new server and get all the data (UTF8) right?

    Thanks in advance.




  • #2
    Just changing the character set and collation of the database won't change the imported data. You'll need to import the data as latin1_swedish_ci and then convert it on the new server. Each table and every field in each table. As tech support, we have scripts to convert a vBulletin 5 database but not a vBulletin 4 database.

    What is your specific UTF-8 problem?
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      The umlaute will be shown as ?. Instead of an "ö" I do have an "?".

      I did export it but I didnt convert it.

      Comment


      • #4
        Open your vBulletin AdminCP. Go to Languages & Phrases -> Language Manager. Edit your language. Change the HTML Character Set from ISO-8859-1 (doesn't support extended characters) to UTF-8 (Case Sensitive).

        Make sure you're using a UTF-8 font in your style. Not all fonts support UTF-8.

        What happens after you do this?
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud customization and demonstration site.
        vBulletin 5 Documentation - Updated every Friday. Report issues here.
        vBulletin 5 API - Full / Mobile
        I am not currently available for vB Messenger Chats.

        Comment


        • #5
          Originally posted by Marius974 View Post
          The umlaute will be shown as ?. Instead of an "ö" I do have an "?".

          I did export it but I didnt convert it.
          Richtig, brauchst du auch nicht, wird auch so nicht ohne viel Ärger funktionieren.

          Gehe so vor.
          Exportiere deine Datenbank auf dem alten Server in eine SQL Datei.
          Kopiere alle Dateien des alten Servers auf den Neuen, am besten mittels rsync.
          Achte peinlich genau darauf dass die Pfade und Rechte des alten Servers genau so wieder auf den neuen Server erstellt werden.
          Lege die gleichen Benutzer wie auf dem alten Server, auch auf dem neuen Server an. Importiere nun die auf dem alten Server erstellte SQL-Datei in denen SQLServer. Achte auch hier darauf dass die neue Datenbank exakt so benannt wird wie dies auf dem alten Server der Fall war.

          Es spiel übrigens auch keine Rolle ob die Datenbankverbindung des neuen Servers UTF8 nutzt. Wichtig ist dass in der neuen Datenbank alles so importiert wird wie es auf dem alten Server war.

          Nun, wenn alle Pfade und Rechte auf dem neuen Server so gesetzt sind wie das im alten Server der Fall war sollte dein Forum exakt so laufen wie zuvor.

          Wie ich gerade ERST SEHE nutzt du auf dem neuen Server PHP7. Dann solltest du dich darauf vorbereiten dass es zu Problemen mit Addons kommen kann. An besten du startest das Forum erstmal mit deaktivierten Addons, loggt dich ein und aktiviert dann die Addons nach und nach wieder.

          Mein vB 3.8.11 läuft mit deaktivierten Addons selbst mit PHP 7.2. wenn man die "Warnings" im Log ignoriert, die keine negativen Auswirkungen haben. Mit Addons muss ich auf PHP 7.1 zurück, wobei auch schon der Wechsel von php 6.x auf 7.1 die Anpassungen einiger Addons erforderte.
          Last edited by MasetX; Sat 13th Oct '18, 3:39am. Reason: EDIT...

          Comment


          • #6
            Danke MasteX.

            Ich habe in den letzten schon einige Serverumzüge hinter mir und bin immer gleich vorgegangen. Dies ist jetzt das erste mal dass ich auf solche Probleme gestossen bin. Ich habe es jetzt allerdings gerade eben hinbekommen!

            so, ich habs!

            1. Export SQL old DB
            2. new DB "ALTER DATABASE datenbasename CHARACTER SET latin1 COLLATE latin1_swedish_ci;"
            3. Import SQL
            4. Download language pack from the member area and copy the files in the "install" directory on the server
            5. enter your URL with "/install/upgrade.php?version=final"
            6. Delete "install" directory after you finished the installation
            7. At the ACP "Language manager" "settings" klicken und unter "HTML-Characters" (or similar) enter "UTF-8"

            and its working again

            Thank you!

            Comment


            • #7
              Originally posted by Marius974 View Post
              Danke MasteX.

              Ich habe in den letzten schon einige Serverumzüge hinter mir und bin immer gleich vorgegangen. Dies ist jetzt das erste mal dass ich auf solche Probleme gestossen bin. Ich habe es jetzt allerdings gerade eben hinbekommen!

              so, ich habs!

              1. Export SQL old DB
              2. new DB "ALTER DATABASE datenbasename CHARACTER SET latin1 COLLATE latin1_swedish_ci;"
              3. Import SQL
              4. Download language pack from the member area and copy the files in the "install" directory on the server
              5. enter your URL with "/install/upgrade.php?version=final"
              6. Delete "install" directory after you finished the installation
              7. At the ACP "Language manager" "settings" klicken und unter "HTML-Characters" (or similar) enter "UTF-8"

              and its working again

              Thank you!
              Yes, this is correct course of action and correlates what I said in my previous posts.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud customization and demonstration site.
              vBulletin 5 Documentation - Updated every Friday. Report issues here.
              vBulletin 5 API - Full / Mobile
              I am not currently available for vB Messenger Chats.

              Comment

              Related Topics

              Collapse

              Working...
              X